diff options
author | Lokesh Vutla <lokeshvutla@ti.com> | 2021-05-17 22:56:11 +0000 |
---|---|---|
committer | Praneeth Bajjuri <praneeth@ti.com> | 2021-05-17 17:37:22 -0500 |
commit | 0a7997966f160ffa8b889fa1864355058c3a11e5 (patch) | |
tree | 0f2d86ecaedffcd68257c14958b8d73efb80495c | |
parent | 33ad83a1de45d78a00a11ec2f3160fba5811c28e (diff) | |
download | meta-ti-0a7997966f160ffa8b889fa1864355058c3a11e5.tar.gz |
machine: am64xx-sk: Drop am64xx-sk Machine support
With U-Boot supporting both am64xx-evm and am64xx-sk with single
defconfig, there is not need for a new machine for am64xx-sk.
So, drop support for am64xx-sk machine.
Signed-off-by: Lokesh Vutla <lokeshvutla@ti.com>
-rw-r--r-- | conf/machine/am64xx-sk-k3r5.conf | 11 | ||||
-rw-r--r-- | conf/machine/am64xx-sk.conf | 11 | ||||
-rw-r--r-- | recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | 17 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-ti.inc | 6 |
4 files changed, 0 insertions, 45 deletions
diff --git a/conf/machine/am64xx-sk-k3r5.conf b/conf/machine/am64xx-sk-k3r5.conf deleted file mode 100644 index 07ca5902..00000000 --- a/conf/machine/am64xx-sk-k3r5.conf +++ /dev/null | |||
@@ -1,11 +0,0 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: AM64xx SK (R5F) | ||
3 | #@DESCRIPTION: Machine configuration for the TI AM64xx SK (R5F core) | ||
4 | |||
5 | require conf/machine/include/k3r5.inc | ||
6 | |||
7 | SYSFW_SOC = "am64x" | ||
8 | SYSFW_CONFIG = "evm" | ||
9 | SYSFW_SUFFIX = "gp" | ||
10 | |||
11 | UBOOT_MACHINE = "am64x_sk_r5_defconfig" | ||
diff --git a/conf/machine/am64xx-sk.conf b/conf/machine/am64xx-sk.conf deleted file mode 100644 index 445ff723..00000000 --- a/conf/machine/am64xx-sk.conf +++ /dev/null | |||
@@ -1,11 +0,0 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: AM64xx SK | ||
3 | #@DESCRIPTION: Machine configuration for the TI AM64xx SK board | ||
4 | |||
5 | require conf/machine/include/am64xx.inc | ||
6 | |||
7 | UBOOT_MACHINE = "am64x_sk_a53_defconfig" | ||
8 | |||
9 | KERNEL_DEVICETREE = " \ | ||
10 | ti/k3-am642-sk.dtb \ | ||
11 | " | ||
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb index e6fa460c..87fdec68 100644 --- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb +++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | |||
@@ -3,7 +3,6 @@ require recipes-bsp/ti-sci-fw/ti-sci-fw.inc | |||
3 | DEPENDS = "openssl-native u-boot-mkimage-native dtc-native" | 3 | DEPENDS = "openssl-native u-boot-mkimage-native dtc-native" |
4 | DEPENDS_append_j7200-evm-k3r5 = " virtual/bootloader" | 4 | DEPENDS_append_j7200-evm-k3r5 = " virtual/bootloader" |
5 | DEPENDS_append_am64xx-evm-k3r5 = " virtual/bootloader" | 5 | DEPENDS_append_am64xx-evm-k3r5 = " virtual/bootloader" |
6 | DEPENDS_append_am64xx-sk-k3r5 = " virtual/bootloader" | ||
7 | 6 | ||
8 | CLEANBROKEN = "1" | 7 | CLEANBROKEN = "1" |
9 | PR = "r1" | 8 | PR = "r1" |
@@ -54,7 +53,6 @@ EXTRA_OEMAKE_append = "${@['',' ${EXTRA_OEMAKE_HS}']['${SYSFW_SUFFIX}' == 'hs']} | |||
54 | 53 | ||
55 | EXTRA_OEMAKE_append_j7200-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" | 54 | EXTRA_OEMAKE_append_j7200-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" |
56 | EXTRA_OEMAKE_append_am64xx-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" | 55 | EXTRA_OEMAKE_append_am64xx-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" |
57 | EXTRA_OEMAKE_append_am64xx-sk-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" | ||
58 | 56 | ||
59 | do_compile() { | 57 | do_compile() { |
60 | cd ${WORKDIR}/imggen/ | 58 | cd ${WORKDIR}/imggen/ |
@@ -117,19 +115,4 @@ do_deploy_am64xx-evm-k3r5() { | |||
117 | install -m 644 ${SYSFW_TISCI} ${DEPLOYDIR}/ | 115 | install -m 644 ${SYSFW_TISCI} ${DEPLOYDIR}/ |
118 | } | 116 | } |
119 | 117 | ||
120 | do_install_am64xx-sk-k3r5() { | ||
121 | install -d ${D}/boot | ||
122 | install -m 644 ${WORKDIR}/imggen/${UBOOT_BINARY} ${D}/boot/${UBOOT_IMAGE} | ||
123 | ln -sf ${UBOOT_IMAGE} ${D}/boot/${UBOOT_SYMLINK} | ||
124 | ln -sf ${UBOOT_IMAGE} ${D}/boot/${UBOOT_BINARY} | ||
125 | } | ||
126 | |||
127 | do_deploy_am64xx-sk-k3r5() { | ||
128 | install -d ${DEPLOYDIR} | ||
129 | install -m 644 ${WORKDIR}/imggen/${UBOOT_BINARY} ${DEPLOYDIR}/${UBOOT_IMAGE} | ||
130 | ln -sf ${UBOOT_IMAGE} ${DEPLOYDIR}/${UBOOT_SYMLINK} | ||
131 | ln -sf ${UBOOT_IMAGE} ${DEPLOYDIR}/${UBOOT_BINARY} | ||
132 | install -m 644 ${SYSFW_TISCI} ${DEPLOYDIR}/ | ||
133 | } | ||
134 | |||
135 | addtask deploy before do_build after do_compile | 118 | addtask deploy before do_build after do_compile |
diff --git a/recipes-bsp/u-boot/u-boot-ti.inc b/recipes-bsp/u-boot/u-boot-ti.inc index e5f92f4b..dc8d6b06 100644 --- a/recipes-bsp/u-boot/u-boot-ti.inc +++ b/recipes-bsp/u-boot/u-boot-ti.inc | |||
@@ -66,7 +66,6 @@ SPL_UART_BINARY_k3r5 = "" | |||
66 | SPL_UART_BINARY_lego-ev3 = "" | 66 | SPL_UART_BINARY_lego-ev3 = "" |
67 | SPL_UART_BINARY_j7200-evm-k3r5 = "u-boot-spl.bin" | 67 | SPL_UART_BINARY_j7200-evm-k3r5 = "u-boot-spl.bin" |
68 | SPL_UART_BINARY_am64xx-evm-k3r5 = "u-boot-spl.bin" | 68 | SPL_UART_BINARY_am64xx-evm-k3r5 = "u-boot-spl.bin" |
69 | SPL_UART_BINARY_am64xx-sk-k3r5 = "u-boot-spl.bin" | ||
70 | 69 | ||
71 | SPL_UART_IMAGE ?= "${SPL_UART_BINARY}-${MACHINE}-${PV}-${PR}" | 70 | SPL_UART_IMAGE ?= "${SPL_UART_BINARY}-${MACHINE}-${PV}-${PR}" |
72 | SPL_UART_SYMLINK ?= "${SPL_UART_BINARY}-${MACHINE}" | 71 | SPL_UART_SYMLINK ?= "${SPL_UART_BINARY}-${MACHINE}" |
@@ -402,9 +401,4 @@ do_deploy_append_am64xx-evm-k3r5 () { | |||
402 | mv ${DEPLOYDIR}/u-boot-spl.bin ${DEPLOYDIR}/u-boot-spl-r5spl.bin || true | 401 | mv ${DEPLOYDIR}/u-boot-spl.bin ${DEPLOYDIR}/u-boot-spl-r5spl.bin || true |
403 | } | 402 | } |
404 | 403 | ||
405 | do_deploy_append_am64xx-sk-k3r5 () { | ||
406 | mv ${DEPLOYDIR}/tiboot3.bin ${DEPLOYDIR}/tiboot3-r5spl.bin || true | ||
407 | mv ${DEPLOYDIR}/u-boot-spl.bin ${DEPLOYDIR}/u-boot-spl-r5spl.bin || true | ||
408 | } | ||
409 | |||
410 | TOOLCHAIN = "gcc" | 404 | TOOLCHAIN = "gcc" |