summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-09-08 20:20:54 +0000
committerRyan Eatmon <reatmon@ti.com>2022-09-11 14:44:47 -0500
commit8e1d209ef752174c3841dd695ca822a51249ac71 (patch)
tree1d801053fa84d3f484f45a30a430495da27d308c
parenta735f8bb1e0100f8a4e502a56d11ef2dd8aca82d (diff)
downloadmeta-ti-8e1d209ef752174c3841dd695ca822a51249ac71.tar.gz
linux-ti-mainline: unbreak devtool
devtool has a long-standing bug where it cannot handle references to ${WORKDIR} due to externalsrc: https://bugzilla.yoctoproject.org/show_bug.cgi?id=12677 linux-ti-mainline clones additional ti-upstream-tools repo alongside the kernel sources into ${WORKDIR}, which exposes this devtool bug. Work around the issue by moving ti-upstream-tools inside the kernel source tree, i.e. inside ${S} Reported-by: Radoslav Pesek <radoslav.pesek@microstep-mis.com> Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--recipes-kernel/linux/linux-ti-mainline_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-kernel/linux/linux-ti-mainline_git.bb b/recipes-kernel/linux/linux-ti-mainline_git.bb
index 3b7ad885..e8e5cd03 100644
--- a/recipes-kernel/linux/linux-ti-mainline_git.bb
+++ b/recipes-kernel/linux/linux-ti-mainline_git.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
5 5
6inherit kernel 6inherit kernel
7 7
8DEFCONFIG_BUILDER = "${WORKDIR}/ti-upstream-tools/config/defconfig_builder.sh" 8DEFCONFIG_BUILDER = "${S}/ti-upstream-tools/config/defconfig_builder.sh"
9require recipes-kernel/linux/setup-defconfig.inc 9require recipes-kernel/linux/setup-defconfig.inc
10require recipes-kernel/linux/kernel-rdepends.inc 10require recipes-kernel/linux/kernel-rdepends.inc
11require recipes-kernel/linux/ti-kernel.inc 11require recipes-kernel/linux/ti-kernel.inc
@@ -32,7 +32,7 @@ KERNEL_GIT_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.g
32KERNEL_GIT_PROTOCOL = "https" 32KERNEL_GIT_PROTOCOL = "https"
33SRC_URI += " \ 33SRC_URI += " \
34 ${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH};name=linux \ 34 ${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH};name=linux \
35 git://git.ti.com/git/ti-linux-kernel/ti-upstream-tools.git;branch=${TOOLS_BRANCH};protocol=${KERNEL_GIT_PROTOCOL};name=ti-upstream-tools;destsuffix=ti-upstream-tools \ 35 git://git.ti.com/git/ti-linux-kernel/ti-upstream-tools.git;branch=${TOOLS_BRANCH};protocol=${KERNEL_GIT_PROTOCOL};name=ti-upstream-tools;destsuffix=git/ti-upstream-tools \
36 file://defconfig \ 36 file://defconfig \
37" 37"
38 38
@@ -43,7 +43,7 @@ KERNEL_DEVICETREE = ""
43 43
44kernel_do_compile_append() { 44kernel_do_compile_append() {
45 oe_runmake dtbs CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS} 45 oe_runmake dtbs CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS}
46 oe_runmake -C ${WORKDIR}/ti-upstream-tools LINUX=${S} DTC=${B}/scripts/dtc/dtc O=${B} CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS} 46 oe_runmake -C ${S}/ti-upstream-tools LINUX=${S} DTC=${B}/scripts/dtc/dtc O=${B} CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS}
47} 47}
48 48
49do_install_append() { 49do_install_append() {