summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2022-08-11 20:41:26 -0500
committerRyan Eatmon <reatmon@ti.com>2022-08-26 14:33:15 -0500
commita5cb2b74b47801e6653510a78ed90003c25e2530 (patch)
tree3abf39198a549d8728d8e54d4b6cfd3c35dcbaf8
parent015a440a80d4db33b82fa4ee2c912da073cb4bc7 (diff)
downloadmeta-ti-a5cb2b74b47801e6653510a78ed90003c25e2530.tar.gz
recipies-ti: Add TI K3 Security Development Package
Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--recipes-ti/includes/ti-paths.inc2
-rw-r--r--recipes-ti/secdev/ti-k3-secdev_git.bb36
2 files changed, 38 insertions, 0 deletions
diff --git a/recipes-ti/includes/ti-paths.inc b/recipes-ti/includes/ti-paths.inc
index 52a93cf5..44731a4e 100644
--- a/recipes-ti/includes/ti-paths.inc
+++ b/recipes-ti/includes/ti-paths.inc
@@ -61,6 +61,7 @@ export TI_CGT6X_7_INSTALL_DIR_RECIPE = "${installdir}/cgt6x-7"
61export GCC_LINARO_BAREMETAL_TOOLCHAIN_RECIPE = "${installdir}/gcc-linaro-baremetal" 61export GCC_LINARO_BAREMETAL_TOOLCHAIN_RECIPE = "${installdir}/gcc-linaro-baremetal"
62export GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN_RECIPE = "${installdir}/gcc-linaro-baremetal-aarch64" 62export GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN_RECIPE = "${installdir}/gcc-linaro-baremetal-aarch64"
63export TI_CGT7X_INSTALL_DIR_RECIPE = "${installdir}/cgt-c7x" 63export TI_CGT7X_INSTALL_DIR_RECIPE = "${installdir}/cgt-c7x"
64export TI_K3_SECDEV_INSTALL_DIR_RECIPE = "${installdir}/ti-k3-secdev"
64 65
65 66
66# This is where the tools will end up in sysroot 67# This is where the tools will end up in sysroot
@@ -116,6 +117,7 @@ export TI_CGT6X_7_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_CGT6X_7_INSTALL_DIR
116export GCC_LINARO_BAREMETAL_TOOLCHAIN = "${STAGING_DIR_NATIVE}${GCC_LINARO_BAREMETAL_TOOLCHAIN_RECIPE}" 117export GCC_LINARO_BAREMETAL_TOOLCHAIN = "${STAGING_DIR_NATIVE}${GCC_LINARO_BAREMETAL_TOOLCHAIN_RECIPE}"
117export GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN = "${STAGING_DIR_NATIVE}${GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN_RECIPE}" 118export GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN = "${STAGING_DIR_NATIVE}${GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN_RECIPE}"
118export TI_CGT7X_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_CGT7X_INSTALL_DIR_RECIPE}" 119export TI_CGT7X_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_CGT7X_INSTALL_DIR_RECIPE}"
120export TI_K3_SECDEV_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_K3_SECDEV_INSTALL_DIR_RECIPE}"
119 121
120 122
121DSPSUFFIX_omapl137 = "x674" 123DSPSUFFIX_omapl137 = "x674"
diff --git a/recipes-ti/secdev/ti-k3-secdev_git.bb b/recipes-ti/secdev/ti-k3-secdev_git.bb
new file mode 100644
index 00000000..28dbe9ee
--- /dev/null
+++ b/recipes-ti/secdev/ti-k3-secdev_git.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "Security development tools for High-Security(HS) TI K3 processors."
2HOMEPAGE = "https://git.ti.com/cgit/security-development-tools/core-secdev-k3"
3SECTION = "devel"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://manifest/k3-secdev-0.2-manifest.html;md5=f632a78870cc64550078d7b3cbac0892"
6
7# Native host tool only
8COMPATIBLE_MACHINE = "null"
9COMPATIBLE_MACHINE_class-native = "(.*)"
10COMPATIBLE_MACHINE_class-nativesdk = "(.*)"
11
12GIT_URI = "git://git.ti.com/git/security-development-tools/core-secdev-k3.git"
13GIT_PROTOCOL = "https"
14GIT_BRANCH = "master"
15GIT_SRCREV = "eb2c4d734487e5095b94cef3fd7213ee71d9e016"
16
17SRC_URI = "${GIT_URI};protocol=${GIT_PROTOCOL};branch=${GIT_BRANCH}"
18SRCREV = "${GIT_SRCREV}"
19
20S = "${WORKDIR}/git"
21
22do_install() {
23 CP_ARGS="-Prf --preserve=mode,links,timestamps --no-preserve=ownership"
24 install -d ${D}${TI_K3_SECDEV_INSTALL_DIR_RECIPE}
25 cp ${CP_ARGS} ${S}/* ${D}${TI_K3_SECDEV_INSTALL_DIR_RECIPE}
26}
27
28FILES_${PN} += "${TI_K3_SECDEV_INSTALL_DIR_RECIPE}"
29
30INSANE_SKIP_${PN} = "arch ldflags file-rdeps"
31
32INHIBIT_PACKAGE_STRIP = "1"
33INHIBIT_SYSROOT_STRIP = "1"
34INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
35
36BBCLASSEXTEND = "native nativesdk"