summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-10-18 02:15:56 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-10-17 22:48:34 +0000
commitb2d62f62bb6ecbb07577a0af9438bcaa017bf1da (patch)
tree768143c3403cc6ef78cd44119d25a59898b83483
parent934fed368d0b6f2880d7e9768176a541a9bc189a (diff)
downloadmeta-ti-b2d62f62bb6ecbb07577a0af9438bcaa017bf1da.tar.gz
recipes: Limit ti specific recipes under ti-soc override
This helps in multi-BSP scenario, where other BSP layers are also present in the layermix Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bb2
-rw-r--r--recipes-bsp/cmem/cmem.inc2
-rw-r--r--recipes-bsp/cuia/cuia_1.0.0.13.bb3
-rw-r--r--recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb3
-rw-r--r--recipes-bsp/x-load/x-load_git.bb3
-rw-r--r--recipes-graphics/gbm/libgbm_10.0.0.bb3
-rw-r--r--recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb3
-rw-r--r--recipes-graphics/omapfbplay/omapfbplay.inc2
-rw-r--r--recipes-multimedia/libdce/libdce_3.00.14.00.bb3
-rw-r--r--recipes-ti/bios/ti-biosutils_1.02.02.bb3
-rw-r--r--recipes-ti/devtools/ti-xdctools-common.inc5
-rw-r--r--recipes-ti/dmai/ti-dmai_svn.bb3
-rw-r--r--recipes-ti/dsplib/dsplib.inc2
-rw-r--r--recipes-ti/hdvpss/ti-hdvpss_01.00.01.27.bb3
-rw-r--r--recipes-ti/includes/ti-unpack.inc4
-rw-r--r--recipes-ti/ipc/ti-ipc-common.inc2
-rw-r--r--recipes-ti/linuxutils/ti-linuxutils_2.26.01.02.bb3
-rw-r--r--recipes-ti/mathlib/mathlib.inc2
-rw-r--r--recipes-ti/ndk/ti-ndk_3.40.01.01.bb3
-rw-r--r--recipes-ti/osal/ti-osal.inc3
-rw-r--r--recipes-ti/swtools/swtools_git.bb2
21 files changed, 58 insertions, 1 deletions
diff --git a/recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bb b/recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bb
index 93cebd71..b9a3b0fa 100644
--- a/recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bb
+++ b/recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bb
@@ -24,3 +24,5 @@ do_install() {
24} 24}
25 25
26FILES_${PN} += "${base_libdir}/firmware" 26FILES_${PN} += "${base_libdir}/firmware"
27COMPATIBLE_HOST ?= "null"
28COMPATIBLE_HOST_ti-soc = "(.*)"
diff --git a/recipes-bsp/cmem/cmem.inc b/recipes-bsp/cmem/cmem.inc
index 11cebe8d..abbf2492 100644
--- a/recipes-bsp/cmem/cmem.inc
+++ b/recipes-bsp/cmem/cmem.inc
@@ -12,3 +12,5 @@ PV = "4.15.00.02+git${SRCPV}"
12SRC_URI = "git://git.ti.com/ipc/ludev.git;protocol=git;branch=${BRANCH}" 12SRC_URI = "git://git.ti.com/ipc/ludev.git;protocol=git;branch=${BRANCH}"
13 13
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
15COMPATIBLE_HOST ?= "null"
16COMPATIBLE_HOST_ti-soc = "(.*)"
diff --git a/recipes-bsp/cuia/cuia_1.0.0.13.bb b/recipes-bsp/cuia/cuia_1.0.0.13.bb
index e048f6aa..a7caf504 100644
--- a/recipes-bsp/cuia/cuia_1.0.0.13.bb
+++ b/recipes-bsp/cuia/cuia_1.0.0.13.bb
@@ -23,3 +23,6 @@ do_install() {
23 cd ${S} 23 cd ${S}
24 oe_runmake DESTDIR=${D} libdir=${libdir} includedir=${includedir} install 24 oe_runmake DESTDIR=${D} libdir=${libdir} includedir=${includedir} install
25} 25}
26
27COMPATIBLE_HOST ?= "null"
28COMPATIBLE_HOST_ti-soc = "(.*)"
diff --git a/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb b/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
index 94485b6a..d29b6496 100644
--- a/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
+++ b/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
@@ -22,3 +22,6 @@ do_install() {
22 install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/extra 22 install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/extra
23 install -m 644 ${S}/galcore.ko ${D}/${base_libdir}/modules/${KERNEL_VERSION}/extra 23 install -m 644 ${S}/galcore.ko ${D}/${base_libdir}/modules/${KERNEL_VERSION}/extra
24} 24}
25
26COMPATIBLE_HOST ?= "null"
27COMPATIBLE_HOST_ti-soc = "(.*)"
diff --git a/recipes-bsp/x-load/x-load_git.bb b/recipes-bsp/x-load/x-load_git.bb
index dd8bce2d..1ce1b0f0 100644
--- a/recipes-bsp/x-load/x-load_git.bb
+++ b/recipes-bsp/x-load/x-load_git.bb
@@ -17,3 +17,6 @@ CONFIG_HEADER_beagleboard = "1"
17XLOAD_MACHINE_omap3-touchbook = "omap3530beagle_config" 17XLOAD_MACHINE_omap3-touchbook = "omap3530beagle_config"
18 18
19PACKAGE_ARCH = "${MACHINE_ARCH}" 19PACKAGE_ARCH = "${MACHINE_ARCH}"
20
21COMPATIBLE_HOST ?= "null"
22COMPATIBLE_HOST_ti-soc = "(.*)"
diff --git a/recipes-graphics/gbm/libgbm_10.0.0.bb b/recipes-graphics/gbm/libgbm_10.0.0.bb
index 38715ccf..9e3c7ed0 100644
--- a/recipes-graphics/gbm/libgbm_10.0.0.bb
+++ b/recipes-graphics/gbm/libgbm_10.0.0.bb
@@ -16,3 +16,6 @@ SRC_URI = "git://git.ti.com/glsdk/libgbm.git;protocol=git;branch=${BRANCH} \
16 file://0001-gbm.c-include-sys-sysmacros.h-for-minor-major-in-new.patch" 16 file://0001-gbm.c-include-sys-sysmacros.h-for-minor-major-in-new.patch"
17 17
18S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
19
20COMPATIBLE_HOST ?= "null"
21COMPATIBLE_HOST_ti-soc = "(.*)"
diff --git a/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb b/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb
index dafaac1e..a2f8f192 100644
--- a/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb
+++ b/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb
@@ -37,3 +37,6 @@ do_install() {
37} 37}
38 38
39INSANE_SKIP_${PN} += "ldflags" 39INSANE_SKIP_${PN} += "ldflags"
40
41COMPATIBLE_HOST ?= "null"
42COMPATIBLE_HOST_ti-soc = "(.*)"
diff --git a/recipes-graphics/omapfbplay/omapfbplay.inc b/recipes-graphics/omapfbplay/omapfbplay.inc
index df166dd3..744eb8f7 100644
--- a/recipes-graphics/omapfbplay/omapfbplay.inc
+++ b/recipes-graphics/omapfbplay/omapfbplay.inc
@@ -14,6 +14,8 @@ SRC_URI = "git://git.mansr.com/omapfbplay;protocol=git \
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
15 15
16PACKAGE_ARCH = "${MACHINE_ARCH}" 16PACKAGE_ARCH = "${MACHINE_ARCH}"
17COMPATIBLE_HOST ?= "null"
18COMPATIBLE_HOST_ti-soc = "(.*)"
17 19
18# We want a kernel header for armv7a, but we don't want to make mplayer machine specific for that 20# We want a kernel header for armv7a, but we don't want to make mplayer machine specific for that
19STAGING_KERNEL_DIR = "${STAGING_DIR}/${MACHINE_ARCH}${TARGET_VENDOR}-${TARGET_OS}/kernel" 21STAGING_KERNEL_DIR = "${STAGING_DIR}/${MACHINE_ARCH}${TARGET_VENDOR}-${TARGET_OS}/kernel"
diff --git a/recipes-multimedia/libdce/libdce_3.00.14.00.bb b/recipes-multimedia/libdce/libdce_3.00.14.00.bb
index 04c0b718..4d032422 100644
--- a/recipes-multimedia/libdce/libdce_3.00.14.00.bb
+++ b/recipes-multimedia/libdce/libdce_3.00.14.00.bb
@@ -13,3 +13,6 @@ PR = "r1"
13 13
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
15EXTRA_OECONF += "IPC_HEADERS=${STAGING_INCDIR}/ti/ipc/mm" 15EXTRA_OECONF += "IPC_HEADERS=${STAGING_INCDIR}/ti/ipc/mm"
16
17COMPATIBLE_HOST ?= "null"
18COMPATIBLE_HOST_ti-soc = "(.*)"
diff --git a/recipes-ti/bios/ti-biosutils_1.02.02.bb b/recipes-ti/bios/ti-biosutils_1.02.02.bb
index 5b6b4f43..01c070d7 100644
--- a/recipes-ti/bios/ti-biosutils_1.02.02.bb
+++ b/recipes-ti/bios/ti-biosutils_1.02.02.bb
@@ -7,3 +7,6 @@ SRC_URI[biosutilstarball.md5sum] = "0654e9e72b0a6fc7a6575829c0cd90c9"
7SRC_URI[biosutilstarball.sha256sum] = "df486500bdc8dbe3800fc7efe4241e6fa5b1827ba7c0dc17a71b41d42ef921e1" 7SRC_URI[biosutilstarball.sha256sum] = "df486500bdc8dbe3800fc7efe4241e6fa5b1827ba7c0dc17a71b41d42ef921e1"
8 8
9INSANE_SKIP_${PN} = "installed-vs-shipped" 9INSANE_SKIP_${PN} = "installed-vs-shipped"
10
11COMPATIBLE_HOST ?= "null"
12COMPATIBLE_HOST_ti-soc = "(.*)"
diff --git a/recipes-ti/devtools/ti-xdctools-common.inc b/recipes-ti/devtools/ti-xdctools-common.inc
index a3949cad..27f8f908 100644
--- a/recipes-ti/devtools/ti-xdctools-common.inc
+++ b/recipes-ti/devtools/ti-xdctools-common.inc
@@ -61,3 +61,8 @@ libhpi.so \
61lib.so \ 61lib.so \
62libcairo.so.2 \ 62libcairo.so.2 \
63" 63"
64
65COMPATIBLE_HOST ?= "null"
66COMPATIBLE_HOST_ti-soc = "(.*)"
67COMPATIBLE_HOST_class-native = "(.*)"
68COMPATIBLE_HOST_class-nativesdk = "(.*)"
diff --git a/recipes-ti/dmai/ti-dmai_svn.bb b/recipes-ti/dmai/ti-dmai_svn.bb
index 4a91b9b9..3cc54b91 100644
--- a/recipes-ti/dmai/ti-dmai_svn.bb
+++ b/recipes-ti/dmai/ti-dmai_svn.bb
@@ -38,3 +38,6 @@ SRC_URI_append = " file://omap3530-r642-remove-include-videodev.diff;striplevel=
38 " 38 "
39 39
40INSANE_SKIP_${PN} = "installed-vs-shipped" 40INSANE_SKIP_${PN} = "installed-vs-shipped"
41
42COMPATIBLE_HOST ?= "null"
43COMPATIBLE_HOST_ti-soc = "(.*)"
diff --git a/recipes-ti/dsplib/dsplib.inc b/recipes-ti/dsplib/dsplib.inc
index f3696795..a3953105 100644
--- a/recipes-ti/dsplib/dsplib.inc
+++ b/recipes-ti/dsplib/dsplib.inc
@@ -69,3 +69,5 @@ ALLOW_EMPTY_${PN} = "1"
69FILES_${PN}-dev += "${DSPLIB_INSTALL_DIR_RECIPE}" 69FILES_${PN}-dev += "${DSPLIB_INSTALL_DIR_RECIPE}"
70 70
71INSANE_SKIP_${PN}-dev = "arch" 71INSANE_SKIP_${PN}-dev = "arch"
72COMPATIBLE_HOST ?= "null"
73COMPATIBLE_HOST_ti-soc = "(.*)"
diff --git a/recipes-ti/hdvpss/ti-hdvpss_01.00.01.27.bb b/recipes-ti/hdvpss/ti-hdvpss_01.00.01.27.bb
index e3b1c56f..88b08442 100644
--- a/recipes-ti/hdvpss/ti-hdvpss_01.00.01.27.bb
+++ b/recipes-ti/hdvpss/ti-hdvpss_01.00.01.27.bb
@@ -3,4 +3,5 @@ require ti-hdvpss.inc
3SRC_URI[md5sum] = "6db908bef3b933dc8cea666564d5d4d8" 3SRC_URI[md5sum] = "6db908bef3b933dc8cea666564d5d4d8"
4SRC_URI[sha256sum] = "2caa9c859cfe348197e860f07d174a8ab7048d38d6d3a12ec576802122c9e91e" 4SRC_URI[sha256sum] = "2caa9c859cfe348197e860f07d174a8ab7048d38d6d3a12ec576802122c9e91e"
5 5
6 6COMPATIBLE_HOST ?= "null"
7COMPATIBLE_HOST_ti-soc = "(.*)"
diff --git a/recipes-ti/includes/ti-unpack.inc b/recipes-ti/includes/ti-unpack.inc
index a571fd5d..9da11ede 100644
--- a/recipes-ti/includes/ti-unpack.inc
+++ b/recipes-ti/includes/ti-unpack.inc
@@ -79,3 +79,7 @@ python ti_bin_do_unpack() {
79 # Return to the previous directory 79 # Return to the previous directory
80 os.chdir(save_cwd) 80 os.chdir(save_cwd)
81} 81}
82
83COMPATIBLE_HOST ?= "null"
84COMPATIBLE_HOST_ti-soc = "(.*)"
85COMPATIBLE_HOST_class-native = "(.*)"
diff --git a/recipes-ti/ipc/ti-ipc-common.inc b/recipes-ti/ipc/ti-ipc-common.inc
index dddb7344..aea9d278 100644
--- a/recipes-ti/ipc/ti-ipc-common.inc
+++ b/recipes-ti/ipc/ti-ipc-common.inc
@@ -2,6 +2,8 @@ PV = "3.50.02.02"
2INC_PR = "r0" 2INC_PR = "r0"
3 3
4PACKAGE_ARCH = "${MACHINE_ARCH}" 4PACKAGE_ARCH = "${MACHINE_ARCH}"
5COMPATIBLE_HOST ?= "null"
6COMPATIBLE_HOST_ti-soc = "(.*)"
5 7
6PLATFORM = "UNKNOWN" 8PLATFORM = "UNKNOWN"
7PLATFORM_omap5-evm = "OMAP54XX" 9PLATFORM_omap5-evm = "OMAP54XX"
diff --git a/recipes-ti/linuxutils/ti-linuxutils_2.26.01.02.bb b/recipes-ti/linuxutils/ti-linuxutils_2.26.01.02.bb
index 1a56d1da..113e6a69 100644
--- a/recipes-ti/linuxutils/ti-linuxutils_2.26.01.02.bb
+++ b/recipes-ti/linuxutils/ti-linuxutils_2.26.01.02.bb
@@ -12,3 +12,6 @@ SRC_URI[md5sum] = "70b4918bc35c1bcfef34d6ba3fbce0c8"
12SRC_URI[sha256sum] = "51266dd928f8d629cd417c869789a6c0d596612120f165619119cbaadfd66ee2" 12SRC_URI[sha256sum] = "51266dd928f8d629cd417c869789a6c0d596612120f165619119cbaadfd66ee2"
13 13
14INSANE_SKIP_${PN} = "installed-vs-shipped" 14INSANE_SKIP_${PN} = "installed-vs-shipped"
15
16COMPATIBLE_HOST ?= "null"
17COMPATIBLE_HOST_ti-soc = "(.*)"
diff --git a/recipes-ti/mathlib/mathlib.inc b/recipes-ti/mathlib/mathlib.inc
index 6aea085a..61f198bc 100644
--- a/recipes-ti/mathlib/mathlib.inc
+++ b/recipes-ti/mathlib/mathlib.inc
@@ -68,3 +68,5 @@ ALLOW_EMPTY_${PN} = "1"
68FILES_${PN}-dev += "${MATHLIB_INSTALL_DIR_RECIPE}" 68FILES_${PN}-dev += "${MATHLIB_INSTALL_DIR_RECIPE}"
69 69
70INSANE_SKIP_${PN}-dev = "arch" 70INSANE_SKIP_${PN}-dev = "arch"
71COMPATIBLE_HOST ?= "null"
72COMPATIBLE_HOST_ti-soc = "(.*)"
diff --git a/recipes-ti/ndk/ti-ndk_3.40.01.01.bb b/recipes-ti/ndk/ti-ndk_3.40.01.01.bb
index 4a494b19..c6c18733 100644
--- a/recipes-ti/ndk/ti-ndk_3.40.01.01.bb
+++ b/recipes-ti/ndk/ti-ndk_3.40.01.01.bb
@@ -11,3 +11,6 @@ SRC_URI[ndkzip.sha256sum] = "e2e5c683c70dfad6f4372c5eeebaf0209b27abb0f77304f14f0
11INHIBIT_PACKAGE_STRIP = "1" 11INHIBIT_PACKAGE_STRIP = "1"
12INHIBIT_PACKAGE_DEBUG_SPLIT = "1" 12INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
13INHIBIT_SYSROOT_STRIP = "1" 13INHIBIT_SYSROOT_STRIP = "1"
14
15COMPATIBLE_HOST ?= "null"
16COMPATIBLE_HOST_ti-soc = "(.*)"
diff --git a/recipes-ti/osal/ti-osal.inc b/recipes-ti/osal/ti-osal.inc
index cb8da354..0a966d40 100644
--- a/recipes-ti/osal/ti-osal.inc
+++ b/recipes-ti/osal/ti-osal.inc
@@ -19,3 +19,6 @@ INSANE_SKIP_${PN}-dev = "staticdev"
19 19
20ALLOW_EMPTY_${PN} = "1" 20ALLOW_EMPTY_${PN} = "1"
21FILES_${PN}-dev += "${OSAL_INSTALL_DIR_RECIPE}" 21FILES_${PN}-dev += "${OSAL_INSTALL_DIR_RECIPE}"
22
23COMPATIBLE_HOST ?= "null"
24COMPATIBLE_HOST_ti-soc = "(.*)"
diff --git a/recipes-ti/swtools/swtools_git.bb b/recipes-ti/swtools/swtools_git.bb
index 425a0690..168fe211 100644
--- a/recipes-ti/swtools/swtools_git.bb
+++ b/recipes-ti/swtools/swtools_git.bb
@@ -42,3 +42,5 @@ FILES_${PN}-dev += "${SWTOOLS_INSTALL_DIR_RECIPE}"
42 42
43INSANE_SKIP_${PN}-dev = "arch staticdev" 43INSANE_SKIP_${PN}-dev = "arch staticdev"
44ALLOW_EMPTY_${PN} = "1" 44ALLOW_EMPTY_${PN} = "1"
45COMPATIBLE_HOST ?= "null"
46COMPATIBLE_HOST_ti-soc = "(.*)"