summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaupin, Chase <chase.maupin@ti.com>2014-06-14 03:55:54 +0000
committerDenys Dmytriyenko <denys@ti.com>2014-06-16 18:20:34 -0400
commit7c5088b0d0d1e624edf1116c36dc175c7d63eb34 (patch)
tree11179d4574c2369cf0b80948d7c14219f6461887
parentde54630569e2d84c6c077b8bd0f700e9a8949847 (diff)
downloadmeta-ti-7c5088b0d0d1e624edf1116c36dc175c7d63eb34.tar.gz
u-boot: Add mainline u-boot version 2014.07-rc3
* The latest mainline u-boot works well for most TI devices and we want to enable more people to use and test it. Adding version 2014.07-rc3 will allow more people to build and use this u-boot version * Add a dependency on dtc-native since the latest mainline of u-boot now requires this and not every build host will have the right version. Signed-off-by: Chase Maupin <Chase.Maupin@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/u-boot/u-boot_2014.07.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot_2014.07.bb b/recipes-bsp/u-boot/u-boot_2014.07.bb
new file mode 100644
index 00000000..b326aa13
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot_2014.07.bb
@@ -0,0 +1,27 @@
1require u-boot-ti.inc
2
3# DEPEND on dtc-native for mainline u-boot because the mainline u-boot depends
4# on some of the latest syntax constructs for an appended in dtb used for
5# items like secure boot/image signing.
6DEPENDS += "dtc-native"
7
8DESCRIPTION = "Mainline u-boot bootloader"
9
10DEFAULT_PREFERENCE = "-1"
11
12LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
13
14# This is still an RC so set the PV accordingly to allow proper version
15# ordering when the RC is dropped.
16PV = "2014.04+2014.07-rc3"
17PR = "r0"
18
19SRC_URI = "git://git.denx.de/u-boot.git;protocol=git;branch=${BRANCH}"
20
21BRANCH ?= "master"
22
23# Corresponds to tag v2014.07-rc3
24SRCREV = "76b21026ceb5a6a83fc53b0ecdf425f240318022"
25
26SPL_BINARY = "MLO"
27SPL_UART_BINARY = "u-boot-spl.bin"