diff options
author | Sam Nelson <sam.nelson@ti.com> | 2016-05-13 21:32:39 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2016-05-13 14:57:27 -0400 |
commit | af64c0cb48acd949928311c1c4b3bddf165de8f7 (patch) | |
tree | cd7ce3a8f4ef6908ca95d6ccdf5fb35642e9dcfd | |
parent | a6318a5709d371db7864e05791836b8e48ff2c69 (diff) | |
download | meta-ti-af64c0cb48acd949928311c1c4b3bddf165de8f7.tar.gz |
uio-module-drv: Update to 2.0.0.0 GA version
Reformatted recipes to have one common PV between module and test
recipes
Signed-off-by: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r-- | recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb | 3 | ||||
-rw-r--r-- | recipes-bsp/uio-module-drv/uio-module-drv.inc | 6 | ||||
-rw-r--r-- | recipes-bsp/uio-module-drv/uio-module-drv_git.bb | 3 |
3 files changed, 7 insertions, 5 deletions
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb b/recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb index 1080a916..3134a032 100644 --- a/recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb +++ b/recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb | |||
@@ -1,7 +1,8 @@ | |||
1 | DESCRIPTION = "Test code for user space IO (UIO) driver" | 1 | DESCRIPTION = "Test code for user space IO (UIO) driver" |
2 | 2 | ||
3 | include uio-module-drv.inc | 3 | include uio-module-drv.inc |
4 | PV = "1.0.2.3" | 4 | |
5 | PR = "r1" | ||
5 | 6 | ||
6 | COMPATIBLE_MACHINE = "keystone" | 7 | COMPATIBLE_MACHINE = "keystone" |
7 | RDEPENDS_${PN} = "uio-module-drv" | 8 | RDEPENDS_${PN} = "uio-module-drv" |
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv.inc b/recipes-bsp/uio-module-drv/uio-module-drv.inc index ed34a8ab..161c45bc 100644 --- a/recipes-bsp/uio-module-drv/uio-module-drv.inc +++ b/recipes-bsp/uio-module-drv/uio-module-drv.inc | |||
@@ -1,10 +1,12 @@ | |||
1 | LICENSE = "BSD" | 1 | LICENSE = "BSD" |
2 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2b7c96eb2aed7b0f6f922214dbde9016" | 2 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2b7c96eb2aed7b0f6f922214dbde9016" |
3 | 3 | ||
4 | BRANCH = "linux4.1" | 4 | BRANCH = "master" |
5 | # This corresponds to version 02.00.00.00_eng | 5 | # This corresponds to version 02.00.00.00 |
6 | SRCREV = "6a7eda36e390658593a5b8d87b0f00beb3997240" | 6 | SRCREV = "6a7eda36e390658593a5b8d87b0f00beb3997240" |
7 | 7 | ||
8 | PV = "2.0.0.0+git${SRCPV}" | ||
9 | |||
8 | SRC_URI = "git://git.ti.com/keystone-linux/uio-module-drv.git;protocol=git;branch=${BRANCH}" | 10 | SRC_URI = "git://git.ti.com/keystone-linux/uio-module-drv.git;protocol=git;branch=${BRANCH}" |
9 | 11 | ||
10 | S = "${WORKDIR}/git" | 12 | S = "${WORKDIR}/git" |
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv_git.bb b/recipes-bsp/uio-module-drv/uio-module-drv_git.bb index 401fdbe0..15a76912 100644 --- a/recipes-bsp/uio-module-drv/uio-module-drv_git.bb +++ b/recipes-bsp/uio-module-drv/uio-module-drv_git.bb | |||
@@ -1,10 +1,9 @@ | |||
1 | DESCRIPTION="User space IO (UIO) driver for on-chip modules" | 1 | DESCRIPTION="User space IO (UIO) driver for on-chip modules" |
2 | 2 | ||
3 | include uio-module-drv.inc | 3 | include uio-module-drv.inc |
4 | PV = "2.0.0.0+git${SRCPV}" | ||
5 | 4 | ||
6 | # This package builds a kernel module, use kernel PR as base and append a local | 5 | # This package builds a kernel module, use kernel PR as base and append a local |
7 | MACHINE_KERNEL_PR_append = "c" | 6 | MACHINE_KERNEL_PR_append = "d" |
8 | PR = "${MACHINE_KERNEL_PR}" | 7 | PR = "${MACHINE_KERNEL_PR}" |
9 | 8 | ||
10 | module_auto_load_uio-module-drv = "uio-module-drv" | 9 | module_auto_load_uio-module-drv = "uio-module-drv" |