diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2012-06-28 11:53:55 +0200 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2012-07-25 20:25:01 -0400 |
commit | 51ce8e5738e9ab91122769aa1bedd36f95de613d (patch) | |
tree | c4dacdbc84fd01f4ac141bdf5ce99ab08ee810ad | |
parent | 24ba2ae0857e9a2cd0221e33aa6e7888328db817 (diff) | |
download | meta-ti-51ce8e5738e9ab91122769aa1bedd36f95de613d.tar.gz |
beaglebone-capes: use backlight hack for all LCD4 variants
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r-- | recipes-ti/beagleboard/beaglebone-capes.bb | 2 | ||||
-rwxr-xr-x | recipes-ti/beagleboard/beaglebone-capes/cape-stop.sh | 4 | ||||
-rwxr-xr-x | recipes-ti/beagleboard/beaglebone-capes/cape.sh | 2 |
3 files changed, 4 insertions, 4 deletions
diff --git a/recipes-ti/beagleboard/beaglebone-capes.bb b/recipes-ti/beagleboard/beaglebone-capes.bb index b463a893..ae9132ec 100644 --- a/recipes-ti/beagleboard/beaglebone-capes.bb +++ b/recipes-ti/beagleboard/beaglebone-capes.bb | |||
@@ -3,7 +3,7 @@ DESCRIPTION = "Userspace setup for beaglebone capes" | |||
3 | LICENSE = "MIT" | 3 | LICENSE = "MIT" |
4 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" | 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" |
5 | 5 | ||
6 | PR = "r3" | 6 | PR = "r4" |
7 | 7 | ||
8 | inherit allarch | 8 | inherit allarch |
9 | 9 | ||
diff --git a/recipes-ti/beagleboard/beaglebone-capes/cape-stop.sh b/recipes-ti/beagleboard/beaglebone-capes/cape-stop.sh index 49500176..222a010d 100755 --- a/recipes-ti/beagleboard/beaglebone-capes/cape-stop.sh +++ b/recipes-ti/beagleboard/beaglebone-capes/cape-stop.sh | |||
@@ -5,8 +5,8 @@ for eeprom in /sys/bus/i2c/devices/3-005*/eeprom ; do | |||
5 | "BB-BONE-LCD3-01.") | 5 | "BB-BONE-LCD3-01.") |
6 | echo "Turning off backlight for LCD3 cape" | 6 | echo "Turning off backlight for LCD3 cape" |
7 | i2cset -f -y 1 0x24 0x07 0x00;; | 7 | i2cset -f -y 1 0x24 0x07 0x00;; |
8 | "BB-BONE-LCD4-01.") | 8 | "BB-BONE-LCD4"*) |
9 | echo "Turning off backlight for LCD3 cape" | 9 | echo "Turning off backlight for LCD4 cape" |
10 | i2cset -f -y 1 0x24 0x07 0x00;; | 10 | i2cset -f -y 1 0x24 0x07 0x00;; |
11 | *) | 11 | *) |
12 | echo "unknown cape: $PARTNUMBER";; | 12 | echo "unknown cape: $PARTNUMBER";; |
diff --git a/recipes-ti/beagleboard/beaglebone-capes/cape.sh b/recipes-ti/beagleboard/beaglebone-capes/cape.sh index 566cdf5f..c279349d 100755 --- a/recipes-ti/beagleboard/beaglebone-capes/cape.sh +++ b/recipes-ti/beagleboard/beaglebone-capes/cape.sh | |||
@@ -6,7 +6,7 @@ for eeprom in /sys/bus/i2c/devices/3-005*/eeprom ; do | |||
6 | echo "Turning on backlight for LCD3 cape" | 6 | echo "Turning on backlight for LCD3 cape" |
7 | i2cset -f -y 1 0x24 0x07 0x09 | 7 | i2cset -f -y 1 0x24 0x07 0x09 |
8 | i2cset -f -y 1 0x24 0x08 0x60;; | 8 | i2cset -f -y 1 0x24 0x08 0x60;; |
9 | "BB-BONE-LCD4-01.") | 9 | "BB-BONE-LCD4"*) |
10 | echo "Turning on backlight for LCD4 cape" | 10 | echo "Turning on backlight for LCD4 cape" |
11 | i2cset -f -y 1 0x24 0x07 0x09 | 11 | i2cset -f -y 1 0x24 0x07 0x09 |
12 | i2cset -f -y 1 0x24 0x08 0x60;; | 12 | i2cset -f -y 1 0x24 0x08 0x60;; |