summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYogesh Siraswar <yogeshs@ti.com>2021-11-12 22:09:55 +0000
committerYogesh Siraswar <yogeshs@ti.com>2021-11-15 21:07:16 +0000
commite20113d667855f05dab5b5507182ef1b76fc19bc (patch)
tree101de635988626635ba8bae91cee4435d609cd6e
parentc28a6115d94702c7f4a3bf672a6ac862b6677f52 (diff)
downloadmeta-ti-e20113d667855f05dab5b5507182ef1b76fc19bc.tar.gz
am64xx-hs: changes to support new hs platform
Changes to support new am64x hs platform in: 1) optee: sign the image 2) atf: sign the image 3) u-boot: Add u-boot-spl image for combined boot image Signed-off-by: Yogesh Siraswar <yogeshs@ti.com>
-rw-r--r--recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend8
-rw-r--r--recipes-bsp/u-boot/u-boot-ti.inc6
-rw-r--r--recipes-security/optee/optee-os_%.bbappend4
3 files changed, 18 insertions, 0 deletions
diff --git a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
index eb6f2fd1..90fa0333 100644
--- a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
+++ b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
@@ -16,6 +16,14 @@ do_compile_append_am65xx-hs-evm() {
16 ) 16 )
17} 17}
18 18
19do_compile_append_am64xx-hs-evm() {
20 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
21 ( cd ${B}/${BUILD_DIR}/release/; \
22 mv bl31.bin bl31.bin.unsigned; \
23 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
24 )
25}
26
19do_compile_append_j7-hs-evm() { 27do_compile_append_j7-hs-evm() {
20 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} 28 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
21 ( cd ${B}/${BUILD_DIR}/release/; \ 29 ( cd ${B}/${BUILD_DIR}/release/; \
diff --git a/recipes-bsp/u-boot/u-boot-ti.inc b/recipes-bsp/u-boot/u-boot-ti.inc
index dc8d6b06..131c03e8 100644
--- a/recipes-bsp/u-boot/u-boot-ti.inc
+++ b/recipes-bsp/u-boot/u-boot-ti.inc
@@ -66,6 +66,7 @@ SPL_UART_BINARY_k3r5 = ""
66SPL_UART_BINARY_lego-ev3 = "" 66SPL_UART_BINARY_lego-ev3 = ""
67SPL_UART_BINARY_j7200-evm-k3r5 = "u-boot-spl.bin" 67SPL_UART_BINARY_j7200-evm-k3r5 = "u-boot-spl.bin"
68SPL_UART_BINARY_am64xx-evm-k3r5 = "u-boot-spl.bin" 68SPL_UART_BINARY_am64xx-evm-k3r5 = "u-boot-spl.bin"
69SPL_UART_BINARY_am64xx-hs-evm-k3r5 = "u-boot-spl.bin"
69 70
70SPL_UART_IMAGE ?= "${SPL_UART_BINARY}-${MACHINE}-${PV}-${PR}" 71SPL_UART_IMAGE ?= "${SPL_UART_BINARY}-${MACHINE}-${PV}-${PR}"
71SPL_UART_SYMLINK ?= "${SPL_UART_BINARY}-${MACHINE}" 72SPL_UART_SYMLINK ?= "${SPL_UART_BINARY}-${MACHINE}"
@@ -401,4 +402,9 @@ do_deploy_append_am64xx-evm-k3r5 () {
401 mv ${DEPLOYDIR}/u-boot-spl.bin ${DEPLOYDIR}/u-boot-spl-r5spl.bin || true 402 mv ${DEPLOYDIR}/u-boot-spl.bin ${DEPLOYDIR}/u-boot-spl-r5spl.bin || true
402} 403}
403 404
405do_deploy_append_am64xx-hs-evm-k3r5 () {
406 mv ${DEPLOYDIR}/tiboot3.bin ${DEPLOYDIR}/tiboot3-r5spl.bin || true
407 mv ${DEPLOYDIR}/u-boot-spl.bin ${DEPLOYDIR}/u-boot-spl-r5spl.bin || true
408}
409
404TOOLCHAIN = "gcc" 410TOOLCHAIN = "gcc"
diff --git a/recipes-security/optee/optee-os_%.bbappend b/recipes-security/optee/optee-os_%.bbappend
index c90d85ea..401ac534 100644
--- a/recipes-security/optee/optee-os_%.bbappend
+++ b/recipes-security/optee/optee-os_%.bbappend
@@ -61,6 +61,10 @@ do_compile_append_am65xx-hs-evm() {
61 optee_sign_k3hs 61 optee_sign_k3hs
62} 62}
63 63
64do_compile_append_am64xx-hs-evm() {
65 optee_sign_k3hs
66}
67
64do_compile_append_j7-hs-evm() { 68do_compile_append_j7-hs-evm() {
65 optee_sign_k3hs 69 optee_sign_k3hs
66} 70}