summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikhil Devshatwar <nikhil.nd@ti.com>2021-06-15 16:42:43 +0530
committerYogesh Siraswar <yogeshs@ti.com>2021-06-26 11:53:20 +0000
commit7876863adbd123ac939c6ca546a61aeb8606e51a (patch)
tree57dce1ff563660db404c7c8f23c835ddbf6dca9b
parent2ab3edaf703916d8d996e583538947b12d3c1cff (diff)
downloadmeta-ti-7876863adbd123ac939c6ca546a61aeb8606e51a.tar.gz
recipes-bsp: ivshmem: Remove ivshmem packages
Jailhouse support is dropped for K3 platforms. So the ivshmem (inter VM shared memory) based UIO driver and test applications cannot be build and are not required. Remove the recipes for the same. Signed-off-by: Nikhil Devshatwar <nikhil.nd@ti.com> Signed-off-by: Yogesh Siraswar <yogeshs@ti.com>
-rw-r--r--recipes-bsp/ivshmem-uio/ivshmem-uio-driver_git.bb29
-rw-r--r--recipes-bsp/ivshmem-uio/ivshmem-uio-tests_git.bb23
2 files changed, 0 insertions, 52 deletions
diff --git a/recipes-bsp/ivshmem-uio/ivshmem-uio-driver_git.bb b/recipes-bsp/ivshmem-uio/ivshmem-uio-driver_git.bb
deleted file mode 100644
index 39a75533..00000000
--- a/recipes-bsp/ivshmem-uio/ivshmem-uio-driver_git.bb
+++ /dev/null
@@ -1,29 +0,0 @@
1SUMMARY = "Kernel driver for IVSHMEM based UIO driver"
2DESCRIPTION = "Kernel module which registers a UIO (userspace io) device for inter VM shared memory"
3HOMEPAGE = "https://github.com/henning-schild-work/ivshmem-guest-code"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=0546a27aad86c83b75ad4ee6133e9d5e"
6
7inherit module
8
9RDEPENDS_${PN} = "jailhouse"
10
11PROTOCOL = "git"
12BRANCH = "jailhouse"
13SRCREV = "f3ad79881bebb6c6068966ee3d265d8034c20492"
14SRC_URI = "git://github.com/henning-schild-work/ivshmem-guest-code.git;protocol=${PROTOCOL};branch=${BRANCH}"
15
16S = "${WORKDIR}/git"
17
18EXTRA_OEMAKE += 'KDIR="${STAGING_KERNEL_DIR}"'
19
20COMPATIBLE_MACHINE = "(ti-soc)"
21
22do_compile_prepend() {
23 cd ${S}/kernel_module/uio
24}
25
26do_install() {
27 install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/extra
28 install -m 644 ${S}/kernel_module/uio/uio_ivshmem.ko ${D}/${base_libdir}/modules/${KERNEL_VERSION}/extra
29}
diff --git a/recipes-bsp/ivshmem-uio/ivshmem-uio-tests_git.bb b/recipes-bsp/ivshmem-uio/ivshmem-uio-tests_git.bb
deleted file mode 100644
index 997b8c48..00000000
--- a/recipes-bsp/ivshmem-uio/ivshmem-uio-tests_git.bb
+++ /dev/null
@@ -1,23 +0,0 @@
1SUMMARY = "UIO tests for IVSHMEM based UIO driver"
2DESCRIPTION = "Test programs which use UIO (userspace io) device for inter VM communication"
3HOMEPAGE = "https://github.com/henning-schild-work/ivshmem-guest-code"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://${WORKDIR}/git/COPYING;md5=0546a27aad86c83b75ad4ee6133e9d5e"
6
7inherit cmake
8
9PROTOCOL = "git"
10BRANCH = "jailhouse"
11SRCREV = "f3ad79881bebb6c6068966ee3d265d8034c20492"
12SRC_URI = "git://github.com/henning-schild-work/ivshmem-guest-code.git;protocol=${PROTOCOL};branch=${BRANCH}"
13
14S = "${WORKDIR}/git/uio/tests/Interrupts/VM"
15
16COMPATIBLE_MACHINE = "(ti-soc)"
17OECMAKE_TARGET_COMPILE = "uio_send uio_read"
18
19do_install() {
20 install -d ${D}/${bindir}
21 install -m 755 ${B}/uio_send ${D}/${bindir}/
22 install -m 755 ${B}/uio_read ${D}/${bindir}/
23}