summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2020-08-25 07:01:01 +0000
committerDenys Dmytriyenko <denys@ti.com>2020-08-25 17:58:35 +0000
commitc5e7e23e14f5d212ef14192d0845173cf14eefc1 (patch)
treed5ccc987db33fa2c7f4a8b7fa38afc28297023dd
parent9ea5416a233d57dd7b450987379cdccf59569159 (diff)
downloadmeta-ti-c5e7e23e14f5d212ef14192d0845173cf14eefc1.tar.gz
rtos, gcc-arm-none-eabi: Rename gcc-arm-none-eabi -> gcc-arm-baremetal
Rename gcc-arm-none-eabi to gcc-arm-baremetal. As meta-arm now provides baremetal gcc-arm-none-eabi version 9, and due to layer priorities, let's rename gcc-arm-none-eabi to gcc-arm-baremetal to force picking the right version for RTOS builds. Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--classes/ti-pdk.bbclass6
-rw-r--r--recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb2
-rw-r--r--recipes-bsp/starterware/starterware-rtos_git.bb2
-rw-r--r--recipes-ti/devtools/gcc-arm-baremetal_7-2018-q2-update.bb (renamed from recipes-ti/devtools/gcc-arm-none-eabi_7-2018-q2-update.bb)0
-rw-r--r--recipes-ti/devtools/gcc-arm-none-eabi-native_4.9.2015q3.bb23
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos.inc4
6 files changed, 7 insertions, 30 deletions
diff --git a/classes/ti-pdk.bbclass b/classes/ti-pdk.bbclass
index 2571234b..68314215 100644
--- a/classes/ti-pdk.bbclass
+++ b/classes/ti-pdk.bbclass
@@ -3,15 +3,15 @@ require recipes-ti/includes/ti-staging.inc
3 3
4inherit perlnative 4inherit perlnative
5 5
6DEPENDS = "ti-xdctools-native ti-cg-xml-native ti-sysbios common-csl-ip-rtos libxml-simple-perl-native gcc-arm-none-eabi-native ti-cgt6x-native ti-cgt-pru-native ti-pdk-build-rtos doxygen-native" 6DEPENDS = "ti-xdctools-native ti-cg-xml-native ti-sysbios common-csl-ip-rtos libxml-simple-perl-native gcc-arm-baremetal-native ti-cgt6x-native ti-cgt-pru-native ti-pdk-build-rtos doxygen-native"
7 7
8DEPENDS_append_omap-a15 = " ti-cgt-arm-native" 8DEPENDS_append_omap-a15 = " ti-cgt-arm-native"
9DEPENDS_remove_ti33x = "ti-cgt6x-native" 9DEPENDS_remove_ti33x = "ti-cgt6x-native"
10DEPENDS_remove_ti43x = "ti-cgt6x-native" 10DEPENDS_remove_ti43x = "ti-cgt6x-native"
11DEPENDS_append_omapl1 = " ti-cgt-arm-native" 11DEPENDS_append_omapl1 = " ti-cgt-arm-native"
12DEPENDS_remove_am65xx = "gcc-arm-none-eabi-native ti-cgt6x-native" 12DEPENDS_remove_am65xx = "gcc-arm-baremetal-native ti-cgt6x-native"
13DEPENDS_append_am65xx = " ti-cgt-arm-native gcc-linaro-baremetal-aarch64-native" 13DEPENDS_append_am65xx = " ti-cgt-arm-native gcc-linaro-baremetal-aarch64-native"
14DEPENDS_remove_j7 = "gcc-arm-none-eabi-native" 14DEPENDS_remove_j7 = "gcc-arm-baremetal-native"
15DEPENDS_append_j7 = " ti-cgt-arm-native gcc-linaro-baremetal-aarch64-native ti-cgt7x-native" 15DEPENDS_append_j7 = " ti-cgt-arm-native gcc-linaro-baremetal-aarch64-native ti-cgt7x-native"
16 16
17S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
diff --git a/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb b/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb
index 71c4fce4..4812afee 100644
--- a/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb
+++ b/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb
@@ -3,7 +3,7 @@ require recipes-ti/includes/ti-paths.inc
3 3
4PR = "${INC_PR}.1" 4PR = "${INC_PR}.1"
5 5
6DEPENDS = "ti-sysbios ti-xdctools-native gcc-arm-none-eabi-native ti-cgt-arm-native ti-cgt6x-native" 6DEPENDS = "ti-sysbios ti-xdctools-native gcc-arm-baremetal-native ti-cgt-arm-native ti-cgt6x-native"
7 7
8COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|c66x|omapl1" 8COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|c66x|omapl1"
9PACKAGE_ARCH = "${MACHINE_ARCH}" 9PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-bsp/starterware/starterware-rtos_git.bb b/recipes-bsp/starterware/starterware-rtos_git.bb
index 5e3535e9..bcac8d42 100644
--- a/recipes-bsp/starterware/starterware-rtos_git.bb
+++ b/recipes-bsp/starterware/starterware-rtos_git.bb
@@ -1,6 +1,6 @@
1require starterware.inc 1require starterware.inc
2 2
3DEPENDS = "gcc-arm-none-eabi-native ti-pdk-build-rtos ti-xdctools-native" 3DEPENDS = "gcc-arm-baremetal-native ti-pdk-build-rtos ti-xdctools-native"
4 4
5require recipes-ti/includes/ti-paths.inc 5require recipes-ti/includes/ti-paths.inc
6 6
diff --git a/recipes-ti/devtools/gcc-arm-none-eabi_7-2018-q2-update.bb b/recipes-ti/devtools/gcc-arm-baremetal_7-2018-q2-update.bb
index f474c87f..f474c87f 100644
--- a/recipes-ti/devtools/gcc-arm-none-eabi_7-2018-q2-update.bb
+++ b/recipes-ti/devtools/gcc-arm-baremetal_7-2018-q2-update.bb
diff --git a/recipes-ti/devtools/gcc-arm-none-eabi-native_4.9.2015q3.bb b/recipes-ti/devtools/gcc-arm-none-eabi-native_4.9.2015q3.bb
deleted file mode 100644
index 1fe5c525..00000000
--- a/recipes-ti/devtools/gcc-arm-none-eabi-native_4.9.2015q3.bb
+++ /dev/null
@@ -1,23 +0,0 @@
1DESCRIPTION = "Baremetal GCC for ARM"
2LICENSE = "GPL-3.0-with-GCC-exception & GPLv3"
3
4LIC_FILES_CHKSUM = "file://share/doc/gcc-arm-none-eabi/license.txt;md5=cba77c7fde3ed13e866b04a2f3d93918"
5
6inherit native
7require recipes-ti/includes/ti-paths.inc
8
9SRC_URI = "https://launchpad.net/gcc-arm-embedded/4.9/4.9-2015-q3-update/+download/gcc-arm-none-eabi-4_9-2015q3-20150921-linux.tar.bz2;name=gcc-arm-none"
10
11SRC_URI[gcc-arm-none.md5sum] = "8a4a74872830f80c788c944877d3ad8c"
12SRC_URI[gcc-arm-none.sha256sum] = "c50078bfbd29e6c15615900e746f4d0acde917338e55860b0f145f57387c12ab"
13
14S = "${WORKDIR}/gcc-arm-none-eabi-4_9-2015q3"
15
16do_install() {
17 install -d ${D}${GCC_ARM_NONE_TOOLCHAIN_RECIPE}
18 cp -r ${S}/. ${D}${GCC_ARM_NONE_TOOLCHAIN_RECIPE}
19}
20
21FILES_${PN} = "${GCC_ARM_NONE_TOOLCHAIN_RECIPE}/*"
22
23INSANE_SKIP_${PN} = "already-stripped"
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc
index a68ba806..b6b7892f 100644
--- a/recipes-ti/ipc/ti-ipc-rtos.inc
+++ b/recipes-ti/ipc/ti-ipc-rtos.inc
@@ -42,11 +42,11 @@ RELEASE_SUFFIX = ""
42PR = "${INC_PR}.r0" 42PR = "${INC_PR}.r0"
43 43
44DEPENDS_append_keystone = " ti-cgt6x-native \ 44DEPENDS_append_keystone = " ti-cgt6x-native \
45 gcc-arm-none-eabi-native \ 45 gcc-arm-baremetal-native \
46" 46"
47DEPENDS_append_omap-a15 = " ti-cgt6x-native \ 47DEPENDS_append_omap-a15 = " ti-cgt6x-native \
48 ti-cgt-arm-native \ 48 ti-cgt-arm-native \
49 gcc-arm-none-eabi-native \ 49 gcc-arm-baremetal-native \
50" 50"
51DEPENDS_append_omapl138 = " ti-cgt6x-native \ 51DEPENDS_append_omapl138 = " ti-cgt6x-native \
52" 52"