summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Murphy <dmurphy@ti.com>2021-01-07 07:22:16 -0600
committerDan Murphy <dmurphy@ti.com>2021-01-08 06:34:55 -0600
commit89402b1230533444fa1f96138d98a6e037996ed2 (patch)
tree838265a5a54ae77e8dcccff50cf383d15774703e
parent707f3b67c8819af1fabdde826353a34e1eb753c8 (diff)
downloadmeta-ti-89402b1230533444fa1f96138d98a6e037996ed2.tar.gz
am64xx: Add combined boot build support
Add combined boot flow support for the AM64XX device. From: Dan Murphy <dmurphy@ti.com> Signed-off-by: Dan Murphy <dmurphy@ti.com>
-rw-r--r--conf/machine/am64xx-evm-k3r5.conf4
-rw-r--r--conf/machine/am64xx-evm.conf8
-rw-r--r--recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb16
-rw-r--r--recipes-bsp/u-boot/u-boot-ti.inc7
4 files changed, 34 insertions, 1 deletions
diff --git a/conf/machine/am64xx-evm-k3r5.conf b/conf/machine/am64xx-evm-k3r5.conf
index b788e634..dfeaeb57 100644
--- a/conf/machine/am64xx-evm-k3r5.conf
+++ b/conf/machine/am64xx-evm-k3r5.conf
@@ -7,6 +7,8 @@ require conf/machine/include/k3r5.inc
7SYSFW_SOC = "am64x" 7SYSFW_SOC = "am64x"
8SYSFW_CONFIG = "evm" 8SYSFW_CONFIG = "evm"
9SYSFW_SUFFIX = "gp" 9SYSFW_SUFFIX = "gp"
10SYSFW_SYMLINK = "sysfw.itb"
11 10
12UBOOT_MACHINE = "am64x_evm_r5_defconfig" 11UBOOT_MACHINE = "am64x_evm_r5_defconfig"
12UBOOT_BINARY = "tiboot3.${UBOOT_SUFFIX}"
13UBOOT_IMAGE = "tiboot3-${MAINMACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
14UBOOT_SYMLINK = "tiboot3-${MAINMACHINE}.${UBOOT_SUFFIX}"
diff --git a/conf/machine/am64xx-evm.conf b/conf/machine/am64xx-evm.conf
index c6ba2a87..eda310a3 100644
--- a/conf/machine/am64xx-evm.conf
+++ b/conf/machine/am64xx-evm.conf
@@ -4,4 +4,12 @@
4 4
5require conf/machine/include/am64xx.inc 5require conf/machine/include/am64xx.inc
6 6
7IMAGE_BOOT_FILES = "tispl.bin u-boot.img"
8
7UBOOT_MACHINE = "am64x_evm_a53_defconfig" 9UBOOT_MACHINE = "am64x_evm_a53_defconfig"
10
11do_image_wic[depends] += "trusted-firmware-a:do_deploy"
12do_image_tar[depends] += "trusted-firmware-a:do_deploy"
13
14do_image_wic[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy"
15do_image_tar[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy"
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index 310c7d54..4d4a9a34 100644
--- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -2,6 +2,7 @@ require recipes-bsp/ti-sci-fw/ti-sci-fw.inc
2 2
3DEPENDS = "openssl-native u-boot-mkimage-native dtc-native" 3DEPENDS = "openssl-native u-boot-mkimage-native dtc-native"
4DEPENDS_append_j7200-evm-k3r5 = " virtual/bootloader" 4DEPENDS_append_j7200-evm-k3r5 = " virtual/bootloader"
5DEPENDS_append_am64xx-evm-k3r5 = " virtual/bootloader"
5 6
6CLEANBROKEN = "1" 7CLEANBROKEN = "1"
7PR = "r1" 8PR = "r1"
@@ -52,6 +53,7 @@ EXTRA_OEMAKE_HS = " \
52EXTRA_OEMAKE_append = "${@['',' ${EXTRA_OEMAKE_HS}']['${SYSFW_SUFFIX}' == 'hs']}" 53EXTRA_OEMAKE_append = "${@['',' ${EXTRA_OEMAKE_HS}']['${SYSFW_SUFFIX}' == 'hs']}"
53 54
54EXTRA_OEMAKE_append_j7200-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" 55EXTRA_OEMAKE_append_j7200-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
56EXTRA_OEMAKE_append_am64xx-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
55 57
56do_compile() { 58do_compile() {
57 cd ${WORKDIR}/imggen/ 59 cd ${WORKDIR}/imggen/
@@ -98,4 +100,18 @@ do_deploy_j7200-evm-k3r5() {
98 ln -sf ${UBOOT_IMAGE} ${DEPLOYDIR}/${UBOOT_BINARY} 100 ln -sf ${UBOOT_IMAGE} ${DEPLOYDIR}/${UBOOT_BINARY}
99} 101}
100 102
103do_install_am64xx-evm-k3r5() {
104 install -d ${D}/boot
105 install -m 644 ${WORKDIR}/imggen/${UBOOT_BINARY} ${D}/boot/${UBOOT_IMAGE}
106 ln -sf ${UBOOT_IMAGE} ${D}/boot/${UBOOT_SYMLINK}
107 ln -sf ${UBOOT_IMAGE} ${D}/boot/${UBOOT_BINARY}
108}
109
110do_deploy_am64xx-evm-k3r5() {
111 install -d ${DEPLOYDIR}
112 install -m 644 ${WORKDIR}/imggen/${UBOOT_BINARY} ${DEPLOYDIR}/${UBOOT_IMAGE}
113 ln -sf ${UBOOT_IMAGE} ${DEPLOYDIR}/${UBOOT_SYMLINK}
114 ln -sf ${UBOOT_IMAGE} ${DEPLOYDIR}/${UBOOT_BINARY}
115}
116
101addtask deploy before do_build after do_compile 117addtask deploy before do_build after do_compile
diff --git a/recipes-bsp/u-boot/u-boot-ti.inc b/recipes-bsp/u-boot/u-boot-ti.inc
index b7fd246a..a871b779 100644
--- a/recipes-bsp/u-boot/u-boot-ti.inc
+++ b/recipes-bsp/u-boot/u-boot-ti.inc
@@ -41,6 +41,7 @@ PACKAGECONFIG[dm] = "DM=${STAGING_DIR_HOST}${nonarch_base_libdir}/firmware/pdk-i
41 41
42PACKAGECONFIG_append_aarch64 = " atf optee" 42PACKAGECONFIG_append_aarch64 = " atf optee"
43PACKAGECONFIG_append_j7 = " dm" 43PACKAGECONFIG_append_j7 = " dm"
44PACKAGECONFIG_append_am64xx = " dm"
44 45
45COMPATIBLE_MACHINE = "(ti-soc)" 46COMPATIBLE_MACHINE = "(ti-soc)"
46 47
@@ -65,6 +66,7 @@ SPL_UART_BINARY_keystone = ""
65SPL_UART_BINARY_k3r5 = "" 66SPL_UART_BINARY_k3r5 = ""
66SPL_UART_BINARY_lego-ev3 = "" 67SPL_UART_BINARY_lego-ev3 = ""
67SPL_UART_BINARY_j7200-evm-k3r5 = "u-boot-spl.bin" 68SPL_UART_BINARY_j7200-evm-k3r5 = "u-boot-spl.bin"
69SPL_UART_BINARY_am64xx-evm-k3r5 = "u-boot-spl.bin"
68 70
69SPL_UART_IMAGE ?= "${SPL_UART_BINARY}-${MACHINE}-${PV}-${PR}" 71SPL_UART_IMAGE ?= "${SPL_UART_BINARY}-${MACHINE}-${PV}-${PR}"
70SPL_UART_SYMLINK ?= "${SPL_UART_BINARY}-${MACHINE}" 72SPL_UART_SYMLINK ?= "${SPL_UART_BINARY}-${MACHINE}"
@@ -395,4 +397,9 @@ do_deploy_append_j7200-evm-k3r5 () {
395 mv ${DEPLOYDIR}/u-boot-spl.bin ${DEPLOYDIR}/u-boot-spl-r5spl.bin || true 397 mv ${DEPLOYDIR}/u-boot-spl.bin ${DEPLOYDIR}/u-boot-spl-r5spl.bin || true
396} 398}
397 399
400do_deploy_append_am64xx-evm-k3r5 () {
401 mv ${DEPLOYDIR}/tiboot3.bin ${DEPLOYDIR}/tiboot3-r5spl.bin || true
402 mv ${DEPLOYDIR}/u-boot-spl.bin ${DEPLOYDIR}/u-boot-spl-r5spl.bin || true
403}
404
398TOOLCHAIN = "gcc" 405TOOLCHAIN = "gcc"