summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-10-30 07:46:00 +0000
committerDan Murphy <dmurphy@ti.com>2020-11-02 07:25:11 -0600
commit91fe7b2a7a6f44cf58bc748e51e7b45394181080 (patch)
treec13bd077bdacf33753ee3be612ddf2cd6fffbd1f
parent31dfe138b53c727c8f11680820a9bdcc7857b474 (diff)
downloadmeta-ti-91fe7b2a7a6f44cf58bc748e51e7b45394181080.tar.gz
ti-rpmsg-char-examples: Fix cross compile
This fixes problems during cross compile where it starts to peek into build host's include and library paths and causes errors with clang and QA warnings with gcc Signed-off-by: Khem Raj <raj.khem@gmail.com> Reviewed-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Dan Murphy <dmurphy@ti.com>
-rw-r--r--recipes-ti/ipc/ti-rpmsg-char-examples/0001-examples-Remove-use-of-includedir-and-libdir.patch38
-rw-r--r--recipes-ti/ipc/ti-rpmsg-char-examples_git.bb2
2 files changed, 40 insertions, 0 deletions
diff --git a/recipes-ti/ipc/ti-rpmsg-char-examples/0001-examples-Remove-use-of-includedir-and-libdir.patch b/recipes-ti/ipc/ti-rpmsg-char-examples/0001-examples-Remove-use-of-includedir-and-libdir.patch
new file mode 100644
index 00000000..71fca1b0
--- /dev/null
+++ b/recipes-ti/ipc/ti-rpmsg-char-examples/0001-examples-Remove-use-of-includedir-and-libdir.patch
@@ -0,0 +1,38 @@
1From 1a26cb577ba54dd9214eeb94fed0ce3a0f4603b6 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 24 Oct 2020 23:46:39 -0700
4Subject: [PATCH] examples: Remove use of includedir and libdir
5
6These point to standard include and library paths which already are used
7from sysroot relative paths secondly, they use absolute paths which
8means we are asking to add -I/usr/include which might be ok in a native
9build but not in cross build. This helps mitigate QA errors found with
10OE build system since it finds it adding host include and library search
11paths to linker/compiler commandline
12
13Upstream-Status: Pending
14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15---
16 examples/Makefile.am | 5 +----
17 1 file changed, 1 insertion(+), 4 deletions(-)
18
19diff --git a/examples/Makefile.am b/examples/Makefile.am
20index 5a9bedb..d547e41 100644
21--- a/examples/Makefile.am
22+++ b/examples/Makefile.am
23@@ -1,6 +1,4 @@
24-INCLUDE = -I${includedir}
25-
26-AM_CFLAGS = -Wall -g -O2 $(INCLUDE)
27+AM_CFLAGS = -Wall -g -O2
28
29 bin_PROGRAMS = rpmsg_char_simple
30
31@@ -8,4 +6,3 @@ bin_PROGRAMS = rpmsg_char_simple
32 rpmsg_char_simple_SOURCES = rpmsg_char_simple.c
33 rpmsg_char_simple_CPPFLAGS = $(AM_CFLAGS)
34 rpmsg_char_simple_LDADD = -lpthread -lti_rpmsg_char
35-rpmsg_char_simple_LDFLAGS = -L${libdir}
36--
372.29.1
38
diff --git a/recipes-ti/ipc/ti-rpmsg-char-examples_git.bb b/recipes-ti/ipc/ti-rpmsg-char-examples_git.bb
index 142e5bf0..cbe4d7fd 100644
--- a/recipes-ti/ipc/ti-rpmsg-char-examples_git.bb
+++ b/recipes-ti/ipc/ti-rpmsg-char-examples_git.bb
@@ -2,6 +2,8 @@ SUMMARY = "TI RPMsg Char Sample Applications and Tests"
2 2
3require ti-rpmsg-char.inc 3require ti-rpmsg-char.inc
4 4
5SRC_URI += "file://0001-examples-Remove-use-of-includedir-and-libdir.patch"
6
5DEPENDS = "ti-rpmsg-char" 7DEPENDS = "ti-rpmsg-char"
6 8
7inherit autotools pkgconfig 9inherit autotools pkgconfig