summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-01-08 10:47:06 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-01-08 10:55:59 +0100
commit234596fc5d169b91aba8f998e20307715fdebfcc (patch)
treeb29fb8d407ed2548c867df2b626556e40e11b16c
parent7173560f284e57c0160a12e0f46e2f9224da5be2 (diff)
downloadmeta-ti-234596fc5d169b91aba8f998e20307715fdebfcc.tar.gz
TI BSP: add support the AM37x EVM board
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--conf/machine/am37x-evm.conf51
-rw-r--r--recipes-bsp/u-boot/u-boot_git.bb7
2 files changed, 58 insertions, 0 deletions
diff --git a/conf/machine/am37x-evm.conf b/conf/machine/am37x-evm.conf
new file mode 100644
index 00000000..0b9e2ddc
--- /dev/null
+++ b/conf/machine/am37x-evm.conf
@@ -0,0 +1,51 @@
1#@TYPE: Machine
2#@NAME: AM37x EVM
3#@DESCRIPTION: Machine configuration for the TI AM37x EVM
4TARGET_ARCH = "arm"
5
6PREFERRED_PROVIDER_virtual/xserver = "xserver-xorg"
7XSERVER = "xserver-xorg \
8 xf86-input-evdev \
9 xf86-input-mouse \
10 xf86-input-tslib \
11 xf86-video-omapfb \
12 xf86-input-keyboard"
13
14GUI_MACHINE_CLASS = "smallscreen"
15
16require conf/machine/include/omap3.inc
17
18# Ship all kernel modules
19
20IMAGE_FSTYPES ?= "jffs2 tar.bz2"
21EXTRA_IMAGECMD_jffs2 = "-lnp -e 0x20000 -s 2048"
22
23SERIAL_CONSOLE = "115200 ttyS0"
24
25PREFERRED_PROVIDER_virtual/kernel = "linux-omap-psp"
26
27PREFERRED_PROVIDER_virtual/bootloader = "u-boot"
28
29UBOOT_ARCH = "arm"
30UBOOT_MACHINE = "omap3_evm_config"
31XLOAD_MACHINE = "omap3evm_config"
32
33MACHINE_FEATURES = "kernel26 apm usbgadget usbhost vfat ext2 screen touchscreen"
34
35# NOTE: there are NAND and OneNAND versions of this board...
36
37# do ubiattach /dev/ubi_ctrl -m 4
38# From dmesg:
39# UBI: smallest flash I/O unit: 2048
40# UBI: logical eraseblock size: 129024 bytes
41# from ubiattach stdout:
42# UBI device number 0, total 1996 LEBs
43MKUBIFS_ARGS = "-m 2048 -e 129024 -c 1996"
44
45# do ubiattach /dev/ubi_ctrl -m 4
46# from dmesg:
47# UBI: smallest flash I/O unit: 2048
48# UBI: physical eraseblock size: 131072 bytes (128 KiB)
49# UBI: sub-page size: 512
50UBINIZE_ARGS = "-m 2048 -p 128KiB -s 512"
51
diff --git a/recipes-bsp/u-boot/u-boot_git.bb b/recipes-bsp/u-boot/u-boot_git.bb
index 5546447d..f7423c95 100644
--- a/recipes-bsp/u-boot/u-boot_git.bb
+++ b/recipes-bsp/u-boot/u-boot_git.bb
@@ -66,6 +66,13 @@ SRC_URI_omap3evm = "git://arago-project.org/git/projects/u-boot-omap3.git;protoc
66SRCREV_omap3evm = "c0a8fb217fdca7888d89f9a3dee74a4cec865620" 66SRCREV_omap3evm = "c0a8fb217fdca7888d89f9a3dee74a4cec865620"
67PV_omap3evm = "2009.11+${PR}+gitr${SRCREV}" 67PV_omap3evm = "2009.11+${PR}+gitr${SRCREV}"
68 68
69# ~ TI PSP v2009.11_OMAPPSP_03.00.01.06 (+ couple of commits)
70SRC_URI_am37x-evm = "git://arago-project.org/git/projects/u-boot-omap3.git;protocol=git \
71 file://0001-omap3evm-Change-default-console-serial-port-from.patch \
72"
73SRCREV_am37x-evm = "c0a8fb217fdca7888d89f9a3dee74a4cec865620"
74PV_am37x-evm = "2009.11+${PR}+gitr${SRCREV}"
75
69# hawkboard - master branch (hawk still .07beta) 76# hawkboard - master branch (hawk still .07beta)
70SRC_URI_hawkboard = "git://arago-project.org/git/people/sekhar/u-boot-omapl1.git;protocol=git;branch=master" 77SRC_URI_hawkboard = "git://arago-project.org/git/people/sekhar/u-boot-omapl1.git;protocol=git;branch=master"
71SRC_URI_hawkboard += "file://dont-inline-weak-symbols.patch" 78SRC_URI_hawkboard += "file://dont-inline-weak-symbols.patch"