summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2020-08-24 23:30:40 +0000
committerDenys Dmytriyenko <denys@ti.com>2020-08-25 17:57:56 +0000
commit152e3ae0a3235066454707c5ad93d1b74da871a4 (patch)
tree33b9d32e58772c5f93095f9c8839ff3397ad1c0a
parent92c95804bfc6f468fa3dba2dccf7518d7b42202d (diff)
downloadmeta-ti-152e3ae0a3235066454707c5ad93d1b74da871a4.tar.gz
Revert "HACK: ipumm: Temporary work-around for linker error with XDC tools upgrade"
This reverts commit 33b0e937b77894e0402d42e3798f48309a03fdce. Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/ipumm-fw/files/0001-HACK-ipumm-Workaround-for-linker-error.patch48
-rw-r--r--recipes-bsp/ipumm-fw/ipumm-fw_git.bb6
2 files changed, 1 insertions, 53 deletions
diff --git a/recipes-bsp/ipumm-fw/files/0001-HACK-ipumm-Workaround-for-linker-error.patch b/recipes-bsp/ipumm-fw/files/0001-HACK-ipumm-Workaround-for-linker-error.patch
deleted file mode 100644
index 0bea358f..00000000
--- a/recipes-bsp/ipumm-fw/files/0001-HACK-ipumm-Workaround-for-linker-error.patch
+++ /dev/null
@@ -1,48 +0,0 @@
1From 7226700841c62e6a42690eaa8b3e31b2c329b341 Mon Sep 17 00:00:00 2001
2From: Ramprasad N <x0038811@ti.com>
3Date: Thu, 28 May 2020 09:53:59 +0530
4Subject: [PATCH] HACK: ipumm: Workaround for linker error
5
6* HACK: ti_sdo_ce_utils_syscbuf_SysCBuf_Module_startup__E is no longer
7* defined with latest XDC tools. To temporarily get around the issue
8* until the real fix can be made, dummy defination of the missing function
9* is added in ipu_main.c
10
11*IPUMM dependent tool chain components are upgraded to latest version
12* BIOS : 6_82_01_17_eng
13* XDC : 3_61_00_16_core
14* This issue is seen only with xdc tools upgrade.
15
16Signed-off-by: Angela Stegmaier <angelabaker@ti.com>
17Signed-off-by: Ramprasad N <x0038811@ti.com>
18---
19 platform/ti/dce/baselib/ipumm_main.c | 13 +++++++++++++
20 1 file changed, 13 insertions(+)
21
22diff --git a/platform/ti/dce/baselib/ipumm_main.c b/platform/ti/dce/baselib/ipumm_main.c
23index 76ccd34..f4ca6e5 100644
24--- a/platform/ti/dce/baselib/ipumm_main.c
25+++ b/platform/ti/dce/baselib/ipumm_main.c
26@@ -50,6 +50,19 @@
27 #include <string.h>
28 #include <stdlib.h>
29
30+/*
31+ * HACK: ti_sdo_ce_utils_syscbuf_SysCBuf_Module_startup__E is no longer
32+ * defined with latest XDC tools. To temporarily get around the issue
33+ * until the real fix can be made, define the missing function
34+ * here.
35+ */
36+extern ti_sdo_ce_utils_syscbuf_SysCBuf_Module_startup__F(xdc_Int state);
37+
38+/* Module_startup */
39+xdc_Int ti_sdo_ce_utils_syscbuf_SysCBuf_Module_startup__E( xdc_Int state )
40+{
41+ return ti_sdo_ce_utils_syscbuf_SysCBuf_Module_startup__F(state);
42+}
43
44 /* Legacy function to allow Linux side rpmsg sample tests to work: */
45 extern void start_ping_tasks();
46--
471.9.1
48
diff --git a/recipes-bsp/ipumm-fw/ipumm-fw_git.bb b/recipes-bsp/ipumm-fw/ipumm-fw_git.bb
index e53d0a98..4f6ae89e 100644
--- a/recipes-bsp/ipumm-fw/ipumm-fw_git.bb
+++ b/recipes-bsp/ipumm-fw/ipumm-fw_git.bb
@@ -15,14 +15,10 @@ SRC_URI = "git://git.ti.com/ivimm/ipumm.git;protocol=git"
15 15
16SRCREV = "df4c50aecc9aad7ab3eb1ca9ebacfe473fcad7c5" 16SRCREV = "df4c50aecc9aad7ab3eb1ca9ebacfe473fcad7c5"
17 17
18SRC_URI += " \
19 file://0001-HACK-ipumm-Workaround-for-linker-error.patch \
20 "
21
22S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
23 19
24PV = "3.00.15.00" 20PV = "3.00.15.00"
25PR = "r6" 21PR = "r5"
26 22
27require recipes-ti/includes/ti-paths.inc 23require recipes-ti/includes/ti-paths.inc
28 24