summaryrefslogtreecommitdiffstats
path: root/recipes-security/setools/setools_4.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/setools/setools_4.3.0.bb')
-rw-r--r--recipes-security/setools/setools_4.3.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-security/setools/setools_4.3.0.bb b/recipes-security/setools/setools_4.3.0.bb
new file mode 100644
index 0000000..ec73f7c
--- /dev/null
+++ b/recipes-security/setools/setools_4.3.0.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Policy analysis tools for SELinux"
2DESCRIPTION = "\
3SETools is a collection of graphical tools, command-line tools, and \
4libraries designed to facilitate SELinux policy analysis. \
5\n\
6This meta-package depends upon the main packages necessary to run \
7SETools."
8SECTION = "base"
9LICENSE = "GPLv2 & LGPLv2.1"
10
11S = "${WORKDIR}/git"
12SRC_URI = "git://github.com/SELinuxProject/${BPN}.git;branch=4.3 \
13 file://setools4-fixes-for-cross-compiling.patch \
14"
15
16SRCREV = "a57ad3cdb669a39f785c4e85d63416a469c8d445"
17
18LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=83a5eb6974c11f30785e90d0eeccf40c \
19 file://${S}/COPYING.GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
20 file://${S}/COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c"
21
22DEPENDS += "bison-native flex-native swig-native python3 python3-cython-native libsepol libselinux"
23
24RDEPENDS_${PN} += "python3-networkx python3-decorator python3-setuptools \
25 python3-logging python3-json libselinux-python"
26
27RPROVIDES_${PN} += "${PN}-console"
28
29inherit setuptools3
30
31do_install_append() {
32 # Need PyQt5 support, disable gui tools
33 rm -f ${D}${bindir}/apol
34 rm -rf ${D}${libdir}/${PYTHON_DIR}/site-packages/setoolsgui
35 rm -rf ${D}${libdir}/${PYTHON_DIR}/site-packages/setools/__pycache__
36 rm -rf ${D}${libdir}/${PYTHON_DIR}/site-packages/setools/*/__pycache__
37}