summaryrefslogtreecommitdiffstats
path: root/recipes-security/selinux/selinux-python/fix-sepolicy-install-path.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/selinux/selinux-python/fix-sepolicy-install-path.patch')
-rw-r--r--recipes-security/selinux/selinux-python/fix-sepolicy-install-path.patch23
1 files changed, 13 insertions, 10 deletions
diff --git a/recipes-security/selinux/selinux-python/fix-sepolicy-install-path.patch b/recipes-security/selinux/selinux-python/fix-sepolicy-install-path.patch
index 1d54231..6f68c94 100644
--- a/recipes-security/selinux/selinux-python/fix-sepolicy-install-path.patch
+++ b/recipes-security/selinux/selinux-python/fix-sepolicy-install-path.patch
@@ -1,4 +1,4 @@
1From 69e8697cd2ae48710ff8190bad3e61d2fd115b99 Mon Sep 17 00:00:00 2001 1From c1aae6cc131371729f098e4b0aa02142a85b5890 Mon Sep 17 00:00:00 2001
2From: Xin Ouyang <Xin.Ouyang@windriver.com> 2From: Xin Ouyang <Xin.Ouyang@windriver.com>
3Date: Mon, 23 Sep 2013 21:17:59 +0800 3Date: Mon, 23 Sep 2013 21:17:59 +0800
4Subject: [PATCH] policycoreutils: fix install path for new pymodule sepolicy 4Subject: [PATCH] policycoreutils: fix install path for new pymodule sepolicy
@@ -7,16 +7,16 @@ Uptream-Status: Pending
7 7
8Signed-off-by: Xin Ouyang <Xin.Ouyang@windriver.com> 8Signed-off-by: Xin Ouyang <Xin.Ouyang@windriver.com>
9Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> 9Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
10 10Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
11--- 11---
12 sepolicy/Makefile | 4 +++- 12 sepolicy/Makefile | 4 +++-
13 1 file changed, 3 insertions(+), 1 deletion(-) 13 1 file changed, 3 insertions(+), 1 deletion(-)
14 14
15diff --git a/sepolicy/Makefile b/sepolicy/Makefile 15diff --git a/sepolicy/Makefile b/sepolicy/Makefile
16index 5a56e6c..82c3e36 100644 16index fb8a132..a6ee749 100644
17--- a/sepolicy/Makefile 17--- a/sepolicy/Makefile
18+++ b/sepolicy/Makefile 18+++ b/sepolicy/Makefile
19@@ -12,6 +12,8 @@ SHAREDIR ?= $(PREFIX)/share/sandbox 19@@ -8,6 +8,8 @@ BASHCOMPLETIONDIR ?= $(PREFIX)/share/bash-completion/completions
20 CFLAGS ?= -Wall -Werror -Wextra -W 20 CFLAGS ?= -Wall -Werror -Wextra -W
21 override CFLAGS += -DPACKAGE="policycoreutils" -DSHARED -shared 21 override CFLAGS += -DPACKAGE="policycoreutils" -DSHARED -shared
22 22
@@ -25,12 +25,15 @@ index 5a56e6c..82c3e36 100644
25 BASHCOMPLETIONS=sepolicy-bash-completion.sh 25 BASHCOMPLETIONS=sepolicy-bash-completion.sh
26 26
27 all: python-build 27 all: python-build
28@@ -30,7 +32,7 @@ test: 28@@ -26,7 +28,7 @@ test:
29 @$(PYTHON) test_sepolicy.py -v 29 @$(PYTHON) test_sepolicy.py -v
30 30
31 install: 31 install:
32- $(PYTHON) setup.py install `test -n "$(DESTDIR)" && echo --root $(DESTDIR)` 32- $(PYTHON) setup.py install --prefix=$(PREFIX) `test -n "$(DESTDIR)" && echo --root $(DESTDIR)`
33+ $(PYTHON) setup.py install --install-lib $(LIBDIR)/$(PYLIBVER)/site-packages 33+ $(PYTHON) setup.py install --prefix=$(PREFIX) --install-lib $(DESTDIR)$(LIBDIR)/$(PYLIBVER)/site-packages
34 [ -d $(BINDIR) ] || mkdir -p $(BINDIR) 34 [ -d $(DESTDIR)$(BINDIR) ] || mkdir -p $(DESTDIR)$(BINDIR)
35 install -m 755 sepolicy.py $(BINDIR)/sepolicy 35 install -m 755 sepolicy.py $(DESTDIR)$(BINDIR)/sepolicy
36 (cd $(BINDIR); ln -sf sepolicy sepolgen) 36 (cd $(DESTDIR)$(BINDIR); ln -sf sepolicy sepolgen)
37--
382.7.4
39