summaryrefslogtreecommitdiffstats
path: root/recipes-security/audit/audit_2.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/audit/audit_2.2.1.bb')
-rw-r--r--recipes-security/audit/audit_2.2.1.bb26
1 files changed, 3 insertions, 23 deletions
diff --git a/recipes-security/audit/audit_2.2.1.bb b/recipes-security/audit/audit_2.2.1.bb
index 4d94025..a58b9e1 100644
--- a/recipes-security/audit/audit_2.2.1.bb
+++ b/recipes-security/audit/audit_2.2.1.bb
@@ -4,7 +4,7 @@ storing and searching the audit records generated by the audit subsystem \
4in the Linux kernel." 4in the Linux kernel."
5HOMEPAGE = "http://people.redhat.com/sgrubb/audit/" 5HOMEPAGE = "http://people.redhat.com/sgrubb/audit/"
6SECTION = "base" 6SECTION = "base"
7PR = "r5" 7PR = "r6"
8LICENSE = "GPLv2+ & LGPLv2+" 8LICENSE = "GPLv2+ & LGPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" 9LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
10 10
@@ -12,8 +12,9 @@ SRC_URI = "http://people.redhat.com/sgrubb/audit/audit-${PV}.tar.gz \
12 file://disable-ldap.patch \ 12 file://disable-ldap.patch \
13 file://audit-python.patch" 13 file://audit-python.patch"
14 14
15SRC_URI += "file://2.2.1-audit-for-cross-compiling.patch \ 15SRC_URI += "\
16 file://audit-python-configure.patch \ 16 file://audit-python-configure.patch \
17 file://audit-cross-compiling.patch \
17 file://auditd" 18 file://auditd"
18 19
19inherit autotools pythonnative update-rc.d 20inherit autotools pythonnative update-rc.d
@@ -61,27 +62,6 @@ FILES_${PN}-dbg += "${libdir}/python${PYTHON_BASEVERSION}/*/.debug"
61FILES_${PN}-python = "${libdir}/python${PYTHON_BASEVERSION}" 62FILES_${PN}-python = "${libdir}/python${PYTHON_BASEVERSION}"
62FILES_${PN}-dev += "${base_libdir}/*.so ${base_libdir}/*.la" 63FILES_${PN}-dev += "${base_libdir}/*.so ${base_libdir}/*.la"
63 64
64# The executables in lib/, which are named as gen_*_h, will run on the hosts to create
65# *_tables.h/*tabs.h header files for the targets.
66# In some old hosts, build will fail because some .h files in the old linux-libc-headers (<= 2.6.29)
67# has incomplete DEFINE lists for the audit system.
68do_compile_prepend() {
69 mkdir -p ${S}/lib/linux
70 cp -f ${STAGING_INCDIR}/linux/audit.h ${S}/lib/linux/
71 cp -f ${STAGING_INCDIR}/linux/elf-em.h ${S}/lib/linux/
72 cp -f ${STAGING_INCDIR}/linux/net.h ${S}/lib/linux/
73 mkdir -p ${S}/lib/sys
74 cp -f ${STAGING_INCDIR}/sys/mount.h ${S}/lib/sys/
75 cp -f ${STAGING_INCDIR}/sys/personality.h ${S}/lib/sys/
76 mkdir -p ${S}/lib/bits
77 cp -f ${STAGING_INCDIR}/bits/socket.h ${S}/lib/bits
78
79 # eglibc-2.16 splits enum __socket_type from bits/socket.h to bits/socket_type.h, so we
80 # copy bits/socket_type.h only if it exists.
81 test -f ${STAGING_INCDIR}/bits/socket_type.h && \
82 cp -f ${STAGING_INCDIR}/bits/socket_type.h ${S}/lib/bits
83}
84
85do_install_append() { 65do_install_append() {
86 rm -f ${D}/${libdir}/python${PYTHON_BASEVERSION}/site-packages/*.a 66 rm -f ${D}/${libdir}/python${PYTHON_BASEVERSION}/site-packages/*.a
87 rm -f ${D}/${libdir}/python${PYTHON_BASEVERSION}/site-packages/*.la 67 rm -f ${D}/${libdir}/python${PYTHON_BASEVERSION}/site-packages/*.la