summaryrefslogtreecommitdiffstats
path: root/recipes-security/audit/audit_2.1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/audit/audit_2.1.3.bb')
-rw-r--r--recipes-security/audit/audit_2.1.3.bb58
1 files changed, 0 insertions, 58 deletions
diff --git a/recipes-security/audit/audit_2.1.3.bb b/recipes-security/audit/audit_2.1.3.bb
deleted file mode 100644
index 4cd7554..0000000
--- a/recipes-security/audit/audit_2.1.3.bb
+++ /dev/null
@@ -1,58 +0,0 @@
1SUMMARY = "User space tools for kernel auditing"
2DESCRIPTION = "The audit package contains the user space utilities for \
3storing and searching the audit records generated by the audit subsystem \
4in the Linux kernel."
5HOMEPAGE = "http://people.redhat.com/sgrubb/audit/"
6SECTION = "base"
7PR = "r2"
8LICENSE = "GPLv2+ & LGPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
10
11SRC_URI = "http://people.redhat.com/sgrubb/audit/audit-2.1.3.tar.gz \
12 file://disable-ldap.patch \
13 file://audit-python.patch"
14
15SRC_URI += "file://audit-for-cross-compiling.patch \
16 file://fix-swig-host-contamination.patch"
17
18inherit autotools pythonnative
19
20SRC_URI[md5sum] = "abf26e3ac09f666905c5636dd24611fa"
21SRC_URI[sha256sum] = "1c61858d8ed299128aa6bd8e85bac758bfe33e61358d259e52acb7d961fee90e"
22
23DEPENDS += "python tcp-wrappers libcap-ng linux-libc-headers (>= 2.6.30)"
24
25EXTRA_OECONF += "--without-prelude --with-libwrap --enable-gssapi-krb5=no --disable-ldap --with-libcap-ng=yes"
26
27EXTRA_OEMAKE += "PYLIBVER='python${PYTHON_BASEVERSION}' PYINC='${STAGING_INCDIR}/$(PYLIBVER)' STDINC='${STAGING_INCDIR}'"
28
29SUMMARY_audispd-plugins = "Plugins for the audit event dispatcher"
30DESCRIPTION_audispd-plugins = "The audispd-plugins package provides plugins for the real-time \
31interface to the audit system, audispd. These plugins can do things \
32like relay events to remote machines or analyze events for suspicious \
33behavior."
34
35PACKAGES =+ "audispd-plugins ${PN}-libs"
36PACKAGES += "${PN}-python"
37
38FILES_${PN}-libs += "${sysconfdir}/libaudit.conf ${libdir}/libaudit.so.1* ${libdir}/libauparse.so.*"
39FILES_${PN} += "${bindir} ${sbindir}"
40FILES_audispd-plugins += "${sysconfdir}/audisp ${sbindir}/audisp*"
41FILES_${PN}-dbg += "${libdir}/python${PYTHON_BASEVERSION}/*/.debug"
42FILES_${PN}-python = "${libdir}/python${PYTHON_BASEVERSION}"
43
44
45# The executables in lib/, which are named as gen_*_h, will run on the hosts to create
46# *_tables.h/*tabs.h header files for the targets.
47# In some old hosts, build will fail because audit.h in the old linux-libc-headers (<= 2.6.29)
48# has a incomplete netlink message list for the audit system.
49do_compile_prepend() {
50 mkdir -p ${S}/lib/linux
51 cp -f ${STAGING_INCDIR}/linux/audit.h ${S}/lib/linux/
52 cp -f ${STAGING_INCDIR}/linux/elf-em.h ${S}/lib/linux/
53}
54
55do_install_append() {
56 rm -f ${D}/${libdir}/python${PYTHON_BASEVERSION}/site-packages/*.a
57 rm -f ${D}/${libdir}/python${PYTHON_BASEVERSION}/site-packages/*.la
58}