summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-ipy_0.81.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python-ipy_0.81.bb')
-rw-r--r--recipes-devtools/python/python-ipy_0.81.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-ipy_0.81.bb b/recipes-devtools/python/python-ipy_0.81.bb
new file mode 100644
index 0000000..3ce66a7
--- /dev/null
+++ b/recipes-devtools/python/python-ipy_0.81.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Python module for handling IPv4 and IPv6 Addresses and Networks"
2DESCRIPTION = "IPy is a Python module for handling IPv4 and IPv6 Addresses and Networks \
3in a fashion similar to perl's Net::IP and friends. The IP class allows \
4a comfortable parsing and handling for most notations in use for IPv4 \
5and IPv6 Addresses and Networks."
6SECTION = "devel/python"
7HOMEPAGE = "https://github.com/haypo/python-ipy"
8DEPENDS = "python"
9LICENSE = "BSD"
10LIC_FILES_CHKSUM = "file://COPYING;md5=ebc0028ff5cdaf7796604875027dcd55"
11
12SRC_URI = "http://pypi.python.org/packages/source/I/IPy/IPy-${PV}.tar.gz"
13
14SRC_URI[md5sum] = "7a305c0b60950a9a90c89e9a6f9e06f4"
15SRC_URI[sha256sum] = "4bc17a9b5e72e893a034e77193b82c2bc321ddf8d8c345281f2bb81bb007b939"
16
17S = "${WORKDIR}/IPy-${PV}"
18
19inherit distutils
20
21# need to export these variables for python-config to work
22export BUILD_SYS
23export HOST_SYS
24export STAGING_INCDIR
25export STAGING_LIBDIR
26
27BBCLASSEXTEND = "native"
28
29do_install_append() {
30 install -d ${D}/${datadir}/doc/${BPN}-${PV}
31 install AUTHORS COPYING ChangeLog PKG-INFO README ${D}/${datadir}/doc/${BPN}-${PV}
32}