summaryrefslogtreecommitdiffstats
path: root/recipes-security/setools/setools_4.4.1.bb
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2023-02-23 09:44:00 +0800
committerJoe MacDonald <joe@deserted.net>2023-03-06 11:04:54 -0500
commit1e6a19762e60b52f3274e9629c6f86c0bba654fb (patch)
tree3d76c3d9f0f266924ac1c372fd5f1e1f95683e27 /recipes-security/setools/setools_4.4.1.bb
parent4aed1e830c05520c1798e03f27fdd6641ab4808f (diff)
downloadmeta-selinux-1e6a19762e60b52f3274e9629c6f86c0bba654fb.tar.gz
setools: upgrade 4.4.0 -> 4.4.1
Changelog: https://github.com/SELinuxProject/setools/releases/tag/4.4.1 License-Update: Refine COPYING text. No license changes.[1] [1] https://github.com/SELinuxProject/setools/commit/fff1906ff436835108b62bf46616e19705183dfb Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Joe MacDonald <joe@deserted.net>
Diffstat (limited to 'recipes-security/setools/setools_4.4.1.bb')
-rw-r--r--recipes-security/setools/setools_4.4.1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes-security/setools/setools_4.4.1.bb b/recipes-security/setools/setools_4.4.1.bb
new file mode 100644
index 0000000..8ed8f19
--- /dev/null
+++ b/recipes-security/setools/setools_4.4.1.bb
@@ -0,0 +1,38 @@
1SUMMARY = "Policy analysis tools for SELinux"
2DESCRIPTION = "\
3SETools is a collection of graphical tools, command-line tools, and \
4libraries designed to facilitate SELinux policy analysis."
5SECTION = "base"
6LICENSE = "GPL-2.0-only & LGPL-2.1-only"
7
8SRC_URI = "git://github.com/SELinuxProject/${BPN}.git;branch=4.4;protocol=https \
9 file://setools4-fixes-for-cross-compiling.patch \
10 "
11SRCREV = "bec5c81d4fc41c45c63f0ba19f132fab94f8d2e5"
12
13LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=69a7b68f0a4a570d7c0c43465333ecbc \
14 file://${S}/COPYING.GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
15 file://${S}/COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c"
16
17S = "${WORKDIR}/git"
18
19DEPENDS = "python3-cython-native libsepol libselinux"
20
21RDEPENDS:${PN} = "python3-networkx python3-setuptools \
22 python3-logging libselinux-python"
23
24RPROVIDES:${PN} = "${PN}-console"
25
26inherit setuptools3
27
28do_install:prepend() {
29 sed -i -e 's:${RECIPE_SYSROOT}::g' ${S}/setools/policyrep.c
30}
31
32do_install:append() {
33 # Need PyQt5 support, disable gui tools
34 rm -f ${D}${bindir}/apol
35 rm -rf ${D}${libdir}/${PYTHON_DIR}/site-packages/setoolsgui
36 rm -rf ${D}${libdir}/${PYTHON_DIR}/site-packages/setools/__pycache__
37 rm -rf ${D}${libdir}/${PYTHON_DIR}/site-packages/setools/*/__pycache__
38}