summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2021-01-07 11:43:29 +0800
committerJoe MacDonald <joe@deserted.net>2021-01-14 07:12:07 -0500
commitf01787d62766166fc006ec6104417788bdba97c4 (patch)
tree15e3ec170504cfed6161b31591e77a46458c95d8
parentfb15056ff44318d7886fd0f68e2f6dba716e9be4 (diff)
downloadmeta-selinux-f01787d62766166fc006ec6104417788bdba97c4.tar.gz
audit: enable arm/aarch64 processor support by default
We encountered a runtime error for auditctl on lib32 image for aarch64: root@xilinx-zynqmp:~# auditctl -a always,exit -F arch=b32 -S adjtimex -k TEST-time-change arch elf mapping not found The root cause is the aarch64 processor support is not enabled for arm build. Refer to Debian[1] and Fedora[2], actually we can enable arm/aarch64 processor support unconditionally. [1] https://salsa.debian.org/debian/audit/-/commit/8c6b2049bafb52712ca981e73d5b79d5bd97e08e [2] https://src.fedoraproject.org/rpms/audit/blob/master/f/audit.spec Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Joe MacDonald <joe@deserted.net>
-rw-r--r--recipes-security/audit/audit_2.8.5.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-security/audit/audit_2.8.5.bb b/recipes-security/audit/audit_2.8.5.bb
index e3e5ddd..e2e0352 100644
--- a/recipes-security/audit/audit_2.8.5.bb
+++ b/recipes-security/audit/audit_2.8.5.bb
@@ -41,9 +41,9 @@ EXTRA_OECONF += "--without-prelude \
41 --without-python \ 41 --without-python \
42 --without-golang \ 42 --without-golang \
43 --disable-zos-remote \ 43 --disable-zos-remote \
44 --with-arm=yes \
45 --with-aarch64=yes \
44 " 46 "
45EXTRA_OECONF_append_arm = " --with-arm=yes"
46EXTRA_OECONF_append_aarch64 = " --with-aarch64=yes"
47 47
48EXTRA_OEMAKE += "PYLIBVER='python${PYTHON_BASEVERSION}' \ 48EXTRA_OEMAKE += "PYLIBVER='python${PYTHON_BASEVERSION}' \
49 PYINC='${STAGING_INCDIR}/$(PYLIBVER)' \ 49 PYINC='${STAGING_INCDIR}/$(PYLIBVER)' \