summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2022-08-28 10:29:34 +0800
committerJoe MacDonald <joe@deserted.net>2022-08-28 13:54:59 -0400
commit6683a43e618b8cf2dc8905a38a593ec9c164f233 (patch)
treed7f361a40d54411998f56a1dc6111d86b5389508
parent02cf8bb65a64adc2e55f8a90fafc4065fb0b9b2c (diff)
downloadmeta-selinux-6683a43e618b8cf2dc8905a38a593ec9c164f233.tar.gz
setools: fix buildpaths issue
Fixes: QA Issue: File /usr/src/debug/setools/4.4.0-r0/setools/policyrep.c in package setools-src contains reference to TMPDIR [buildpaths] Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Joe MacDonald <joe@deserted.net>
-rw-r--r--recipes-security/setools/setools_4.4.0.bb33
1 files changed, 17 insertions, 16 deletions
diff --git a/recipes-security/setools/setools_4.4.0.bb b/recipes-security/setools/setools_4.4.0.bb
index f1557b1..81b0bfb 100644
--- a/recipes-security/setools/setools_4.4.0.bb
+++ b/recipes-security/setools/setools_4.4.0.bb
@@ -1,37 +1,38 @@
1SUMMARY = "Policy analysis tools for SELinux" 1SUMMARY = "Policy analysis tools for SELinux"
2DESCRIPTION = "\ 2DESCRIPTION = "\
3SETools is a collection of graphical tools, command-line tools, and \ 3SETools is a collection of graphical tools, command-line tools, and \
4libraries designed to facilitate SELinux policy analysis. \ 4libraries designed to facilitate SELinux policy analysis."
5\n\
6This meta-package depends upon the main packages necessary to run \
7SETools."
8SECTION = "base" 5SECTION = "base"
9LICENSE = "GPL-2.0-only & LGPL-2.1-only" 6LICENSE = "GPL-2.0-only & LGPL-2.1-only"
10 7
11S = "${WORKDIR}/git"
12SRC_URI = "git://github.com/SELinuxProject/${BPN}.git;branch=4.4;protocol=https \ 8SRC_URI = "git://github.com/SELinuxProject/${BPN}.git;branch=4.4;protocol=https \
13 file://setools4-fixes-for-cross-compiling.patch \ 9 file://setools4-fixes-for-cross-compiling.patch \
14" 10 "
15
16SRCREV = "4758cdf803d93274f49cb6445cb2bab527d6549f" 11SRCREV = "4758cdf803d93274f49cb6445cb2bab527d6549f"
17 12
18LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=83a5eb6974c11f30785e90d0eeccf40c \ 13LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=83a5eb6974c11f30785e90d0eeccf40c \
19 file://${S}/COPYING.GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ 14 file://${S}/COPYING.GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
20 file://${S}/COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c" 15 file://${S}/COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c"
21 16
22DEPENDS += "bison-native flex-native swig-native python3 python3-cython-native libsepol libselinux" 17S = "${WORKDIR}/git"
18
19DEPENDS = "python3-cython-native libsepol libselinux"
23 20
24RDEPENDS:${PN} += "python3-networkx python3-decorator python3-setuptools \ 21RDEPENDS:${PN} = "python3-networkx python3-setuptools \
25 python3-logging python3-json libselinux-python" 22 python3-logging libselinux-python"
26 23
27RPROVIDES:${PN} += "${PN}-console" 24RPROVIDES:${PN} = "${PN}-console"
28 25
29inherit setuptools3 26inherit setuptools3
30 27
28do_install:prepend() {
29 sed -i -e 's:${RECIPE_SYSROOT}::g' ${S}/setools/policyrep.c
30}
31
31do_install:append() { 32do_install:append() {
32 # Need PyQt5 support, disable gui tools 33 # Need PyQt5 support, disable gui tools
33 rm -f ${D}${bindir}/apol 34 rm -f ${D}${bindir}/apol
34 rm -rf ${D}${libdir}/${PYTHON_DIR}/site-packages/setoolsgui 35 rm -rf ${D}${libdir}/${PYTHON_DIR}/site-packages/setoolsgui
35 rm -rf ${D}${libdir}/${PYTHON_DIR}/site-packages/setools/__pycache__ 36 rm -rf ${D}${libdir}/${PYTHON_DIR}/site-packages/setools/__pycache__
36 rm -rf ${D}${libdir}/${PYTHON_DIR}/site-packages/setools/*/__pycache__ 37 rm -rf ${D}${libdir}/${PYTHON_DIR}/site-packages/setools/*/__pycache__
37} 38}