summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2021-02-07 11:19:56 +0800
committerJoe MacDonald <joe@deserted.net>2021-02-18 18:33:00 -0500
commit435879ef35d68cf932b22614d8734756358d7b26 (patch)
tree83237c9d1556c385b00cec5d5ac2856d4e143518
parentdc700d01f921d338833dc5990b9d39d4e167e4b3 (diff)
downloadmeta-selinux-435879ef35d68cf932b22614d8734756358d7b26.tar.gz
e2fsprogs: remove bbappend
Remove bbappend since the misc_create_inode.c-label_rootfs.patch has been merged upstream[1]. [1] https://git.kernel.org/pub/scm/fs/ext2/e2fsprogs.git/commit/?id=7616fd6a599e44c5700c2c3a2e08979c6c5c747e Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Joe MacDonald <joe@deserted.net>
-rw-r--r--recipes-devtools/e2fsprogs/e2fsprogs_%.bbappend1
-rw-r--r--recipes-devtools/e2fsprogs/e2fsprogs_selinux.inc3
-rw-r--r--recipes-devtools/e2fsprogs/files/lib-ext2fs-ext2_ext_attr.h-add-xattr-index.patch20
-rw-r--r--recipes-devtools/e2fsprogs/files/misc_create_inode.c-label_rootfs.patch45
4 files changed, 0 insertions, 69 deletions
diff --git a/recipes-devtools/e2fsprogs/e2fsprogs_%.bbappend b/recipes-devtools/e2fsprogs/e2fsprogs_%.bbappend
deleted file mode 100644
index 7719d3b..0000000
--- a/recipes-devtools/e2fsprogs/e2fsprogs_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1require ${@bb.utils.contains('DISTRO_FEATURES', 'selinux', '${BPN}_selinux.inc', '', d)}
diff --git a/recipes-devtools/e2fsprogs/e2fsprogs_selinux.inc b/recipes-devtools/e2fsprogs/e2fsprogs_selinux.inc
deleted file mode 100644
index 9cbb7fe..0000000
--- a/recipes-devtools/e2fsprogs/e2fsprogs_selinux.inc
+++ /dev/null
@@ -1,3 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3SRC_URI += "file://misc_create_inode.c-label_rootfs.patch"
diff --git a/recipes-devtools/e2fsprogs/files/lib-ext2fs-ext2_ext_attr.h-add-xattr-index.patch b/recipes-devtools/e2fsprogs/files/lib-ext2fs-ext2_ext_attr.h-add-xattr-index.patch
deleted file mode 100644
index b87c414..0000000
--- a/recipes-devtools/e2fsprogs/files/lib-ext2fs-ext2_ext_attr.h-add-xattr-index.patch
+++ /dev/null
@@ -1,20 +0,0 @@
1Add xattr name index for xattrs with the 'security' prefix. These are defined
2in the ext(2|3|4)/xattr.h in the kernel. We use the EXT2 prefix for consistency
3with e2fslibs naming.
4
5Signed-off-by: Philip Tricca <flihp@twobit.us>
6
7Index: e2fsprogs-1.42.9/lib/ext2fs/ext2_ext_attr.h
8===================================================================
9--- e2fsprogs-1.42.9.orig/lib/ext2fs/ext2_ext_attr.h
10+++ e2fsprogs-1.42.9/lib/ext2fs/ext2_ext_attr.h
11@@ -15,6 +15,9 @@
12 /* Maximum number of references to one attribute block */
13 #define EXT2_EXT_ATTR_REFCOUNT_MAX 1024
14
15+/* Name indexes */
16+#define EXT2_XATTR_INDEX_SECURITY 6
17+
18 struct ext2_ext_attr_header {
19 __u32 h_magic; /* magic number for identification */
20 __u32 h_refcount; /* reference count */
diff --git a/recipes-devtools/e2fsprogs/files/misc_create_inode.c-label_rootfs.patch b/recipes-devtools/e2fsprogs/files/misc_create_inode.c-label_rootfs.patch
deleted file mode 100644
index 046e521..0000000
--- a/recipes-devtools/e2fsprogs/files/misc_create_inode.c-label_rootfs.patch
+++ /dev/null
@@ -1,45 +0,0 @@
1From: Philip Tricca <flihp@twobit.us>
2To: tytso@mit.edu
3Cc: liezhi.yang@windriver.com
4Date: Sat, 20 Feb 2016 18:58:58 +0000
5Subject: [PATCH] misc/create_inode.c: Copy xattrs from root directory when populating fs.
6
7When copying a file system using the -d option the xattrs from the root
8directory need to be copied before the populate_fs recusion starts.
9
10Signed-off-by: Philip Tricca <flihp@twobit.us>
11Signed-off-by: Jeremy Puhlman <jpuhlman@mvista.com>
12
13---
14 misc/create_inode.c | 8 ++++++++
15 1 file changed, 8 insertions(+)
16
17diff --git a/misc/create_inode.c b/misc/create_inode.c
18index a7b6d348..cfd15922 100644
19--- a/misc/create_inode.c
20+++ b/misc/create_inode.c
21@@ -979,6 +979,13 @@ errcode_t populate_fs2(ext2_filsys fs, ext2_ino_t parent_ino,
22 return retval;
23 }
24
25+ retval = set_inode_xattr(fs, root, source_dir);
26+ if (retval) {
27+ com_err(__func__, retval,
28+ _("while setting xattrs for \"%s\""), source_dir);
29+ goto out;
30+ }
31+
32 file_info.path_len = 0;
33 file_info.path_max_len = 255;
34 file_info.path = calloc(file_info.path_max_len, 1);
35@@ -987,6 +994,7 @@ errcode_t populate_fs2(ext2_filsys fs, ext2_ino_t parent_ino,
36 &file_info, fs_callbacks);
37
38 free(file_info.path);
39+out:
40 free(hdlinks.hdl);
41 return retval;
42 }
43--
442.11.1
45