summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2022-08-28 10:29:21 +0800
committerJoe MacDonald <joe@deserted.net>2022-08-28 13:54:57 -0400
commit3b8a799fa9cabdf891f082a53a29408ebfc49333 (patch)
tree7a66f799ac62a54396ca64b2709bf20d345908ef
parentd97c3636d27ca385c71259533d96ed9eae335524 (diff)
downloadmeta-selinux-3b8a799fa9cabdf891f082a53a29408ebfc49333.tar.gz
libselinux: upgrade 3.3 -> 3.4
Use libpcre2 instead of libpcre. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Joe MacDonald <joe@deserted.net>
-rw-r--r--recipes-security/selinux/libselinux_3.4.bb (renamed from recipes-security/selinux/libselinux_3.3.bb)7
1 files changed, 3 insertions, 4 deletions
diff --git a/recipes-security/selinux/libselinux_3.3.bb b/recipes-security/selinux/libselinux_3.4.bb
index 1144840..8009d6d 100644
--- a/recipes-security/selinux/libselinux_3.3.bb
+++ b/recipes-security/selinux/libselinux_3.4.bb
@@ -8,9 +8,9 @@ LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=84b4d2c6ef954a2d4081e775a270d0d0"
8 8
9require selinux_common.inc 9require selinux_common.inc
10 10
11inherit lib_package python3native pkgconfig 11inherit lib_package pkgconfig
12 12
13DEPENDS += "libsepol libpcre" 13DEPENDS = "libsepol libpcre2"
14DEPENDS:append:libc-musl = " fts" 14DEPENDS:append:libc-musl = " fts"
15 15
16S = "${WORKDIR}/git/libselinux" 16S = "${WORKDIR}/git/libselinux"
@@ -22,8 +22,7 @@ def get_policyconfigarch(d):
22 target = p.sub('i386',target) 22 target = p.sub('i386',target)
23 return "ARCH=%s" % (target) 23 return "ARCH=%s" % (target)
24 24
25EXTRA_OEMAKE += "${@get_policyconfigarch(d)}" 25EXTRA_OEMAKE = "${@get_policyconfigarch(d)}"
26EXTRA_OEMAKE += "LDFLAGS='${LDFLAGS} -lpcre' LIBSEPOLA='${STAGING_LIBDIR}/libsepol.a'"
27EXTRA_OEMAKE:append:libc-musl = " FTS_LDLIBS=-lfts" 26EXTRA_OEMAKE:append:libc-musl = " FTS_LDLIBS=-lfts"
28 27
29BBCLASSEXTEND = "native" 28BBCLASSEXTEND = "native"