summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2018-09-05 08:18:18 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2018-09-07 16:13:57 -0400
commit77b61a4fb685634e3e966f1c795ee0ec8bb9a2bb (patch)
tree722a3163560d5a05758261635fa8b44e221db363
parentcf7a0c932d082a4e461d7a5bcb861d8e6b8e6dbe (diff)
downloadmeta-selinux-77b61a4fb685634e3e966f1c795ee0ec8bb9a2bb.tar.gz
policycoreutils: uprev to 2.8 (20180524)
Remove unused patch: policycoreutils-loadpolicy-symlink.patch Add the following patches to change commands path for backward compatibility: policycoreutils-fix-fixfiles-install-path.patch policycoreutils-fix-fixfiles-install-path.patch Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-rw-r--r--recipes-security/selinux/policycoreutils.inc8
-rw-r--r--recipes-security/selinux/policycoreutils/policycoreutils-fix-fixfiles-install-path.patch29
-rw-r--r--recipes-security/selinux/policycoreutils/policycoreutils-fix-load_policy-install-path.patch29
-rw-r--r--recipes-security/selinux/policycoreutils/policycoreutils-loadpolicy-symlink.patch19
-rw-r--r--recipes-security/selinux/policycoreutils_2.7.bb8
-rw-r--r--recipes-security/selinux/policycoreutils_2.8.bb8
6 files changed, 70 insertions, 31 deletions
diff --git a/recipes-security/selinux/policycoreutils.inc b/recipes-security/selinux/policycoreutils.inc
index e2d44f4..e1dd45b 100644
--- a/recipes-security/selinux/policycoreutils.inc
+++ b/recipes-security/selinux/policycoreutils.inc
@@ -9,6 +9,8 @@ LICENSE = "GPLv2+"
9 9
10SRC_URI += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \ 10SRC_URI += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \
11 file://policycoreutils-fixfiles-de-bashify.patch \ 11 file://policycoreutils-fixfiles-de-bashify.patch \
12 file://policycoreutils-fix-fixfiles-install-path.patch \
13 file://policycoreutils-fix-load_policy-install-path.patch \
12 " 14 "
13 15
14PAM_SRC_URI = "file://pam.d/newrole \ 16PAM_SRC_URI = "file://pam.d/newrole \
@@ -46,7 +48,6 @@ RDEPENDS_${BPN}-semodule += "\
46 libsemanage \ 48 libsemanage \
47" 49"
48# static link to libsepol 50# static link to libsepol
49DEPENDS_${BPN}-semodule-deps += "libsepol"
50RDEPENDS_${BPN}-semodule-expand += "libsepol libselinux" 51RDEPENDS_${BPN}-semodule-expand += "libsepol libselinux"
51RDEPENDS_${BPN}-semodule-link += "libsepol libselinux" 52RDEPENDS_${BPN}-semodule-link += "libsepol libselinux"
52RDEPENDS_${BPN}-semodule-package += "libsepol libselinux" 53RDEPENDS_${BPN}-semodule-package += "libsepol libselinux"
@@ -157,7 +158,6 @@ do_compile_prepend() {
157 158
158do_install_prepend() { 159do_install_prepend() {
159 export PYTHON=python 160 export PYTHON=python
160 export SEMODULE_PATH=${sbindir} SYSTEMDDIR=${D}/${systemd_unitdir}
161 export SBINDIR="${D}/${base_sbindir}" 161 export SBINDIR="${D}/${base_sbindir}"
162} 162}
163 163
@@ -165,8 +165,8 @@ do_install_class-native() {
165 for PCU_CMD in ${PCU_NATIVE_CMDS} ; do 165 for PCU_CMD in ${PCU_NATIVE_CMDS} ; do
166 oe_runmake -C $PCU_CMD install \ 166 oe_runmake -C $PCU_CMD install \
167 DESTDIR="${D}" \ 167 DESTDIR="${D}" \
168 PREFIX="${D}/${prefix}" \ 168 PREFIX="${prefix}" \
169 SBINDIR="${D}/${base_sbindir}" 169 SBINDIR="${base_sbindir}"
170 done 170 done
171} 171}
172 172
diff --git a/recipes-security/selinux/policycoreutils/policycoreutils-fix-fixfiles-install-path.patch b/recipes-security/selinux/policycoreutils/policycoreutils-fix-fixfiles-install-path.patch
new file mode 100644
index 0000000..96d2075
--- /dev/null
+++ b/recipes-security/selinux/policycoreutils/policycoreutils-fix-fixfiles-install-path.patch
@@ -0,0 +1,29 @@
1From 0546ad883d98799972034f8e0fdc6ca2a7319b07 Mon Sep 17 00:00:00 2001
2From: Yi Zhao <yi.zhao@windriver.com>
3Date: Tue, 4 Sep 2018 14:14:45 +0800
4Subject: [PATCH] policycoreutils: fix fixfiles install path
5
6Change path from /usr/sbin to /sbin for backward compatibility
7
8Upstream-Status: Inappropriate [embedded specific]
9
10Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
11---
12 scripts/Makefile | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/scripts/Makefile b/scripts/Makefile
16index afe5dc4..f7a9e34 100644
17--- a/scripts/Makefile
18+++ b/scripts/Makefile
19@@ -1,6 +1,6 @@
20 # Installation directories.
21 PREFIX ?= /usr
22-SBINDIR ?= $(PREFIX)/sbin
23+SBINDIR ?= /sbin
24 MANDIR ?= $(PREFIX)/share/man
25
26 .PHONY: all
27--
282.7.4
29
diff --git a/recipes-security/selinux/policycoreutils/policycoreutils-fix-load_policy-install-path.patch b/recipes-security/selinux/policycoreutils/policycoreutils-fix-load_policy-install-path.patch
new file mode 100644
index 0000000..2136781
--- /dev/null
+++ b/recipes-security/selinux/policycoreutils/policycoreutils-fix-load_policy-install-path.patch
@@ -0,0 +1,29 @@
1From 46077df498b8bb54964506f03fd95390aaaaa392 Mon Sep 17 00:00:00 2001
2From: Yi Zhao <yi.zhao@windriver.com>
3Date: Tue, 4 Sep 2018 14:41:13 +0800
4Subject: [PATCH] policycoreutils: fix load_policy install path
5
6Change path from /usr/sbin to /sbin for backward compatibility
7
8Upstream-Status: Inappropriate [embedded specific]
9
10Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
11---
12 load_policy/Makefile | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/load_policy/Makefile b/load_policy/Makefile
16index 568d5d4..7fbd077 100644
17--- a/load_policy/Makefile
18+++ b/load_policy/Makefile
19@@ -1,6 +1,6 @@
20 # Installation directories.
21 PREFIX ?= /usr
22-SBINDIR ?= $(PREFIX)/sbin
23+SBINDIR ?= /sbin
24 MANDIR ?= $(PREFIX)/share/man
25 LOCALEDIR ?= $(DESTDIR)$(PREFIX)/share/locale
26
27--
282.7.4
29
diff --git a/recipes-security/selinux/policycoreutils/policycoreutils-loadpolicy-symlink.patch b/recipes-security/selinux/policycoreutils/policycoreutils-loadpolicy-symlink.patch
deleted file mode 100644
index ef9936a..0000000
--- a/recipes-security/selinux/policycoreutils/policycoreutils-loadpolicy-symlink.patch
+++ /dev/null
@@ -1,19 +0,0 @@
1policycoreutils: Patch Makefile to get load_policy symlink right
2
3Setting DESTDIR in the policycoreutils do_install creates a bad
4symlink for load_policy. This patch fixes up the Makefile to
5create the symlink relative to DESTDIR.
6
7Signed-off-by: Philip Tricca <flihp@twobit.us>
8
9--- a/load_policy/Makefile
10+++ b/load_policy/Makefile
11@@ -19,7 +19,7 @@ install: all
12 test -d $(MANDIR)/man8 || install -m 755 -d $(MANDIR)/man8
13 install -m 644 load_policy.8 $(MANDIR)/man8/
14 -mkdir -p $(USRSBINDIR)
15- -ln -sf $(SBINDIR)/load_policy $(USRSBINDIR)/load_policy
16+ -ln -sf $(subst $(DESTDIR),,$(SBINDIR))/load_policy $(USRSBINDIR)/load_policy
17
18 clean:
19 -rm -f $(TARGETS) *.o
diff --git a/recipes-security/selinux/policycoreutils_2.7.bb b/recipes-security/selinux/policycoreutils_2.7.bb
deleted file mode 100644
index 78bf031..0000000
--- a/recipes-security/selinux/policycoreutils_2.7.bb
+++ /dev/null
@@ -1,8 +0,0 @@
1include selinux_20170804.inc
2include ${BPN}.inc
3
4LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
5
6SRC_URI[md5sum] = "65311b66ae01f7b7ad7c2ea7401b68ed"
7SRC_URI[sha256sum] = "0a1b8a4a323b854981c6755ff025fe98a0f1cff307f109abb260f0490f13e4f4"
8
diff --git a/recipes-security/selinux/policycoreutils_2.8.bb b/recipes-security/selinux/policycoreutils_2.8.bb
new file mode 100644
index 0000000..85f6ff0
--- /dev/null
+++ b/recipes-security/selinux/policycoreutils_2.8.bb
@@ -0,0 +1,8 @@
1include selinux_20180524.inc
2include ${BPN}.inc
3
4LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
5
6SRC_URI[md5sum] = "da5ceb9c7e1e6f8c573731031b91cffe"
7SRC_URI[sha256sum] = "986553a235f27bee7ad7c2b7c35ea51eb2ee68e2cf03b661b1585de101bc1099"
8