summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Andryuk <jandryuk@gmail.com>2021-10-27 10:03:56 -0400
committerJoe MacDonald <joe@deserted.net>2021-11-23 12:29:30 -0500
commitd5ea35444d83859a04792c8b2b65d761a87eae09 (patch)
tree3eefb7f132e2630e7e715721dff61c125b3bf053
parent0de5dc55459c0a8eb8527ea03521af2ee5793b39 (diff)
downloadmeta-selinux-d5ea35444d83859a04792c8b2b65d761a87eae09.tar.gz
Remove e2fsprogs override
commit b2b3ea27e3e3 "e2fsprogs: Superseded by upstream." removed lib-ext2fs-ext2_ext_attr.h-add-xattr-index.patch from SRC_URI. It was no longer applied, but the file was not deleted. Do that now. e2fsprogs_%.bbappend/e2fsprogs_selinux.inc now do nothing, so remove them as well. Signed-off-by: Jason Andryuk <jandryuk@gmail.com> Signed-off-by: Joe MacDonald <joe@deserted.net>
-rw-r--r--recipes-devtools/e2fsprogs/e2fsprogs_%.bbappend1
-rw-r--r--recipes-devtools/e2fsprogs/e2fsprogs_selinux.inc1
-rw-r--r--recipes-devtools/e2fsprogs/files/lib-ext2fs-ext2_ext_attr.h-add-xattr-index.patch20
3 files changed, 0 insertions, 22 deletions
diff --git a/recipes-devtools/e2fsprogs/e2fsprogs_%.bbappend b/recipes-devtools/e2fsprogs/e2fsprogs_%.bbappend
deleted file mode 100644
index 7719d3b..0000000
--- a/recipes-devtools/e2fsprogs/e2fsprogs_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1require ${@bb.utils.contains('DISTRO_FEATURES', 'selinux', '${BPN}_selinux.inc', '', d)}
diff --git a/recipes-devtools/e2fsprogs/e2fsprogs_selinux.inc b/recipes-devtools/e2fsprogs/e2fsprogs_selinux.inc
deleted file mode 100644
index 81fe7b7..0000000
--- a/recipes-devtools/e2fsprogs/e2fsprogs_selinux.inc
+++ /dev/null
@@ -1 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
diff --git a/recipes-devtools/e2fsprogs/files/lib-ext2fs-ext2_ext_attr.h-add-xattr-index.patch b/recipes-devtools/e2fsprogs/files/lib-ext2fs-ext2_ext_attr.h-add-xattr-index.patch
deleted file mode 100644
index b87c414..0000000
--- a/recipes-devtools/e2fsprogs/files/lib-ext2fs-ext2_ext_attr.h-add-xattr-index.patch
+++ /dev/null
@@ -1,20 +0,0 @@
1Add xattr name index for xattrs with the 'security' prefix. These are defined
2in the ext(2|3|4)/xattr.h in the kernel. We use the EXT2 prefix for consistency
3with e2fslibs naming.
4
5Signed-off-by: Philip Tricca <flihp@twobit.us>
6
7Index: e2fsprogs-1.42.9/lib/ext2fs/ext2_ext_attr.h
8===================================================================
9--- e2fsprogs-1.42.9.orig/lib/ext2fs/ext2_ext_attr.h
10+++ e2fsprogs-1.42.9/lib/ext2fs/ext2_ext_attr.h
11@@ -15,6 +15,9 @@
12 /* Maximum number of references to one attribute block */
13 #define EXT2_EXT_ATTR_REFCOUNT_MAX 1024
14
15+/* Name indexes */
16+#define EXT2_XATTR_INDEX_SECURITY 6
17+
18 struct ext2_ext_attr_header {
19 __u32 h_magic; /* magic number for identification */
20 __u32 h_refcount; /* reference count */