summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2020-06-18 15:55:02 +0800
committerJoe MacDonald <joe@deserted.net>2020-07-13 19:04:46 -0400
commit7af62c91d7d00a260cf28e7908955539304d100d (patch)
treef8e77952ef19da7e84e4dac9c92cd82049c73e9a
parentdb2135de109de4f6fca3ee3e4f4796c1b9b08e10 (diff)
downloadmeta-selinux-7af62c91d7d00a260cf28e7908955539304d100d.tar.gz
checkpolicy: remove unused te_assertions
Backport a patch to remove unused te_assertions to fix the build failure on fedora 32. Fixes: | /build/tmp-glibc/hosttools/ld: policy_define.o:(.bss+0x28): multiple definition of `te_assertions'/build/tmp-glibc/hosttools/ld: policy_define.o:(.bss+0x28): multiple definition of `te_assertions'; y.tab.o:(.bss+0x18): first defined here | collect2: error: ld returned 1 exit status | make: *** [Makefile:33: checkpolicy] Error 1 Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Joe MacDonald <joe@deserted.net>
-rw-r--r--recipes-security/selinux/checkpolicy/0001-checkpolicy-remove-unused-te_assertions.patch45
-rw-r--r--recipes-security/selinux/checkpolicy_3.0.bb4
2 files changed, 49 insertions, 0 deletions
diff --git a/recipes-security/selinux/checkpolicy/0001-checkpolicy-remove-unused-te_assertions.patch b/recipes-security/selinux/checkpolicy/0001-checkpolicy-remove-unused-te_assertions.patch
new file mode 100644
index 0000000..61c301e
--- /dev/null
+++ b/recipes-security/selinux/checkpolicy/0001-checkpolicy-remove-unused-te_assertions.patch
@@ -0,0 +1,45 @@
1From 95d8f16ece96829109eb75a605b1459a25b5a6be Mon Sep 17 00:00:00 2001
2From: Ondrej Mosnacek <omosnace@redhat.com>
3Date: Thu, 23 Jan 2020 13:57:15 +0100
4Subject: [PATCH] checkpolicy: remove unused te_assertions
5
6This variable is declared in a header file, but never defined or used.
7The te_assert structure definition is only used in this declaration, so
8remove both.
9
10Upstream-Status: Backport [https://github.com/SELinuxProject/selinux/commit/4d330d0d3155211f119b3082f728ae42dcc01e96]
11
12Signed-off-by: Ondrej Mosnacek <omosnace@redhat.com>
13Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
14---
15 checkpolicy/checkpolicy.h | 14 --------------
16 1 file changed, 14 deletions(-)
17
18diff --git a/checkpolicy.h b/checkpolicy.h
19index 3868f1fa023b..f127687e72a6 100644
20--- a/checkpolicy.h
21+++ b/checkpolicy.h
22@@ -1,20 +1,6 @@
23 #ifndef _CHECKPOLICY_H_
24 #define _CHECKPOLICY_H_
25
26-#include <sepol/policydb/ebitmap.h>
27-
28-typedef struct te_assert {
29- ebitmap_t stypes;
30- ebitmap_t ttypes;
31- ebitmap_t tclasses;
32- int self;
33- sepol_access_vector_t *avp;
34- unsigned long line;
35- struct te_assert *next;
36-} te_assert_t;
37-
38-te_assert_t *te_assertions;
39-
40 extern unsigned int policyvers;
41
42 #endif
43--
442.24.1
45
diff --git a/recipes-security/selinux/checkpolicy_3.0.bb b/recipes-security/selinux/checkpolicy_3.0.bb
index 201da68..50d6217 100644
--- a/recipes-security/selinux/checkpolicy_3.0.bb
+++ b/recipes-security/selinux/checkpolicy_3.0.bb
@@ -5,3 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
5 5
6SRC_URI[md5sum] = "b7c5547b95ce855bcdc10cb8adba8223" 6SRC_URI[md5sum] = "b7c5547b95ce855bcdc10cb8adba8223"
7SRC_URI[sha256sum] = "c88c719a141dd5c1202d49c378c7f063349d630522d5e04dc6e0c53da81aa4f8" 7SRC_URI[sha256sum] = "c88c719a141dd5c1202d49c378c7f063349d630522d5e04dc6e0c53da81aa4f8"
8
9SRC_URI += "\
10 file://0001-checkpolicy-remove-unused-te_assertions.patch \
11"