summaryrefslogtreecommitdiffstats
path: root/recipes-security/xmlsec1/xmlsec1_1.2.25.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/xmlsec1/xmlsec1_1.2.25.bb')
-rw-r--r--recipes-security/xmlsec1/xmlsec1_1.2.25.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/recipes-security/xmlsec1/xmlsec1_1.2.25.bb b/recipes-security/xmlsec1/xmlsec1_1.2.25.bb
new file mode 100644
index 0000000..d351dd2
--- /dev/null
+++ b/recipes-security/xmlsec1/xmlsec1_1.2.25.bb
@@ -0,0 +1,53 @@
1SUMMARY = "XML Security Library is a C library based on LibXML2"
2DESCRIPTION = "\
3 XML Security Library is a C library based on \
4 LibXML2 and OpenSSL. The library was created with a goal to support major \
5 XML security standards "XML Digital Signature" and "XML Encryption". \
6 "
7HOMEPAGE = "http://www.aleksey.com/xmlsec/"
8DEPENDS = "libtool libxml2 libxslt openssl zlib libgcrypt gnutls nss nspr libgpg-error"
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://COPYING;md5=352791d62092ea8104f085042de7f4d0"
12
13SECTION = "libs"
14
15SRC_URI = "http://www.aleksey.com/xmlsec/download/${BP}.tar.gz \
16 file://fix-ltmain.sh.patch \
17 file://change-finding-path-of-nss.patch \
18 file://makefile-ptest.patch \
19 file://xmlsec1-examples-allow-build-in-separate-dir.patch \
20 file://run-ptest \
21 "
22
23SRC_URI[md5sum] = "dbbef1efc69e61bc4629650205a05b41"
24SRC_URI[sha256sum] = "967ca83edf25ccb5b48a3c4a09ad3405a63365576503bf34290a42de1b92fcd2"
25
26inherit autotools-brokensep ptest pkgconfig
27
28CFLAGS += "-I${STAGING_INCDIR}/nspr4 -I${STAGING_INCDIR}/nss3"
29CPPFLAGS += "-I${STAGING_INCDIR}/nspr4 -I${STAGING_INCDIR}/nss3"
30
31EXTRA_OECONF = "\
32 --with-nss=${STAGING_LIBDIR}/../.. --with-nspr=${STAGING_LIBDIR}/../.. \
33 "
34
35FILES_${PN}-dev += "${libdir}/xmlsec1Conf.sh"
36FILES_${PN}-dbg += "${PTEST_PATH}/.debug/*"
37
38RDEPENDS_${PN}-ptest += "${PN}-dev"
39INSANE_SKIP_${PN}-ptest += "dev-deps"
40
41PTEST_EXTRA_ARGS = "top_srcdir=${S} top_builddir=${B}"
42
43do_compile_ptest () {
44 oe_runmake -C ${S}/examples ${PTEST_EXTRA_ARGS} all
45}
46
47do_install_append() {
48 sed -i -e "s@${STAGING_DIR}@@g" ${D}${bindir}/xmlsec1-config
49}
50
51do_install_ptest () {
52 oe_runmake -C ${S}/examples DESTDIR=${D}${PTEST_PATH} ${PTEST_EXTRA_ARGS} install-ptest
53}