summaryrefslogtreecommitdiffstats
path: root/recipes-security/perl/libwhisker2-perl_2.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/perl/libwhisker2-perl_2.5.bb')
-rw-r--r--recipes-security/perl/libwhisker2-perl_2.5.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-security/perl/libwhisker2-perl_2.5.bb b/recipes-security/perl/libwhisker2-perl_2.5.bb
new file mode 100644
index 0000000..477f995
--- /dev/null
+++ b/recipes-security/perl/libwhisker2-perl_2.5.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "Libwhisker is a Perl module geared specificly for HTTP testing."
2
3SECTION = "libs"
4LICENSE = "Artistic-1.0 | GPL-1.0+"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=254b8e29606fce6d1c1a4c9e32354573"
7
8DEPENDS = "perl"
9
10SRC_URI = "http://sourceforge.net/projects/whisker/files/libwhisker/${PV}/libwhisker2-${PV}.tar.gz \
11 file://libwhisker2.patch"
12
13SRC_URI[md5sum] = "7cc1718dddde8f9a439d5622ae2f37eb"
14SRC_URI[sha256sum] = "f45a1cf2ad2637b29dd1b13d7221ea12e3923ea09d107ced446400f19070a42f"
15
16S = "${WORKDIR}/libwhisker2-2.5"
17
18inherit cpan-base perlnative
19
20do_install() {
21 install -d 755 ${D}${PERLLIBDIRS}/vendor_perl/${PERLVERSION}
22 install -d 755 ${D}${datadir}/perl/${PERLVERSION}
23 oe_runmake install DESTDIR=${D} INSTALLDIR=${PERLLIBDIRS}/vendor_perl/${PERLVERSION} MANDIR=${datadir}/perl/${PERLVERSION}
24}