summaryrefslogtreecommitdiffstats
path: root/recipes-security/perl/curses-perl_1.28.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/perl/curses-perl_1.28.bb')
-rw-r--r--recipes-security/perl/curses-perl_1.28.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-security/perl/curses-perl_1.28.bb b/recipes-security/perl/curses-perl_1.28.bb
new file mode 100644
index 0000000..5984ca7
--- /dev/null
+++ b/recipes-security/perl/curses-perl_1.28.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "This package contains the URI.pm module with friends. \
2The module implements the URI class. URI objects can be used to access \
3and manipulate the various components that make up these strings."
4
5SECTION = "libs"
6LICENSE = "Artistic-1.0 | GPL-1.0+"
7PR = "r0"
8
9LIC_FILES_CHKSUM = "file://README;beginline=26;endline=30;md5=0b37356c5e9e28080a3422d82af8af09"
10
11DEPENDS += "perl ncurses"
12
13SRC_URI = "http://www.cpan.org/authors/id/G/GI/GIRAFFED/Curses-1.28.tgz"
14
15SRC_URI[md5sum] = "ed9f7ddf2d90f4266da91c3dc9fad9c9"
16SRC_URI[sha256sum] = "613b73c4b6075b1550592812214e4fc0e2205d3afcf234e3fa90f208fb8de892"
17
18S = "${WORKDIR}/Curses-${PV}"
19
20EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
21
22inherit cpan
23
24do_compile() {
25 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
26 cpan_do_compile
27}