summaryrefslogtreecommitdiffstats
path: root/recipes-security/nmap/files/nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/nmap/files/nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch')
-rw-r--r--recipes-security/nmap/files/nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch48
1 files changed, 0 insertions, 48 deletions
diff --git a/recipes-security/nmap/files/nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch b/recipes-security/nmap/files/nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch
deleted file mode 100644
index cfe043a..0000000
--- a/recipes-security/nmap/files/nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch
+++ /dev/null
@@ -1,48 +0,0 @@
1[PATCH] replace "./shtool mkdir" with coreutils mkdir command
2
3Upstream-Status: Pending
4
5"./shtool mkdir" is used when mkdir has not -p parameter, but mkdir in today
6most release has supportted the -p parameter, not need to use shtool, and it
7can not fix the race if two process are running mkdir to create same dir
8
9Signed-off-by: Roy Li <rongqing.li@windriver.com>
10---
11 ncat/Makefile.in | 4 ++--
12 nmap-update/Makefile.in | 2 +-
13 2 files changed, 3 insertions(+), 3 deletions(-)
14
15diff --git a/ncat/Makefile.in b/ncat/Makefile.in
16index cfd306d..2166e08 100644
17--- a/ncat/Makefile.in
18+++ b/ncat/Makefile.in
19@@ -163,11 +163,11 @@ $(NSOCKDIR)/libnsock.a: $(NSOCKDIR)/Makefile
20
21 install: $(TARGET)
22 @echo Installing Ncat;
23- $(SHTOOL) mkdir -f -p -m 755 $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1
24+ mkdir -p -m 755 $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1
25 $(INSTALL) -c -m 755 ncat $(DESTDIR)$(bindir)/ncat
26 $(STRIP) -x $(DESTDIR)$(bindir)/ncat
27 if [ -n "$(DATAFILES)" ]; then \
28- $(SHTOOL) mkdir -f -p -m 755 $(DESTDIR)$(pkgdatadir); \
29+ mkdir -p -m 755 $(DESTDIR)$(pkgdatadir); \
30 $(INSTALL) -c -m 644 $(DATAFILES) $(DESTDIR)$(pkgdatadir)/; \
31 fi
32 $(INSTALL) -c -m 644 docs/$(TARGET).1 $(DESTDIR)$(mandir)/man1/$(TARGET).1
33diff --git a/nmap-update/Makefile.in b/nmap-update/Makefile.in
34index 89ff928..93f48d8 100644
35--- a/nmap-update/Makefile.in
36+++ b/nmap-update/Makefile.in
37@@ -37,7 +37,7 @@ $(NBASELIB):
38 cd $(NBASEDIR) && $(MAKE)
39
40 install: nmap-update
41- $(SHTOOL) mkdir -f -p -m 755 $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1
42+ mkdir -p -m 755 $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1
43 $(INSTALL) -c -m 755 nmap-update $(DESTDIR)$(bindir)
44 $(STRIP) -x $(DESTDIR)$(bindir)/nmap-update
45 $(INSTALL) -c -m 644 ../docs/nmap-update.1 $(DESTDIR)$(mandir)/man1/
46--
471.9.1
48