summaryrefslogtreecommitdiffstats
path: root/recipes-security/libseccomp/libseccomp.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/libseccomp/libseccomp.bb')
-rw-r--r--recipes-security/libseccomp/libseccomp.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes-security/libseccomp/libseccomp.bb b/recipes-security/libseccomp/libseccomp.bb
new file mode 100644
index 0000000..b197fca
--- /dev/null
+++ b/recipes-security/libseccomp/libseccomp.bb
@@ -0,0 +1,45 @@
1SUMMARY = "interface to seccomp filtering mechanism"
2DESCRIPTION = "The libseccomp library provides and easy to use, platform independent,interface to the Linux Kernel's syscall filtering mechanism: seccomp."
3SECTION = "security"
4LICENSE = "LGPL-2.1"
5LIC_FILES_CHKSUM = "file://LICENSE;beginline=0;endline=1;md5=8eac08d22113880357ceb8e7c37f989f"
6
7SRCREV = "7f3ae6e6a12390bd38f0787b242f60c47ad076c3"
8
9PV = "2.2.3+git${SRCPV}"
10
11SRC_URI = "git://github.com/seccomp/libseccomp.git \
12 "
13
14S = "${WORKDIR}/git"
15
16inherit autotools-brokensep pkgconfig
17
18PACKAGECONFIG ??= ""
19PACKAGECONFIG[python] = "--enable-python, --disable-python, python"
20
21do_compile_append() {
22 oe_runmake -C tests check-build
23}
24
25do_install_append() {
26 install -d ${D}/${libdir}/${PN}/tests
27 install -d ${D}/${libdir}/${PN}/tools
28 for file in $(find tests/* -executable -type f); do
29 install -m 744 ${S}/${file} ${D}/${libdir}/${PN}/tests
30 done
31 for file in $(find tests/*.tests -type f); do
32 install -m 744 ${S}/${file} ${D}/${libdir}/${PN}/tests
33 done
34 for file in $(find tools/* -executable -type f); do
35 install -m 744 ${S}/${file} ${D}/${libdir}/${PN}/tools
36 done
37}
38
39PACKAGES += " ${PN}-tests"
40FILES_${PN} = "${bindir} ${libdir}/${PN}.so*"
41FILES_${PN}-tests = "${libdir}/${PN}/tools ${libdir}/${PN}/tests"
42FILES_${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug"
43
44RDEPENDS_${PN} = "bash"
45RDEPENDS_${PN}-tests = "bash"