summaryrefslogtreecommitdiffstats
path: root/recipes-security/clamav/clamav-0.98.5/0010-hardcode-LLVM-linker-flag-because-llvm-config-return.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/clamav/clamav-0.98.5/0010-hardcode-LLVM-linker-flag-because-llvm-config-return.patch')
-rw-r--r--recipes-security/clamav/clamav-0.98.5/0010-hardcode-LLVM-linker-flag-because-llvm-config-return.patch26
1 files changed, 0 insertions, 26 deletions
diff --git a/recipes-security/clamav/clamav-0.98.5/0010-hardcode-LLVM-linker-flag-because-llvm-config-return.patch b/recipes-security/clamav/clamav-0.98.5/0010-hardcode-LLVM-linker-flag-because-llvm-config-return.patch
deleted file mode 100644
index 9699b50..0000000
--- a/recipes-security/clamav/clamav-0.98.5/0010-hardcode-LLVM-linker-flag-because-llvm-config-return.patch
+++ /dev/null
@@ -1,26 +0,0 @@
1From 86ebd6e3f8fa60d0bdbed10eb10c5a7699b821e4 Mon Sep 17 00:00:00 2001
2From: Andreas Cadhalpun <Andreas.Cadhalpun@googlemail.com>
3Date: Mon, 25 Aug 2014 22:54:37 +0200
4Subject: hardcode LLVM linker flag, because llvm-config returns only flags for
5 linking statically
6
7this reduces the size of libclamav by more than 80 percent
8---
9 libclamav/c++/configure.ac | 4 ++--
10 1 file changed, 2 insertions(+), 2 deletions(-)
11
12diff --git a/libclamav/c++/configure.ac b/libclamav/c++/configure.ac
13index a6697ddd8e82..3c7c7e26fbf8 100644
14--- a/libclamav/c++/configure.ac
15+++ b/libclamav/c++/configure.ac
16@@ -121,8 +121,8 @@ if test "x$llvmconfig" != "x"; then
17 else
18 AC_SUBST(LLVMCONFIG_LDFLAGS, [`$llvmconfig --ldflags`])
19 fi
20- AC_SUBST(LLVMCONFIG_LIBS, [`$llvmconfig --libs jit nativecodegen scalaropts ipo`])
21- AC_SUBST(LLVMCONFIG_LIBFILES, [`$llvmconfig --libfiles jit nativecodegen scalaropts ipo`])
22+ AC_SUBST(LLVMCONFIG_LIBS, [-lLLVM-$llvmver])
23+ AC_SUBST(LLVMCONFIG_LIBFILES, [])
24 AC_MSG_NOTICE([CXXFLAGS from llvm-config: $LLVMCONFIG_CXXFLAGS])
25 AC_MSG_NOTICE([LDFLAGS from llvm-config: $LLVMCONFIG_LDFLAGS])
26 AC_MSG_NOTICE([LIBS from llvm-config: $LLVMCONFIG_LIBS])