summaryrefslogtreecommitdiffstats
path: root/recipes-ids/suricata/libhtp_0.5.44.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ids/suricata/libhtp_0.5.44.bb')
-rw-r--r--recipes-ids/suricata/libhtp_0.5.44.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-ids/suricata/libhtp_0.5.44.bb b/recipes-ids/suricata/libhtp_0.5.44.bb
new file mode 100644
index 0000000..cc8285c
--- /dev/null
+++ b/recipes-ids/suricata/libhtp_0.5.44.bb
@@ -0,0 +1,27 @@
1SUMMARY = "LibHTP is a security-aware parser for the HTTP protocol and the related bits and pieces."
2
3require suricata.inc
4
5LIC_FILES_CHKSUM = "file://LICENSE;beginline=1;endline=2;md5=596ab7963a1a0e5198e5a1c4aa621843"
6
7SRC_URI = "git://github.com/OISF/libhtp.git;protocol=https;branch=0.5.x"
8SRCREV = "8bdfe7b9d04e5e948c8fbaa7472e14d884cc00af"
9
10DEPENDS = "zlib"
11
12inherit autotools-brokensep pkgconfig
13
14CFLAGS += "-D_DEFAULT_SOURCE"
15
16#S = "${WORKDIR}/suricata-${VER}/${BPN}"
17
18S = "${WORKDIR}/git"
19
20do_configure () {
21 cd ${S}
22 ./autogen.sh
23 oe_runconf
24}
25
26RDEPENDS:${PN} += "zlib"
27