summaryrefslogtreecommitdiffstats
path: root/recipes-forensic/libewf
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-forensic/libewf')
-rw-r--r--recipes-forensic/libewf/files/gcc5_fix.patch22
-rw-r--r--recipes-forensic/libewf/libewf_20140608.bb24
2 files changed, 0 insertions, 46 deletions
diff --git a/recipes-forensic/libewf/files/gcc5_fix.patch b/recipes-forensic/libewf/files/gcc5_fix.patch
deleted file mode 100644
index 0881f25..0000000
--- a/recipes-forensic/libewf/files/gcc5_fix.patch
+++ /dev/null
@@ -1,22 +0,0 @@
1Upstream Status: pending
2
3Don't use inline with gcc 5.0
4
5fixes:
6undefined reference to `libuna_unicode_character_size_to_utf8'
7
8Signed-off-by: Armin Kuster <akuster808@gmail.com>
9
10Index: libuna/libuna_inline.h
11===================================================================
12--- a/libuna/libuna_inline.h
13+++ b/libuna/libuna_inline.h
14@@ -27,7 +27,7 @@
15 #if defined( _MSC_VER )
16 #define LIBUNA_INLINE _inline
17
18-#elif defined( __BORLANDC__ ) || defined( __clang__ )
19+#elif defined( __BORLANDC__ ) || defined( __clang__ ) || ( __GNUC__ > 4 )
20 #define LIBUNA_INLINE /* inline */
21
22 #else
diff --git a/recipes-forensic/libewf/libewf_20140608.bb b/recipes-forensic/libewf/libewf_20140608.bb
deleted file mode 100644
index f7dce12..0000000
--- a/recipes-forensic/libewf/libewf_20140608.bb
+++ /dev/null
@@ -1,24 +0,0 @@
1SUMMARY = "library with support for Expert Witness Compression Format"
2LICENSE = "LGPLv3+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=58c39b26c0549f8e1bb4122173f474cd"
4
5DEPENDS = "virtual/gettext libtool"
6
7SRC_URI = "http://archive.ubuntu.com/ubuntu/pool/universe/libe/${BPN}/${BPN}_${PV}.orig.tar.gz;name=orig \
8 file://gcc5_fix.patch \
9 "
10SRC_URI[orig.md5sum] = "fdf615f23937fad8e02b60b9e3e5fb35"
11SRC_URI[orig.sha256sum] = "d14030ce6122727935fbd676d0876808da1e112721f3cb108564a4d9bf73da71"
12
13inherit autotools-brokensep pkgconfig gettext
14
15PACKAGECONFIG ??= "zlib ssl bz2"
16PACKAGECONFIG[zlib] = "--with-zlib, --without-zlib, zlib, zlib"
17PACKAGECONFIG[bz2] = "--with-bzip2, --without-bzip2, bzip2, bzip2"
18PACKAGECONFIG[ssl] = "--with-openssl, --without-openssl, openssl, openssl"
19PACKAGECONFIG[fuse] = "--with-libfuse, --without-libfuse, fuse"
20PACKAGECONFIG[python] = "--enable-python, --disable-python, python"
21
22EXTRA_OECONF += "--with-gnu-ld --disable-rpath"
23
24RDEPENDS_${PN} += " util-linux-libuuid"