summaryrefslogtreecommitdiffstats
path: root/meta-tpm
diff options
context:
space:
mode:
Diffstat (limited to 'meta-tpm')
-rw-r--r--meta-tpm/recipes-kernel/linux/linux-yocto/tpm.cfg3
-rw-r--r--meta-tpm/recipes-kernel/linux/linux-yocto/tpm2.cfg6
-rw-r--r--meta-tpm/recipes-kernel/linux/linux-yocto/tpm2.scc3
-rw-r--r--meta-tpm/recipes-kernel/linux/linux-yocto_4.%.bbappend6
4 files changed, 18 insertions, 0 deletions
diff --git a/meta-tpm/recipes-kernel/linux/linux-yocto/tpm.cfg b/meta-tpm/recipes-kernel/linux/linux-yocto/tpm.cfg
index e34b24e..8782823 100644
--- a/meta-tpm/recipes-kernel/linux/linux-yocto/tpm.cfg
+++ b/meta-tpm/recipes-kernel/linux/linux-yocto/tpm.cfg
@@ -3,3 +3,6 @@ CONFIG_TCG_TPM=y
3CONFIG_TCG_TIS_CORE=y 3CONFIG_TCG_TIS_CORE=y
4CONFIG_TCG_TIS=y 4CONFIG_TCG_TIS=y
5CONFIG_SECURITYFS=y 5CONFIG_SECURITYFS=y
6CONFIG_TCG_NSC=m
7CONFIG_TCG_ATMEL=m
8CONFIG_TCG_INFINEON=m
diff --git a/meta-tpm/recipes-kernel/linux/linux-yocto/tpm2.cfg b/meta-tpm/recipes-kernel/linux/linux-yocto/tpm2.cfg
new file mode 100644
index 0000000..a81b54d
--- /dev/null
+++ b/meta-tpm/recipes-kernel/linux/linux-yocto/tpm2.cfg
@@ -0,0 +1,6 @@
1CONFIG_HW_RANDOM_TPM=y
2CONFIG_TCG_TPM=y
3CONFIG_TCG_TIS_CORE=y
4CONFIG_TCG_TIS=y
5CONFIG_TCG_CRB=y
6CONFIG_SECURITYFS=y
diff --git a/meta-tpm/recipes-kernel/linux/linux-yocto/tpm2.scc b/meta-tpm/recipes-kernel/linux/linux-yocto/tpm2.scc
new file mode 100644
index 0000000..088148f
--- /dev/null
+++ b/meta-tpm/recipes-kernel/linux/linux-yocto/tpm2.scc
@@ -0,0 +1,3 @@
1define KFEATURE_DESCRIPTION "Enable TPM 2.0"
2
3kconf hardware tpm2.cfg
diff --git a/meta-tpm/recipes-kernel/linux/linux-yocto_4.%.bbappend b/meta-tpm/recipes-kernel/linux/linux-yocto_4.%.bbappend
index 0eebf00..cea8b1b 100644
--- a/meta-tpm/recipes-kernel/linux/linux-yocto_4.%.bbappend
+++ b/meta-tpm/recipes-kernel/linux/linux-yocto_4.%.bbappend
@@ -3,6 +3,12 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/linux-yocto:"
3# Enable tpm in kernel 3# Enable tpm in kernel
4SRC_URI_append_x86 = " \ 4SRC_URI_append_x86 = " \
5 ${@bb.utils.contains('MACHINE_FEATURES', 'tpm', 'file://tpm.scc', '', d)} \ 5 ${@bb.utils.contains('MACHINE_FEATURES', 'tpm', 'file://tpm.scc', '', d)} \
6 ${@bb.utils.contains('MACHINE_FEATURES', 'tpm2', 'file://tpm2.scc', '', d)} \
7 "
8
9SRC_URI_append_x86-64 = " \
10 ${@bb.utils.contains('MACHINE_FEATURES', 'tpm', 'file://tpm.scc', '', d)} \
11 ${@bb.utils.contains('MACHINE_FEATURES', 'tpm2', 'file://tpm2.scc', '', d)} \
6 " 12 "
7 13
8SRC_URI += " \ 14SRC_URI += " \