summaryrefslogtreecommitdiffstats
path: root/meta-tpm/recipes-tpm2/tpm2-openssl/tpm2-openssl_1.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-tpm/recipes-tpm2/tpm2-openssl/tpm2-openssl_1.1.1.bb')
-rw-r--r--meta-tpm/recipes-tpm2/tpm2-openssl/tpm2-openssl_1.1.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-tpm/recipes-tpm2/tpm2-openssl/tpm2-openssl_1.1.1.bb b/meta-tpm/recipes-tpm2/tpm2-openssl/tpm2-openssl_1.1.1.bb
new file mode 100644
index 0000000..b676871
--- /dev/null
+++ b/meta-tpm/recipes-tpm2/tpm2-openssl/tpm2-openssl_1.1.1.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Provider for integration of TPM 2.0 to OpenSSL 3.0"
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=b75785ac083d3c3ca04d99d9e4e1fbab"
4
5DEPENDS = "autoconf-archive-native tpm2-tss openssl"
6
7SRC_URI = "https://github.com/tpm2-software/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.gz"
8
9SRC_URI[sha256sum] = "5a9bb0c6c61d026272b8843cbc291b5dfa9a55c1661a513b1c980807ad2dad01"
10
11UPSTREAM_CHECK_URI = "https://github.com/tpm2-software/${BPN}/releases"
12
13inherit autotools pkgconfig
14
15do_configure:prepend() {
16 # do not extract the version number from git
17 sed -i -e 's/m4_esyscmd_s(\[git describe --tags --always --dirty\])/${PV}/' ${S}/configure.ac
18}
19
20FILES:${PN} = "\
21 ${libdir}/ossl-modules/tpm2.so"