summaryrefslogtreecommitdiffstats
path: root/README.md
diff options
context:
space:
mode:
Diffstat (limited to 'README.md')
-rw-r--r--README.md94
1 files changed, 94 insertions, 0 deletions
diff --git a/README.md b/README.md
new file mode 100644
index 0000000..2d1996b
--- /dev/null
+++ b/README.md
@@ -0,0 +1,94 @@
1Meta-security
2=============
3
4The bbappend files for some recipes (e.g. linux-yocto) in this layer need
5to have 'security' in DISTRO_FEATURES to have effect.
6To enable them, add in configuration file the following line.
7
8 DISTRO_FEATURES:append = " security"
9
10If meta-security is included, but security is not enabled as a
11distro feature a warning is printed at parse time:
12
13 You have included the meta-security layer, but
14 'security' has not been enabled in your DISTRO_FEATURES. Some bbappend files
15 and preferred version setting may not take effect.
16
17If you know what you are doing, this warning can be disabled by setting the following
18variable in your configuration:
19
20 SKIP_META_SECURITY_SANITY_CHECK = 1
21
22This layer provides security tools, hardening tools for Linux kernels
23and libraries for implementing security mechanisms.
24
25Dependencies
26============
27
28This layer depends on:
29
30 URI: git://git.openembedded.org/openembedded-core
31 branch: [same one as checked out for this layer]
32
33 URI: git://git.openembedded.org/meta-openembedded/meta-oe
34 branch: [same one as checked out for this layer]
35
36Adding the security layer to your build
37========================================
38
39In order to use this layer, you need to make the build system aware of
40it.
41
42Assuming the security layer exists at the top-level of your
43yocto build tree, you can add it to the build system by adding the
44location of the security layer to bblayers.conf, along with any
45other layers needed. e.g.:
46
47 BBLAYERS ?= " \
48 /path/to/oe-core/meta \
49 /path/to/meta-openembedded/meta-oe \
50 /path/to/layer/meta-security "
51
52Optional Dynamic layer dependancy
53======================================
54
55 URI: git://git.openembedded.org/meta-openembedded/meta-oe
56
57 URI: git://git.openembedded.org/meta-openembedded/meta-perl
58
59 URI: git://git.openembedded.org/meta-openembedded/meta-python
60
61 BBLAYERS += "/path/to/layer/meta-openembedded/meta-oe"
62 BBLAYERS += "/path/to/layer/meta-openembedded/meta-perl"
63 BBLAYERS += "/path/to/layer/meta-openembedded/meta-python"
64
65This will activate the dynamic-layer mechanism.
66
67
68
69Maintenance
70======================================
71
72Send pull requests, patches, comments or questions to yocto@lists.yoctoproject.org
73
74When sending single patches, please using something like:
75'git send-email -1 --to yocto@lists.yoctoproject.org --subject-prefix=meta-security][PATCH'
76
77These values can be set as defaults for this repository:
78
79$ git config sendemail.to yocto@lists.yoctoproject.org
80$ git config format.subjectPrefix meta-security][PATCH
81
82Now you can just do 'git send-email origin/master' to send all local patches.
83
84For pull requests, please use create-pull-request and send-pull-request.
85
86Maintainers: Armin Kuster <akuster808@gmail.com>
87
88
89License
90=======
91
92All metadata is MIT licensed unless otherwise stated. Source code included
93in tree for individual recipes is under the LICENSE stated in each recipe
94(.bb file) unless otherwise stated.