summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-security/paxctl/paxctl_0.9.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-security/paxctl/paxctl_0.9.bb b/recipes-security/paxctl/paxctl_0.9.bb
index d69219f..fb87f10 100644
--- a/recipes-security/paxctl/paxctl_0.9.bb
+++ b/recipes-security/paxctl/paxctl_0.9.bb
@@ -18,3 +18,18 @@ EXTRA_OEMAKE = "CC='${CC}' DESTDIR='${D}'"
18do_install() { 18do_install() {
19 oe_runmake install 19 oe_runmake install
20} 20}
21
22# The install target in the Makefile will fail for paxctl-native with error:
23# install -D --owner 0 --group 0 --mode a=rx paxctl .../sbin/paxctl
24# install: cannot change ownership of '.../sbin/paxctl': \
25# Operation not permitted
26# Drop '--owner 0 --group 0' to fix the issue.
27do_install_class-native() {
28 local PROG=paxctl
29 install -d ${D}${base_sbindir}
30 install -d ${D}${mandir}/man1
31 install --mode a=rx $PROG ${D}${base_sbindir}/$PROG
32 install --mode a=r $PROG.1 ${D}${mandir}/man1/$PROG.1
33}
34
35BBCLASSEXTEND = "native"