summaryrefslogtreecommitdiffstats
path: root/recipes-security/libseccomp/libseccomp.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-02-05 08:40:06 +0530
committerArmin Kuster <akuster808@gmail.com>2018-02-14 11:56:29 -0800
commit1163dcc00b8bc728c0234cacc3cf586b2a415b67 (patch)
tree55423c72f9d54d081bdf48eba371c6c09c872b87 /recipes-security/libseccomp/libseccomp.bb
parentaedbec5ea3d958c18e8cfd5dead5d37a060bfcec (diff)
downloadmeta-security-1163dcc00b8bc728c0234cacc3cf586b2a415b67.tar.gz
libseccomp: update to 2.3.3
Drop git PV for bb reciped PV. supports 4.15 kernel Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'recipes-security/libseccomp/libseccomp.bb')
-rw-r--r--recipes-security/libseccomp/libseccomp.bb44
1 files changed, 0 insertions, 44 deletions
diff --git a/recipes-security/libseccomp/libseccomp.bb b/recipes-security/libseccomp/libseccomp.bb
deleted file mode 100644
index 7b9e0e5..0000000
--- a/recipes-security/libseccomp/libseccomp.bb
+++ /dev/null
@@ -1,44 +0,0 @@
1SUMMARY = "interface to seccomp filtering mechanism"
2DESCRIPTION = "The libseccomp library provides and easy to use, platform independent,interface to the Linux Kernel's syscall filtering mechanism: seccomp."
3SECTION = "security"
4LICENSE = "LGPL-2.1"
5LIC_FILES_CHKSUM = "file://LICENSE;beginline=0;endline=1;md5=8eac08d22113880357ceb8e7c37f989f"
6
7SRCREV = "2331d104bc0cbde5f6c54e504a038e52bfe8e12d"
8
9PV = "2.3.2+git${SRCPV}"
10
11SRC_URI = "git://github.com/seccomp/libseccomp.git;branch=release-2.3 \
12 file://run-ptest \
13"
14
15S = "${WORKDIR}/git"
16
17inherit autotools-brokensep pkgconfig ptest
18
19PACKAGECONFIG ??= ""
20PACKAGECONFIG[python] = "--enable-python, --disable-python, python"
21
22do_compile_ptest() {
23 oe_runmake -C tests check-build
24}
25
26do_install_ptest() {
27 install -d ${D}${PTEST_PATH}/tests
28 install -d ${D}${PTEST_PATH}/tools
29 for file in $(find tests/* -executable -type f); do
30 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
31 done
32 for file in $(find tests/*.tests -type f); do
33 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
34 done
35 for file in $(find tools/* -executable -type f); do
36 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
37 done
38}
39
40FILES_${PN} = "${bindir} ${libdir}/${PN}.so*"
41FILES_${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug"
42
43RDEPENDS_${PN} = "bash"
44RDEPENDS_${PN}-ptest = "bash"