summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2018-04-11 11:13:31 +0800
committerArmin Kuster <akuster808@gmail.com>2018-04-13 08:18:36 -0700
commitf4293d9fe8bdf7ddf129f7386fb430c11b26adc1 (patch)
tree0474b393a411f4b3242f7036546d6dd18da342a0
parentf1e482a498b0f6b41f23d661c3278fe4d63d8bd7 (diff)
downloadmeta-security-f4293d9fe8bdf7ddf129f7386fb430c11b26adc1.tar.gz
xmlsec1: refresh patches to fix QA warning
Refresh patches with devtool command. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-security/xmlsec1/xmlsec1/change-finding-path-of-nss.patch22
-rw-r--r--recipes-security/xmlsec1/xmlsec1/fix-ltmain.sh.patch16
-rw-r--r--recipes-security/xmlsec1/xmlsec1/makefile-ptest.patch18
-rw-r--r--recipes-security/xmlsec1/xmlsec1/xmlsec1-examples-allow-build-in-separate-dir.patch10
-rw-r--r--recipes-security/xmlsec1/xmlsec1/xmlsec1-fix-a-typo-in-examples-verify3.c.patch6
5 files changed, 40 insertions, 32 deletions
diff --git a/recipes-security/xmlsec1/xmlsec1/change-finding-path-of-nss.patch b/recipes-security/xmlsec1/xmlsec1/change-finding-path-of-nss.patch
index 0f4cef9..fcc63b3 100644
--- a/recipes-security/xmlsec1/xmlsec1/change-finding-path-of-nss.patch
+++ b/recipes-security/xmlsec1/xmlsec1/change-finding-path-of-nss.patch
@@ -1,3 +1,4 @@
1From 47379747e34f952d31af028c672940ca7859ae3c Mon Sep 17 00:00:00 2001
1From: Yulong Pei <Yulong.pei@windriver.com> 2From: Yulong Pei <Yulong.pei@windriver.com>
2Date: Wed, 21 Jul 2010 22:33:43 +0800 3Date: Wed, 21 Jul 2010 22:33:43 +0800
3Subject: [PATCH] change finding path of nss and nspr 4Subject: [PATCH] change finding path of nss and nspr
@@ -6,13 +7,16 @@ Upstream-Status: Pending
6 7
7Signed-off-by: Yulong Pei <Yulong.pei@windriver.com> 8Signed-off-by: Yulong Pei <Yulong.pei@windriver.com>
8Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> 9Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com>
10
9--- 11---
10 configure.ac | 12 ++++++------ 12 configure.ac | 12 ++++++------
11 1 files changed, 6 insertions(+), 6 deletions(-) 13 1 file changed, 6 insertions(+), 6 deletions(-)
12 14
15diff --git a/configure.ac b/configure.ac
16index 3278200..6edec7d 100644
13--- a/configure.ac 17--- a/configure.ac
14+++ b/configure.ac 18+++ b/configure.ac
15@@ -618,7 +618,7 @@ 19@@ -644,7 +644,7 @@ if test "z$NSS_FOUND" = "zno" ; then
16 20
17 if test "z$with_nspr" != "z" ; then 21 if test "z$with_nspr" != "z" ; then
18 NSPR_PREFIX="$with_nspr" 22 NSPR_PREFIX="$with_nspr"
@@ -21,7 +25,7 @@ Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com>
21 if test "z$with_gnu_ld" = "zyes" ; then 25 if test "z$with_gnu_ld" = "zyes" ; then
22 NSPR_LIBS="-Wl,-rpath-link -Wl,$with_nspr/lib -L$with_nspr/lib $NSPR_LIBS_LIST" 26 NSPR_LIBS="-Wl,-rpath-link -Wl,$with_nspr/lib -L$with_nspr/lib $NSPR_LIBS_LIST"
23 else 27 else
24@@ -626,7 +626,7 @@ 28@@ -652,7 +652,7 @@ if test "z$NSS_FOUND" = "zno" ; then
25 fi 29 fi
26 NSPR_INCLUDES_FOUND="yes" 30 NSPR_INCLUDES_FOUND="yes"
27 NSPR_LIBS_FOUND="yes" 31 NSPR_LIBS_FOUND="yes"
@@ -30,7 +34,7 @@ Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com>
30 else 34 else
31 for dir in $ac_nss_inc_dir ; do 35 for dir in $ac_nss_inc_dir ; do
32 if test -f $dir/nspr/prinit.h ; then 36 if test -f $dir/nspr/prinit.h ; then
33@@ -664,7 +664,7 @@ 37@@ -690,7 +690,7 @@ if test "z$NSS_FOUND" = "zno" ; then
34 OLD_CPPFLAGS=$CPPFLAGS 38 OLD_CPPFLAGS=$CPPFLAGS
35 CPPFLAGS="$NSPR_CFLAGS" 39 CPPFLAGS="$NSPR_CFLAGS"
36 AC_EGREP_CPP(yes,[ 40 AC_EGREP_CPP(yes,[
@@ -39,7 +43,7 @@ Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com>
39 #if PR_VMAJOR >= 4 43 #if PR_VMAJOR >= 4
40 yes 44 yes
41 #endif 45 #endif
42@@ -689,7 +689,7 @@ 46@@ -715,7 +715,7 @@ if test "z$NSS_FOUND" = "zno" ; then
43 NSS_NSS_H="" 47 NSS_NSS_H=""
44 48
45 if test "z$with_nss" != "z" ; then 49 if test "z$with_nss" != "z" ; then
@@ -48,7 +52,7 @@ Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com>
48 if test "z$with_gnu_ld" = "zyes" ; then 52 if test "z$with_gnu_ld" = "zyes" ; then
49 NSS_LIBS="$NSS_LIBS -Wl,-rpath-link -Wl,$with_nss/lib -L$with_nss/lib $NSS_LIBS_LIST" 53 NSS_LIBS="$NSS_LIBS -Wl,-rpath-link -Wl,$with_nss/lib -L$with_nss/lib $NSS_LIBS_LIST"
50 else 54 else
51@@ -697,7 +697,7 @@ 55@@ -723,7 +723,7 @@ if test "z$NSS_FOUND" = "zno" ; then
52 fi 56 fi
53 NSS_INCLUDES_FOUND="yes" 57 NSS_INCLUDES_FOUND="yes"
54 NSS_LIBS_FOUND="yes" 58 NSS_LIBS_FOUND="yes"
@@ -57,9 +61,9 @@ Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com>
57 else 61 else
58 for dir in $ac_nss_inc_dir ; do 62 for dir in $ac_nss_inc_dir ; do
59 if test -f $dir/nss/nss.h ; then 63 if test -f $dir/nss/nss.h ; then
60@@ -735,7 +735,7 @@ 64@@ -761,7 +761,7 @@ if test "z$NSS_FOUND" = "zno" ; then
61 OLD_CPPFLAGS=$CPPFLAGS 65 OLD_CPPFLAGS=$CPPFLAGS
62 CPPFLAGS="$NSS_CFLAGS" 66 CPPFLAGS="$NSPR_CFLAGS $NSS_CFLAGS"
63 AC_EGREP_CPP(yes,[ 67 AC_EGREP_CPP(yes,[
64- #include <nss.h> 68- #include <nss.h>
65+ #include <nss3/nss.h> 69+ #include <nss3/nss.h>
diff --git a/recipes-security/xmlsec1/xmlsec1/fix-ltmain.sh.patch b/recipes-security/xmlsec1/xmlsec1/fix-ltmain.sh.patch
index 472f1cc..af598fe 100644
--- a/recipes-security/xmlsec1/xmlsec1/fix-ltmain.sh.patch
+++ b/recipes-security/xmlsec1/xmlsec1/fix-ltmain.sh.patch
@@ -1,3 +1,4 @@
1From 847dc52f5a50e34ee4d6e3dc2c708711747a58ca Mon Sep 17 00:00:00 2001
1From: Yulong Pei <Yulong.pei@windriver.com> 2From: Yulong Pei <Yulong.pei@windriver.com>
2Date: Thu, 21 Jan 2010 14:11:20 +0800 3Date: Thu, 21 Jan 2010 14:11:20 +0800
3Subject: [PATCH] force to use our own libtool 4Subject: [PATCH] force to use our own libtool
@@ -5,22 +6,21 @@ Subject: [PATCH] force to use our own libtool
5Upstream-Status: Inappropriate [ OE specific ] 6Upstream-Status: Inappropriate [ OE specific ]
6 7
7Signed-off-by: Yulong Pei <Yulong.pei@windriver.com> 8Signed-off-by: Yulong Pei <Yulong.pei@windriver.com>
9
8--- 10---
9 ltmain.sh | 2 +- 11 ltmain.sh | 2 +-
10 1 files changed, 1 insertions(+), 1 deletions(-) 12 1 file changed, 1 insertion(+), 1 deletion(-)
11 13
12diff --git a/ltmain.sh b/ltmain.sh 14diff --git a/ltmain.sh b/ltmain.sh
15index 147d758..a61f16b 100644
13--- a/ltmain.sh 16--- a/ltmain.sh
14+++ b/ltmain.sh 17+++ b/ltmain.sh
15@@ -1309,7 +1309,7 @@ EOF 18@@ -6969,7 +6969,7 @@ func_mode_link ()
16 dir=`$echo "X$arg" | $Xsed -e 's/^-L//'` 19 dir=$func_resolve_sysroot_result
17 # We need an absolute path. 20 # We need an absolute path.
18 case $dir in 21 case $dir in
19- [\\/]* | [A-Za-z]:[\\/]*) ;; 22- [\\/]* | [A-Za-z]:[\\/]*) ;;
20+ =* | [\\/]* | [A-Za-z]:[\\/]*) ;; 23+ =* | [\\/]* | [A-Za-z]:[\\/]*) ;;
21 *) 24 *)
22 absdir=`cd "$dir" && pwd` 25 absdir=`cd "$dir" && pwd`
23 if test -z "$absdir"; then 26 test -z "$absdir" && \
24--
251.6.4
26
diff --git a/recipes-security/xmlsec1/xmlsec1/makefile-ptest.patch b/recipes-security/xmlsec1/xmlsec1/makefile-ptest.patch
index 2a199f4..d453569 100644
--- a/recipes-security/xmlsec1/xmlsec1/makefile-ptest.patch
+++ b/recipes-security/xmlsec1/xmlsec1/makefile-ptest.patch
@@ -1,18 +1,26 @@
1From 83a1381e1d6bd1b5ec3df6f7c4bc1f4fe4f860b6 Mon Sep 17 00:00:00 2001
2From: Jackie Huang <jackie.huang@windriver.com>
3Date: Thu, 15 Jun 2017 14:44:01 +0800
4Subject: [PATCH] xmlsec1: add new recipe
5
1This enables the building of the examples directory 6This enables the building of the examples directory
2and it's installed as ptest. 7and it's installed as ptest.
3 8
4Upstream-Status: Inappropriate [ OE ptest specific ] 9Upstream-Status: Inappropriate [ OE ptest specific ]
5 10
6Signed-off-by: Jackie Huang <jackie.huang@windriver.com> 11Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
12
7--- 13---
8 examples/Makefile | 7 +++++-- 14 examples/Makefile | 12 ++++++++++--
9 1 files changed, 7 insertions(+), 0 deletions(-) 15 1 file changed, 10 insertions(+), 2 deletions(-)
10 16
17diff --git a/examples/Makefile b/examples/Makefile
18index 89b1d61..c1cbcca 100644
11--- a/examples/Makefile 19--- a/examples/Makefile
12+++ b/examples/Makefile 20+++ b/examples/Makefile
13@@ -9,9 +9,17 @@ 21@@ -8,9 +8,17 @@ PROGRAMS = \
14 xmldsigverify \ 22 decrypt1 decrypt2 decrypt3 \
15 xkms-server 23 xmldsigverify
16 24
17+ifndef CC 25+ifndef CC
18 CC = gcc 26 CC = gcc
diff --git a/recipes-security/xmlsec1/xmlsec1/xmlsec1-examples-allow-build-in-separate-dir.patch b/recipes-security/xmlsec1/xmlsec1/xmlsec1-examples-allow-build-in-separate-dir.patch
index b0ced03..8b2533e 100644
--- a/recipes-security/xmlsec1/xmlsec1/xmlsec1-examples-allow-build-in-separate-dir.patch
+++ b/recipes-security/xmlsec1/xmlsec1/xmlsec1-examples-allow-build-in-separate-dir.patch
@@ -1,4 +1,4 @@
1From ef8872185dcd05d20c93cd98317ede1913371c94 Mon Sep 17 00:00:00 2001 1From 0c38c6864e7ba8f53a657d87894f24374a6a4932 Mon Sep 17 00:00:00 2001
2From: Jackie Huang <jackie.huang@windriver.com> 2From: Jackie Huang <jackie.huang@windriver.com>
3Date: Tue, 30 Dec 2014 11:18:17 +0800 3Date: Tue, 30 Dec 2014 11:18:17 +0800
4Subject: [PATCH] examples: allow build in separate dir 4Subject: [PATCH] examples: allow build in separate dir
@@ -6,15 +6,16 @@ Subject: [PATCH] examples: allow build in separate dir
6Upstream-Status: Inappropriate [ OE specific ] 6Upstream-Status: Inappropriate [ OE specific ]
7 7
8Signed-off-by: Jackie Huang <jackie.huang@windriver.com> 8Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
9
9--- 10---
10 examples/Makefile | 6 ++++-- 11 examples/Makefile | 6 ++++--
11 1 file changed, 4 insertions(+), 2 deletions(-) 12 1 file changed, 4 insertions(+), 2 deletions(-)
12 13
13diff --git a/examples/Makefile b/examples/Makefile 14diff --git a/examples/Makefile b/examples/Makefile
14index 0d72ad7..f9bccc6 100644 15index c1cbcca..3f1bd14 100644
15--- a/examples/Makefile 16--- a/examples/Makefile
16+++ b/examples/Makefile 17+++ b/examples/Makefile
17@@ -13,8 +13,10 @@ ifndef CC 18@@ -12,8 +12,10 @@ ifndef CC
18 CC = gcc 19 CC = gcc
19 endif 20 endif
20 21
@@ -27,6 +28,3 @@ index 0d72ad7..f9bccc6 100644
27 28
28 DESTDIR = /usr/share/xmlsec1 29 DESTDIR = /usr/share/xmlsec1
29 install-ptest: 30 install-ptest:
30--
311.9.1
32
diff --git a/recipes-security/xmlsec1/xmlsec1/xmlsec1-fix-a-typo-in-examples-verify3.c.patch b/recipes-security/xmlsec1/xmlsec1/xmlsec1-fix-a-typo-in-examples-verify3.c.patch
index 0fe3fd7..5f967bb 100644
--- a/recipes-security/xmlsec1/xmlsec1/xmlsec1-fix-a-typo-in-examples-verify3.c.patch
+++ b/recipes-security/xmlsec1/xmlsec1/xmlsec1-fix-a-typo-in-examples-verify3.c.patch
@@ -1,4 +1,4 @@
1From bf1c7b17cc80a2f4dfd43f112f944f68fa5fbcd6 Mon Sep 17 00:00:00 2001 1From 1d8ae4b32bd76c19ec238f30eb9b1ee582cbe990 Mon Sep 17 00:00:00 2001
2From: Jackie Huang <jackie.huang@windriver.com> 2From: Jackie Huang <jackie.huang@windriver.com>
3Date: Fri, 2 Mar 2018 01:10:58 -0800 3Date: Fri, 2 Mar 2018 01:10:58 -0800
4Subject: [PATCH] xmlsec1: fix a typo in examples/verify3.c 4Subject: [PATCH] xmlsec1: fix a typo in examples/verify3.c
@@ -6,6 +6,7 @@ Subject: [PATCH] xmlsec1: fix a typo in examples/verify3.c
6Upstream-Status: Submitted [https://github.com/lsh123/xmlsec/pull/153] 6Upstream-Status: Submitted [https://github.com/lsh123/xmlsec/pull/153]
7 7
8Signed-off-by: Jackie Huang <jackie.huang@windriver.com> 8Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
9
9--- 10---
10 examples/verify3.c | 2 +- 11 examples/verify3.c | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-) 12 1 file changed, 1 insertion(+), 1 deletion(-)
@@ -20,6 +21,3 @@ index 2d26ae7..68f52ab 100644
20 * XML Security Library example: Verifying a file signed with X509 certificate 21 * XML Security Library example: Verifying a file signed with X509 certificate
21 * 22 *
22 * Verifies a file signed with X509 certificate. 23 * Verifies a file signed with X509 certificate.
23--
242.13.0
25