summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Draszik <adraszik@tycoint.com>2017-10-23 16:51:19 +0100
committerArmin Kuster <akuster808@gmail.com>2017-10-24 14:04:57 -0700
commitde48d57a7f22cd5129279e977fd0d871c81e818f (patch)
tree6d88dfc9fd8d25e9ede67649c994d60581c028a1
parentd9145660cc9fedb4bea17c28d0b69831a6fb4f6e (diff)
downloadmeta-security-de48d57a7f22cd5129279e977fd0d871c81e818f.tar.gz
fscryptctl: add v0.1.0
fscryptctl is a low-level tool written in C that handles raw keys and manages policies for Linux filesystem encryption [1]. For a tool that presents a higher level interface and manages metadata, key generation, key wrapping, PAM integration, and passphrase hashing, see fscrypt [2]. [1] https://lwn.net/Articles/639427 [2] https://github.com/google/fscrypt Signed-off-by: André Draszik <adraszik@tycoint.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-security/fscryptctl/fscryptctl_0.1.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-security/fscryptctl/fscryptctl_0.1.0.bb b/recipes-security/fscryptctl/fscryptctl_0.1.0.bb
new file mode 100644
index 0000000..4f0b12c
--- /dev/null
+++ b/recipes-security/fscryptctl/fscryptctl_0.1.0.bb
@@ -0,0 +1,27 @@
1SUMMARY = "low-level tool handling Linux filesystem encryption"
2DESCIPTION = "fscryptctl is a low-level tool written in C that handles raw keys and manages \
3policies for Linux filesystem encryption (https://lwn.net/Articles/639427). \
4For a tool that presents a higher level interface and manages metadata, key \
5generation, key wrapping, PAM integration, and passphrase hashing, see \
6fscrypt (https://github.com/google/fscrypt)."
7HOMEPAGE = "https://github.com/google/fscryptctl"
8SECTION = "base"
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
11
12SRCREV = "e4c4d0984dee2531897e13c32a18d5e54a2a4aa6"
13SRC_URI = "git://github.com/google/fscryptctl.git"
14
15S = "${WORKDIR}/git"
16
17do_install() {
18 oe_runmake DESTDIR=${D}${bindir} install
19}
20
21RRECOMMENDS_${PN} += "\
22 keyutils \
23 kernel-module-cbc \
24 kernel-module-cts \
25 kernel-module-ecb \
26 kernel-module-xts \
27"