summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-02-16 21:06:51 -0800
committerArmin Kuster <akuster808@gmail.com>2018-02-18 19:31:59 -0800
commitb31e6a9ed4549d3888c98e98b2bc02d3bd2e3c31 (patch)
tree144c0391e27fd15e820fc652326b5d1773d61968
parentb8909293356420d4842fffe0d63f635d5011ec27 (diff)
downloadmeta-security-b31e6a9ed4549d3888c98e98b2bc02d3bd2e3c31.tar.gz
google-authenticator-libpam: add new package
Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-security/google-authenticator-libpam/google-authenticator-libpam_1.05.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-security/google-authenticator-libpam/google-authenticator-libpam_1.05.bb b/recipes-security/google-authenticator-libpam/google-authenticator-libpam_1.05.bb
new file mode 100644
index 0000000..73b802f
--- /dev/null
+++ b/recipes-security/google-authenticator-libpam/google-authenticator-libpam_1.05.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Google Authenticator PAM module"
2HOME_PAGE = "https://github.com/google/google-authenticator-libpam"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
4LICENSE = "Apache-2.0"
5
6SRC_URI = "git://github.com/google/google-authenticator-libpam.git"
7SRCREV = "7365ed10d54393fb4c100cac063ae8edb744eac6"
8
9DEPENDS = "libpam"
10
11S = "${WORKDIR}/git"
12
13inherit autotools distro_features_check
14
15REQUIRED_DISTRO_FEATURES = "pam"
16
17PACKAGES += "pam-google-authenticator"
18FILES_pam-google-authenticator = "${libdir}/security/pam_google_authenticator.so"
19
20RDEPNEDS_pam-google-authenticator = "libpam"