summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-10-17 22:22:39 -0700
committerArmin Kuster <akuster808@gmail.com>2018-10-31 09:02:21 -0700
commit94c7e7168240b5232db5d91465e2edefe5e912bf (patch)
tree1cd3101bbc5904d0acd162286172da22a0324b6d
parent4e3e7da65714e5cb11a0870915e5f38d9be1cbff (diff)
downloadmeta-security-94c7e7168240b5232db5d91465e2edefe5e912bf.tar.gz
suricata: add ptest
Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-security/suricata/files/run-ptest3
-rw-r--r--recipes-security/suricata/suricata_4.0.5.bb6
2 files changed, 8 insertions, 1 deletions
diff --git a/recipes-security/suricata/files/run-ptest b/recipes-security/suricata/files/run-ptest
new file mode 100644
index 0000000..666ba9c
--- /dev/null
+++ b/recipes-security/suricata/files/run-ptest
@@ -0,0 +1,3 @@
1#!/bin/sh
2
3suricata -u
diff --git a/recipes-security/suricata/suricata_4.0.5.bb b/recipes-security/suricata/suricata_4.0.5.bb
index 90b4638..6c0a109 100644
--- a/recipes-security/suricata/suricata_4.0.5.bb
+++ b/recipes-security/suricata/suricata_4.0.5.bb
@@ -10,12 +10,13 @@ SRC_URI += " \
10 file://volatiles.03_suricata \ 10 file://volatiles.03_suricata \
11 file://suricata.yaml \ 11 file://suricata.yaml \
12 file://suricata.service \ 12 file://suricata.service \
13 file://run-ptest \
13 " 14 "
14 15
15SRC_URI[rules.md5sum] = "205c5e5b54e489207ed892c03ad75b33" 16SRC_URI[rules.md5sum] = "205c5e5b54e489207ed892c03ad75b33"
16SRC_URI[rules.sha256sum] = "4aa81011b246875a57181c6a0569ca887845e366904bcaf0043220f33bd69798" 17SRC_URI[rules.sha256sum] = "4aa81011b246875a57181c6a0569ca887845e366904bcaf0043220f33bd69798"
17 18
18inherit autotools-brokensep pkgconfig python-dir systemd 19inherit autotools-brokensep pkgconfig python-dir systemd ptest
19 20
20CFLAGS += "-D_DEFAULT_SOURCE" 21CFLAGS += "-D_DEFAULT_SOURCE"
21 22
@@ -28,6 +29,8 @@ EXTRA_OECONF += " --disable-debug \
28 " 29 "
29 30
30PACKAGECONFIG ??= "htp jansson file pcre yaml pcap cap-ng net nfnetlink nss nspr" 31PACKAGECONFIG ??= "htp jansson file pcre yaml pcap cap-ng net nfnetlink nss nspr"
32PACKAGECONFIG_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'unittests', '', d)}"
33
31PACKAGECONFIG[htp] = "--with-libhtp-includes=${STAGING_INCDIR} --with-libhtp-libraries=${STAGING_LIBDIR}, ,libhtp," 34PACKAGECONFIG[htp] = "--with-libhtp-includes=${STAGING_INCDIR} --with-libhtp-libraries=${STAGING_LIBDIR}, ,libhtp,"
32PACKAGECONFIG[pcre] = "--with-libpcre-includes=${STAGING_INCDIR} --with-libpcre-libraries=${STAGING_LIBDIR}, ,libpcre ," 35PACKAGECONFIG[pcre] = "--with-libpcre-includes=${STAGING_INCDIR} --with-libpcre-libraries=${STAGING_LIBDIR}, ,libpcre ,"
33PACKAGECONFIG[yaml] = "--with-libyaml-includes=${STAGING_INCDIR} --with-libyaml-libraries=${STAGING_LIBDIR}, ,libyaml ," 36PACKAGECONFIG[yaml] = "--with-libyaml-includes=${STAGING_INCDIR} --with-libyaml-libraries=${STAGING_LIBDIR}, ,libyaml ,"
@@ -42,6 +45,7 @@ PACKAGECONFIG[file] = ",,file, file"
42PACKAGECONFIG[nss] = "--with-libnss-includes=${STAGING_INCDIR} --with-libnss-libraries=${STAGING_LIBDIR}, nss, nss," 45PACKAGECONFIG[nss] = "--with-libnss-includes=${STAGING_INCDIR} --with-libnss-libraries=${STAGING_LIBDIR}, nss, nss,"
43PACKAGECONFIG[nspr] = "--with-libnspr-includes=${STAGING_INCDIR} --with-libnspr-libraries=${STAGING_LIBDIR}, nspr, nspr," 46PACKAGECONFIG[nspr] = "--with-libnspr-includes=${STAGING_INCDIR} --with-libnspr-libraries=${STAGING_LIBDIR}, nspr, nspr,"
44PACKAGECONFIG[python] = "--enable-python, --disable-python, python, python" 47PACKAGECONFIG[python] = "--enable-python, --disable-python, python, python"
48PACKAGECONFIG[unittests] = "--enable-unittests, --disable-unittests,"
45 49
46export logdir = "${localstatedir}/log" 50export logdir = "${localstatedir}/log"
47 51