summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-02-05 09:45:24 +0530
committerArmin Kuster <akuster808@gmail.com>2018-02-14 11:56:35 -0800
commit62803a0ecc68b890d7803ef319f2a6ffffd6f3c9 (patch)
treee878e9c48f973f5b2ba94be3814c6bd02b2abb17
parent181d03751aade0d414d762c84462e46d70276f71 (diff)
downloadmeta-security-62803a0ecc68b890d7803ef319f2a6ffffd6f3c9.tar.gz
scapy: update to 2.3.3
Drop patch included in update. Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-security/scapy/scapy/scapy-Pickling-issues-fixed.patch111
-rw-r--r--recipes-security/scapy/scapy_2.3.3.bb (renamed from recipes-security/scapy/scapy_2.3.2.bb)5
2 files changed, 2 insertions, 114 deletions
diff --git a/recipes-security/scapy/scapy/scapy-Pickling-issues-fixed.patch b/recipes-security/scapy/scapy/scapy-Pickling-issues-fixed.patch
deleted file mode 100644
index 9901f91..0000000
--- a/recipes-security/scapy/scapy/scapy-Pickling-issues-fixed.patch
+++ /dev/null
@@ -1,111 +0,0 @@
1From 331dff6c73f89307d108f9ae89264b9548e22dc6 Mon Sep 17 00:00:00 2001
2From: Guillaume Valadon <guillaume.valadon@ssi.gouv.fr>
3Date: Wed, 31 Aug 2016 13:59:21 +0200
4Subject: [PATCH] Pickling issues fixed
5
6Backport from:
7https://github.com/secdev/scapy/pull/284
8
9Upstream-Status: Backport
10
11Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
12---
13 scapy/layers/inet.py | 6 ++++--
14 scapy/layers/inet6.py | 4 +++-
15 scapy/layers/l2.py | 14 +++++++++-----
16 scapy/route.py | 1 -
17 4 files changed, 16 insertions(+), 9 deletions(-)
18
19diff --git a/scapy/layers/inet.py b/scapy/layers/inet.py
20index 4b66946..e35a247 100644
21--- a/scapy/layers/inet.py
22+++ b/scapy/layers/inet.py
23@@ -734,8 +734,10 @@ conf.l3types.register(ETH_P_IP, IP)
24 conf.l3types.register_num2layer(ETH_P_ALL, IP)
25
26
27-conf.neighbor.register_l3(Ether, IP, lambda l2,l3: getmacbyip(l3.dst))
28-conf.neighbor.register_l3(Dot3, IP, lambda l2,l3: getmacbyip(l3.dst))
29+def inet_register_l3(l2, l3):
30+ return getmacbyip(l3.dst)
31+conf.neighbor.register_l3(Ether, IP, inet_register_l3)
32+conf.neighbor.register_l3(Dot3, IP, inet_register_l3)
33
34
35 ###################
36diff --git a/scapy/layers/inet6.py b/scapy/layers/inet6.py
37index ba5674c..195ca9c 100644
38--- a/scapy/layers/inet6.py
39+++ b/scapy/layers/inet6.py
40@@ -474,7 +474,9 @@ class IPv6(_IPv6GuessPayload, Packet, IPTools):
41 return self.payload.answers(other.payload)
42
43
44-conf.neighbor.register_l3(Ether, IPv6, lambda l2,l3: getmacbyip6(l3.dst))
45+def inet6_register_l3(l2, l3):
46+ return getmacbyip6(l3.dst)
47+conf.neighbor.register_l3(Ether, IPv6, inet6_register_l3)
48
49
50 class IPerror6(IPv6):
51diff --git a/scapy/layers/l2.py b/scapy/layers/l2.py
52index 3d88961..47fa386 100644
53--- a/scapy/layers/l2.py
54+++ b/scapy/layers/l2.py
55@@ -183,8 +183,10 @@ class LLC(Packet):
56 XByteField("ssap", 0x00),
57 ByteField("ctrl", 0) ]
58
59-conf.neighbor.register_l3(Ether, LLC, lambda l2,l3: conf.neighbor.resolve(l2,l3.payload))
60-conf.neighbor.register_l3(Dot3, LLC, lambda l2,l3: conf.neighbor.resolve(l2,l3.payload))
61+def l2_register_l3(l2, l3):
62+ return conf.neighbor.resolve(l2, l3.payload)
63+conf.neighbor.register_l3(Ether, LLC, l2_register_l3)
64+conf.neighbor.register_l3(Dot3, LLC, l2_register_l3)
65
66
67 class CookedLinux(Packet):
68@@ -203,7 +205,7 @@ class SNAP(Packet):
69 fields_desc = [ X3BytesField("OUI",0x000000),
70 XShortEnumField("code", 0x000, ETHER_TYPES) ]
71
72-conf.neighbor.register_l3(Dot3, SNAP, lambda l2,l3: conf.neighbor.resolve(l2,l3.payload))
73+conf.neighbor.register_l3(Dot3, SNAP, l2_register_l3)
74
75
76 class Dot1Q(Packet):
77@@ -236,7 +238,7 @@ class Dot1Q(Packet):
78 return self.sprintf("802.1q (%Dot1Q.type%) vlan %Dot1Q.vlan%")
79
80
81-conf.neighbor.register_l3(Ether, Dot1Q, lambda l2,l3: conf.neighbor.resolve(l2,l3.payload))
82+conf.neighbor.register_l3(Ether, Dot1Q, l2_register_l3)
83
84 class STP(Packet):
85 name = "Spanning Tree Protocol"
86@@ -351,7 +353,9 @@ class ARP(Packet):
87 else:
88 return self.sprintf("ARP %op% %psrc% > %pdst%")
89
90-conf.neighbor.register_l3(Ether, ARP, lambda l2,l3: getmacbyip(l3.pdst))
91+def l2_register_l3_arp(l2, l3):
92+ return getmacbyip(l3.pdst)
93+conf.neighbor.register_l3(Ether, ARP, l2_register_l3_arp)
94
95 class GRErouting(Packet):
96 name = "GRE routing informations"
97diff --git a/scapy/route.py b/scapy/route.py
98index 52a9562..4bd27b7 100644
99--- a/scapy/route.py
100+++ b/scapy/route.py
101@@ -20,7 +20,6 @@ from error import Scapy_Exception,warning
102 class Route:
103 def __init__(self):
104 self.resync()
105- self.s=socket.socket(socket.AF_INET, socket.SOCK_DGRAM)
106 self.cache = {}
107
108 def invalidate_cache(self):
109--
1102.8.3
111
diff --git a/recipes-security/scapy/scapy_2.3.2.bb b/recipes-security/scapy/scapy_2.3.3.bb
index 2965c72..1c8685b 100644
--- a/recipes-security/scapy/scapy_2.3.2.bb
+++ b/recipes-security/scapy/scapy_2.3.3.bb
@@ -7,11 +7,10 @@ LIC_FILES_CHKSUM = "file://bin/scapy;beginline=9;endline=13;md5=1d5249872cc54cd4
7 7
8SRC_URI = "https://github.com/secdev/${BPN}/archive/v${PV}.tar.gz;downloadfilename=${BP}.tar.gz \ 8SRC_URI = "https://github.com/secdev/${BPN}/archive/v${PV}.tar.gz;downloadfilename=${BP}.tar.gz \
9 file://run-ptest \ 9 file://run-ptest \
10 file://scapy-Pickling-issues-fixed.patch \
11" 10"
12 11
13SRC_URI[md5sum] = "00f11df3d6b46fe6ac306efd757486f9" 12SRC_URI[md5sum] = "336d6832110efcf79ad30c9856ef5842"
14SRC_URI[sha256sum] = "1b8a86d687feb8ed01114c0c016b428674cbfec04e3eb6f5249a018c427c4f6a" 13SRC_URI[sha256sum] = "67642cf7b806e02daeddd588577588caebddc3426db7904e7999a0b0334a63b5"
15 14
16inherit setuptools ptest 15inherit setuptools ptest
17 16