summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-10-27 04:16:26 +0100
committerArmin Kuster <akuster808@gmail.com>2018-10-31 09:02:21 -0700
commit57cac8ede623f3fabbc0bbee9b1a98cf9942b536 (patch)
treec6e2c5df863241c8f989b93fe8a70f3d31c89a34
parentb15dbacb3224aab2331c0693f9c747755aa7d6c8 (diff)
downloadmeta-security-57cac8ede623f3fabbc0bbee9b1a98cf9942b536.tar.gz
swtpm: switch to stable branch and clean up recipe
Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-tpm/recipes-tpm/swtpm/swtpm_1.0.bb22
1 files changed, 5 insertions, 17 deletions
diff --git a/meta-tpm/recipes-tpm/swtpm/swtpm_1.0.bb b/meta-tpm/recipes-tpm/swtpm/swtpm_1.0.bb
index e0c5ffe..3fe1393 100644
--- a/meta-tpm/recipes-tpm/swtpm/swtpm_1.0.bb
+++ b/meta-tpm/recipes-tpm/swtpm/swtpm_1.0.bb
@@ -3,22 +3,21 @@ LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=fe8092c832b71ef20dfe4c6d3decb3a8" 3LIC_FILES_CHKSUM = "file://LICENSE;md5=fe8092c832b71ef20dfe4c6d3decb3a8"
4SECTION = "apps" 4SECTION = "apps"
5 5
6DEPENDS = "libtasn1 expect socat glib-2.0 libtpm libtpm-native" 6DEPENDS = "libtasn1 expect socat glib-2.0 net-tools-native libtpm libtpm-native"
7 7
8# configure checks for the tools already during compilation and 8# configure checks for the tools already during compilation and
9# then swtpm_setup needs them at runtime 9# then swtpm_setup needs them at runtime
10DEPENDS += "tpm-tools-native expect-native socat-native" 10DEPENDS += "tpm-tools-native expect-native socat-native"
11 11
12SRCREV = "66b42f52ef363998cb57f039889d59381d20bdf1" 12SRCREV = "94bb9f2d716d09bcc6cd2a2e033018f8592008e7"
13SRC_URI = "git://github.com/stefanberger/swtpm.git \ 13SRC_URI = "git://github.com/stefanberger/swtpm.git;branch=tpm2-preview.v2 \
14 file://fix_lib_search_path.patch \
15 file://fix_fcntl_h.patch \ 14 file://fix_fcntl_h.patch \
16 file://ioctl_h.patch \ 15 file://ioctl_h.patch \
17 " 16 "
18 17
19S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
20 19
21inherit autotools-brokensep pkgconfig 20inherit autotools pkgconfig
22PARALLEL_MAKE = "" 21PARALLEL_MAKE = ""
23 22
24TSS_USER="tss" 23TSS_USER="tss"
@@ -35,21 +34,12 @@ EXTRA_OECONF += "--with-tss-user=${TSS_USER} --with-tss-group=${TSS_GROUP}"
35 34
36export SEARCH_DIR = "${STAGING_LIBDIR_NATIVE}" 35export SEARCH_DIR = "${STAGING_LIBDIR_NATIVE}"
37 36
38# dup bootstrap
39do_configure_prepend () {
40 libtoolize --force --copy
41 autoheader
42 aclocal
43 automake --add-missing -c
44 autoconf
45}
46
47USERADD_PACKAGES = "${PN}" 37USERADD_PACKAGES = "${PN}"
48GROUPADD_PARAM_${PN} = "--system ${TSS_USER}" 38GROUPADD_PARAM_${PN} = "--system ${TSS_USER}"
49USERADD_PARAM_${PN} = "--system -g ${TSS_GROUP} --home-dir \ 39USERADD_PARAM_${PN} = "--system -g ${TSS_GROUP} --home-dir \
50 --no-create-home --shell /bin/false ${BPN}" 40 --no-create-home --shell /bin/false ${BPN}"
51 41
52RDEPENDS_${PN} = "libtpm expect socat bash" 42RDEPENDS_${PN} = "libtpm expect socat bash tpm-tools"
53 43
54BBCLASSEXTEND = "native nativesdk" 44BBCLASSEXTEND = "native nativesdk"
55 45
@@ -58,5 +48,3 @@ python() {
58 'filesystems-layer' not in d.getVar('BBFILE_COLLECTIONS').split(): 48 'filesystems-layer' not in d.getVar('BBFILE_COLLECTIONS').split():
59 raise bb.parse.SkipRecipe('Cuse enabled which requires meta-filesystems to be present.') 49 raise bb.parse.SkipRecipe('Cuse enabled which requires meta-filesystems to be present.')
60} 50}
61
62RDEPENDS_${PN} += "tpm-tools"