summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Dragomir <daniel.dragomir@windriver.com>2018-12-07 12:38:00 +0200
committerArmin Kuster <akuster808@gmail.com>2018-12-10 08:55:55 -0800
commit22c18444aa59df5c9888eb084fc6e4a6ef80681e (patch)
tree481d0322550bfc70e24a41e9a4301d21ccc19b43
parent393db42323515a65e554a6b2ed05f7ffcc958e3f (diff)
downloadmeta-security-22c18444aa59df5c9888eb084fc6e4a6ef80681e.tar.gz
tpm2.0-tss: Remove resourcemgr sub-package
Since in 2.0.x branch resourcemgr was removed as deprecated by commit 7966ef8916f79ed09eab966a58d773f413fbb67f ("Remove resourcemgr and fixup build.") and commit 0e175d36c13b1801d75ae768ac520154585326f8 ("contrib: Remove systemd service and udev rules for old resourcemgr."), remove resourcemgr sub-package with it's components. Build will fail when trying sed command on resourcemgr.service (No such file or directory). Signed-off-by: Daniel Dragomir <daniel.dragomir@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-tpm/recipes-tpm/tpm2.0-tss/tpm2.0-tss_2.0.1.bb19
1 files changed, 0 insertions, 19 deletions
diff --git a/meta-tpm/recipes-tpm/tpm2.0-tss/tpm2.0-tss_2.0.1.bb b/meta-tpm/recipes-tpm/tpm2.0-tss/tpm2.0-tss_2.0.1.bb
index 3e7b81a..9d1ff72 100644
--- a/meta-tpm/recipes-tpm/tpm2.0-tss/tpm2.0-tss_2.0.1.bb
+++ b/meta-tpm/recipes-tpm/tpm2.0-tss/tpm2.0-tss_2.0.1.bb
@@ -24,22 +24,6 @@ EXTRA_USERS_PARAMS = "\
24 groupadd tss; \ 24 groupadd tss; \
25 " 25 "
26 26
27SYSTEMD_PACKAGES = "resourcemgr"
28SYSTEMD_SERVICE_resourcemgr = "resourcemgr.service"
29SYSTEMD_AUTO_ENABLE_resourcemgr = "enable"
30
31do_patch[postfuncs] += "${@bb.utils.contains('VIRTUAL-RUNTIME_init_manager','systemd','fix_systemd_unit','', d)}"
32fix_systemd_unit () {
33 sed -i -e 's;^ExecStart=.*/resourcemgr;ExecStart=${sbindir}/resourcemgr;' ${S}/contrib/resourcemgr.service
34}
35
36do_install_append() {
37 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
38 install -d ${D}${systemd_system_unitdir}
39 install -m0644 ${S}/contrib/resourcemgr.service ${D}${systemd_system_unitdir}/resourcemgr.service
40 fi
41}
42
43PROVIDES = "${PACKAGES}" 27PROVIDES = "${PACKAGES}"
44PACKAGES = " \ 28PACKAGES = " \
45 ${PN} \ 29 ${PN} \
@@ -57,7 +41,6 @@ PACKAGES = " \
57 libtss2 \ 41 libtss2 \
58 libtss2-dev \ 42 libtss2-dev \
59 libtss2-staticdev \ 43 libtss2-staticdev \
60 resourcemgr \
61" 44"
62 45
63FILES_libtss2-tcti-device = "${libdir}/libtss2-tcti-device.so.*" 46FILES_libtss2-tcti-device = "${libdir}/libtss2-tcti-device.so.*"
@@ -89,5 +72,3 @@ FILES_libtss2-dev = " \
89FILES_libtss2-staticdev = "${libdir}/libtss*a" 72FILES_libtss2-staticdev = "${libdir}/libtss*a"
90 73
91FILES_${PN} = "${libdir}/udev" 74FILES_${PN} = "${libdir}/udev"
92
93FILES_resourcemgr = "${sbindir}/resourcemgr ${systemd_system_unitdir}/resourcemgr.service"