summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2020-01-21 21:41:20 -0800
committerArmin Kuster <akuster808@gmail.com>2020-01-21 21:41:20 -0800
commitfa8d29bffc1d8d4d44048aa72cf985b506dad68b (patch)
treef63db7473b847fa084d92235928431edebd7cda6
parent4295cfa89e63ba4cf07f08274348cedc74bdce0d (diff)
downloadmeta-security-fa8d29bffc1d8d4d44048aa72cf985b506dad68b.tar.gz
sssd: drop py2 support
Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-security/sssd/sssd_1.16.4.bb6
1 files changed, 2 insertions, 4 deletions
diff --git a/recipes-security/sssd/sssd_1.16.4.bb b/recipes-security/sssd/sssd_1.16.4.bb
index 089a99e..c381c32 100644
--- a/recipes-security/sssd/sssd_1.16.4.bb
+++ b/recipes-security/sssd/sssd_1.16.4.bb
@@ -14,7 +14,7 @@ SRC_URI = "https://releases.pagure.org/SSSD/${BPN}/${BP}.tar.gz\
14SRC_URI[md5sum] = "757bbb6f15409d8d075f4f06cb678d50" 14SRC_URI[md5sum] = "757bbb6f15409d8d075f4f06cb678d50"
15SRC_URI[sha256sum] = "6bb212cd6b75b918e945c24e7c3f95a486fb54d7f7d489a9334cfa1a1f3bf959" 15SRC_URI[sha256sum] = "6bb212cd6b75b918e945c24e7c3f95a486fb54d7f7d489a9334cfa1a1f3bf959"
16 16
17inherit autotools pkgconfig gettext python-dir features_check 17inherit autotools pkgconfig gettext python3-dir features_check
18 18
19REQUIRED_DISTRO_FEATURES = "pam" 19REQUIRED_DISTRO_FEATURES = "pam"
20 20
@@ -22,8 +22,7 @@ SSSD_UID ?= "root"
22SSSD_GID ?= "root" 22SSSD_GID ?= "root"
23 23
24CACHED_CONFIGUREVARS = "ac_cv_member_struct_ldap_conncb_lc_arg=no \ 24CACHED_CONFIGUREVARS = "ac_cv_member_struct_ldap_conncb_lc_arg=no \
25 ac_cv_path_NSUPDATE=${bindir} \ 25 ac_cv_path_NSUPDATE=${bindir} ac_cv_prog_HAVE_PYTHON3=${PYTHON_DIR} \
26 ac_cv_path_PYTHON2=${PYTHON_DIR} ac_cv_prog_HAVE_PYTHON3=${PYTHON_DIR} \
27 " 26 "
28 27
29PACKAGECONFIG ?="nss nscd" 28PACKAGECONFIG ?="nss nscd"
@@ -34,7 +33,6 @@ PACKAGECONFIG[ssh] = "--with-ssh, --with-ssh=no, "
34PACKAGECONFIG[samba] = "--with-samba, --with-samba=no, samba" 33PACKAGECONFIG[samba] = "--with-samba, --with-samba=no, samba"
35PACKAGECONFIG[selinux] = "--with-selinux, --with-selinux=no --with-semanage=no, libselinux" 34PACKAGECONFIG[selinux] = "--with-selinux, --with-selinux=no --with-semanage=no, libselinux"
36PACKAGECONFIG[manpages] = "--with-manpages, --with-manpages=no" 35PACKAGECONFIG[manpages] = "--with-manpages, --with-manpages=no"
37PACKAGECONFIG[python2] = "--with-python2-bindings, --without-python2-bindings"
38PACKAGECONFIG[python3] = "--with-python3-bindings, --without-python3-bindings" 36PACKAGECONFIG[python3] = "--with-python3-bindings, --without-python3-bindings"
39PACKAGECONFIG[nss] = "--with-crypto=nss, ,nss," 37PACKAGECONFIG[nss] = "--with-crypto=nss, ,nss,"
40PACKAGECONFIG[cyrpto] = "--with-crypto=libcrypto, , libcrypto" 38PACKAGECONFIG[cyrpto] = "--with-crypto=libcrypto, , libcrypto"