summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2019-06-10 15:24:23 +0800
committerArmin Kuster <akuster808@gmail.com>2019-06-10 07:38:28 -0700
commit4914a44e6acb53ddb9bea0ca38799b5a94ad8ef6 (patch)
treea23c8d0c232dd5d4c19ad01a7f2e553829f0f494
parent3a02e2dd1c91a055c9d996fd8f14d3dada06f150 (diff)
downloadmeta-security-4914a44e6acb53ddb9bea0ca38799b5a94ad8ef6.tar.gz
python-scapy: solved the conflict with python3-scapy
-Rename the following file to resolve the conflict with python3-scapy: Rename /usr/bin/UTscapy to /usr/bin/UTscapy2 Rename /usr/bin/scapy to /usr/bin/scapy2 Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-security/scapy/python-scapy_2.4.2.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-security/scapy/python-scapy_2.4.2.bb b/recipes-security/scapy/python-scapy_2.4.2.bb
index 98db1fd..982620e 100644
--- a/recipes-security/scapy/python-scapy_2.4.2.bb
+++ b/recipes-security/scapy/python-scapy_2.4.2.bb
@@ -4,3 +4,8 @@ require python-scapy.inc
4SRC_URI += "file://run-ptest" 4SRC_URI += "file://run-ptest"
5 5
6RDEPENDS_${PN} += "${PYTHON_PN}-subprocess" 6RDEPENDS_${PN} += "${PYTHON_PN}-subprocess"
7
8do_install_append() {
9 mv ${D}${bindir}/scapy ${D}${bindir}/scapy2
10 mv ${D}${bindir}/UTscapy ${D}${bindir}/UTscapy2
11}