summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2017-10-07 15:42:08 -0700
committerArmin Kuster <akuster808@gmail.com>2017-10-10 07:24:59 -0700
commitbc9ff10730b56f75d41ea5bfd3d2321bb62a3a71 (patch)
treeb728742129f41b2c909eb6d6b590072c609a1b4c
parent607d2bc7ddc5e13e809393d2ed5dcbc5c6bf8187 (diff)
downloadmeta-security-bc9ff10730b56f75d41ea5bfd3d2321bb62a3a71.tar.gz
swtpm: fix cuse depends
if cuse is enabled, depend on fuse which is in meta-filesystems throw error is layer is missing. Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-tpm/recipes-tpm/swtpm/swtpm_1.0.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/meta-tpm/recipes-tpm/swtpm/swtpm_1.0.bb b/meta-tpm/recipes-tpm/swtpm/swtpm_1.0.bb
index 14f668b..952de1a 100644
--- a/meta-tpm/recipes-tpm/swtpm/swtpm_1.0.bb
+++ b/meta-tpm/recipes-tpm/swtpm/swtpm_1.0.bb
@@ -3,7 +3,7 @@ LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=fe8092c832b71ef20dfe4c6d3decb3a8" 3LIC_FILES_CHKSUM = "file://LICENSE;md5=fe8092c832b71ef20dfe4c6d3decb3a8"
4SECTION = "apps" 4SECTION = "apps"
5 5
6DEPENDS = "libtasn1 fuse expect socat glib-2.0 libtpm libtpm-native" 6DEPENDS = "libtasn1 expect socat glib-2.0 libtpm libtpm-native"
7 7
8# configure checks for the tools already during compilation and 8# configure checks for the tools already during compilation and
9# then swtpm_setup needs them at runtime 9# then swtpm_setup needs them at runtime
@@ -32,7 +32,7 @@ PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux',
32PACKAGECONFIG[openssl] = "--with-openssl, --without-openssl, openssl" 32PACKAGECONFIG[openssl] = "--with-openssl, --without-openssl, openssl"
33PACKAGECONFIG[gnutls] = "--with-gnutls, --without-gnutls, gnutls" 33PACKAGECONFIG[gnutls] = "--with-gnutls, --without-gnutls, gnutls"
34PACKAGECONFIG[selinux] = "--with-selinux, --without-selinux, libselinux" 34PACKAGECONFIG[selinux] = "--with-selinux, --without-selinux, libselinux"
35PACKAGECONFIG[cuse] = "--with-cuse, --without-cuse" 35PACKAGECONFIG[cuse] = "--with-cuse, --without-cuse, fuse"
36 36
37EXTRA_OECONF += "--with-tss-user=${TSS_USER} --with-tss-group=${TSS_GROUP}" 37EXTRA_OECONF += "--with-tss-user=${TSS_USER} --with-tss-group=${TSS_GROUP}"
38 38
@@ -55,3 +55,9 @@ USERADD_PARAM_${PN} = "--system -g ${TSS_GROUP} --home-dir \
55RDEPENDS_${PN} = "libtpm expect socat bash" 55RDEPENDS_${PN} = "libtpm expect socat bash"
56 56
57BBCLASSEXTEND = "native nativesdk" 57BBCLASSEXTEND = "native nativesdk"
58
59python() {
60 if 'cuse' in d.getVar('PACKAGECONFIG') and \
61 'filesystems-layer' not in d.getVar('BBFILE_COLLECTIONS').split():
62 raise bb.parse.SkipRecipe('Cuse enabled which requires meta-filesystems to be present.')
63}